]> git.pld-linux.org Git - packages/python-pushover.git/blob - python-pushover.spec
- release 3 (by relup.sh)
[packages/python-pushover.git] / python-pushover.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  pushover
8 Summary:        Bindings for the Pushover notification service
9 Name:           python-%{module}
10 Version:        0.4
11 Release:        3
12 License:        GPL v3+
13 Group:          Libraries/Python
14 Source0:        https://github.com/Thibauth/python-pushover/archive/v%{version}.tar.gz
15 # Source0-md5:  306c1fea53917263f854cd63b17c7fa0
16 URL:            https://github.com/Thibauth/python-pushover
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.713
19 %if %{with python2}
20 BuildRequires:  python-modules
21 BuildRequires:  python-setuptools
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules
25 BuildRequires:  python3-setuptools
26 %endif
27 Requires:       python-modules
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Bindings for the Pushover notification service
33
34 %package -n python3-%{module}
35 Summary:        Bindings and command line utility for the Pushover notification service
36 Group:          Libraries/Python
37 Requires:       python3-modules
38
39 %description -n python3-%{module}
40 Bindings and command line utility for the Pushover notification
41 service.
42
43 %prep
44 %setup -q
45
46 %build
47 %if %{with python2}
48 %py_build %{?with_tests:test}
49 %endif
50
51 %if %{with python3}
52 %py3_build %{?with_tests:test}
53 %endif
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57 %if %{with python2}
58 %py_install
59 %py_postclean
60 %endif
61
62 %if %{with python3}
63 %py3_install
64 %endif
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %if %{with python2}
70 %files
71 %defattr(644,root,root,755)
72 %doc AUTHORS.rst CHANGES.rst README.rst
73 %{py_sitescriptdir}/%{module}.py[co]
74 %{py_sitescriptdir}/python_%{module}-%{version}-py*.egg-info
75 %endif
76
77 %if %{with python3}
78 %files -n python3-%{module}
79 %defattr(644,root,root,755)
80 %doc AUTHORS.rst CHANGES.rst README.rst
81 %attr(755,root,root) %{_bindir}/pushover
82 %{py3_sitescriptdir}/%{module}.py
83 %{py3_sitescriptdir}/__pycache__/%{module}.*.pyc
84 %{py3_sitescriptdir}/python_%{module}-%{version}-py*.egg-info
85 %endif
This page took 0.095458 seconds and 3 git commands to generate.