]> git.pld-linux.org Git - packages/python-pluggy.git/blob - python-pluggy.spec
9e558c45bd19a94886fc7e3bf7c46d5d2107062f
[packages/python-pluggy.git] / python-pluggy.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 %define         module  pluggy
8 Summary:        Plugin and hook calling mechanisms for Python
9 Summary(pl.UTF-8):      Mechanizmy wtyczek dla Pythona
10 Name:           python-%{module}
11 Version:        0.3.1
12 Release:        1
13 License:        MIT
14 Group:          Libraries/Python
15 Source0:        https://pypi.python.org/packages/1b/a9/6f5f80b75a8d84d21a8a13486fe26a2da9f043f93b464b2e3928be256dc4/pluggy-%{version}.tar.gz
16 # Source0-md5:  ecdd791e309f60668b66fec97c2ee7db
17 URL:            https://pypi.python.org/pypi/pluggy
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules
22 %endif
23 %if %{with python3}
24 BuildRequires:  python3-modules
25 %endif
26 Requires:       python-modules
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Plugin manager as used by pytest but stripped of pytest specific
32 details.
33
34 %description -l pl.UTF-8
35 Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
36 specyficznych dla pytest.
37
38 %package -n python3-%{module}
39 Summary:        Plugin and hook calling mechanisms for Python
40 Summary(pl.UTF-8):      Mechanizmy wtyczek dla Pythona
41 Group:          Libraries/Python
42 Requires:       python3-modules
43
44 %description -n python3-%{module}
45 Plugin manager as used by pytest but stripped of pytest specific
46 details.
47
48 %description -n python3-%{module} -l pl.UTF-8
49 Zarządca wtyczek tak jak używany przez pytest, ale pozbawiony detali
50 specyficznych dla pytest.
51
52 %package apidocs
53 Summary:        %{module} API documentation
54 Summary(pl.UTF-8):      Dokumentacja API %{module}
55 Group:          Documentation
56
57 %description apidocs
58 API documentation for %{module}.
59
60 %description apidocs -l pl.UTF-8
61 Dokumentacja API %{module}.
62
63 %prep
64 %setup -q -n %{module}-%{version}
65
66 %build
67 %if %{with python2}
68 %py_build %{?with_tests:test}
69 %endif
70
71 %if %{with python3}
72 %py3_build %{?with_tests:test}
73 %endif
74
75 %if %{with doc}
76 cd docs
77 %{__make} -j1 html
78 rm -rf _build/html/_sources
79 %endif
80
81 %install
82 rm -rf $RPM_BUILD_ROOT
83 %if %{with python2}
84 %py_install
85 %py_postclean
86 %endif
87
88 %if %{with python3}
89 %py3_install
90 %endif
91
92 %clean
93 rm -rf $RPM_BUILD_ROOT
94
95 %if %{with python2}
96 %files
97 %defattr(644,root,root,755)
98 %doc CHANGELOG README.rst
99 %{py_sitescriptdir}/%{module}.py[co]
100 %{py_sitescriptdir}/%{module}-%{version}-py*.egg-info
101 %endif
102
103 %if %{with python3}
104 %files -n python3-%{module}
105 %defattr(644,root,root,755)
106 %doc CHANGELOG README.rst
107 %{py3_sitescriptdir}/%{module}.py
108 %{py3_sitescriptdir}/__pycache__/%{module}.*.pyc
109 %{py3_sitescriptdir}/%{module}-%{version}-py*.egg-info
110 %endif
111
112 %if %{with doc}
113 %files apidocs
114 %defattr(644,root,root,755)
115 %doc docs/_build/html/*
116 %endif
This page took 0.124867 seconds and 2 git commands to generate.