]> git.pld-linux.org Git - packages/python-parallax.git/blob - python-parallax.spec
- new
[packages/python-parallax.git] / python-parallax.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 Summary:        Parallax Python 2 module - execute commands and copy files over SSH to multiple machines at once
7 Summary(pl.UTF-8):      Moduł Pythona 2 Parallax - wykonywanie poleceń i kopiowanie plików przez SSH na wielu maszynach jednocześnie
8 Name:           python-parallax
9 Version:        1.0.1
10 Release:        1
11 License:        BSD
12 Group:          Libraries/Python
13 #Source0Download: https://pypi.python.org/simple/parallax
14 Source0:        https://files.pythonhosted.org/packages/source/p/parallax/parallax-%{version}.tar.gz
15 # Source0-md5:  d8fccb7c3465c19edb4b1a1836c15b75
16 URL:            https://pypi.python.org/pypi/parallax
17 BuildRequires:  rpm-pythonprov
18 BuildRequires:  rpmbuild(macros) >= 1.714
19 BuildRequires:  sed >= 4.0
20 %if %{with python2}
21 BuildRequires:  python-modules >= 1:2.6
22 BuildRequires:  python-setuptools
23 %endif
24 %if %{with python3}
25 BuildRequires:  python3-modules >= 1:3.2
26 BuildRequires:  python3-setuptools
27 %endif
28 Requires:       python-modules >= 1:2.6
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Parallax SSH provides an interface to executing commands on multiple
34 nodes at once using SSH. It also provides commands for sending and
35 receiving files to multiple nodes using SCP.
36
37 %description -l pl.UTF-8
38 Parallax SSH udostępnia interfejs do wykonywania poleceń na wielu
39 maszynach jednocześnie przy użyciu SSH. Udostępnia także polecenia do
40 wysyłania i odbierania plików na wielu maszynach przy użyciu SCP
41
42 %package -n python3-parallax
43 Summary:        Parallax Python 3 module - execute commands and copy files over SSH to multiple machines at once
44 Summary(pl.UTF-8):      Moduł Pythona 3 Parallax - wykonywanie poleceń i kopiowanie plików przez SSH na wielu maszynach jednocześnie
45 Group:          Libraries/Python
46 Requires:       python3-modules >= 1:3.2
47
48 %description -n python3-parallax
49 Parallax SSH provides an interface to executing commands on multiple
50 nodes at once using SSH. It also provides commands for sending and
51 receiving files to multiple nodes using SCP.
52
53 %description -n python3-parallax -l pl.UTF-8
54 Parallax SSH udostępnia interfejs do wykonywania poleceń na wielu
55 maszynach jednocześnie przy użyciu SSH. Udostępnia także polecenia do
56 wysyłania i odbierania plików na wielu maszynach przy użyciu SCP
57
58 %prep
59 %setup -q -n parallax-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build
64 %{__sed} -i -e "s,'/usr/bin/parallax-askpass','/usr/bin/parallax-askpass-2'," build-2/lib/parallax/askpass_client.py
65 %endif
66
67 %if %{with python3}
68 %py3_build
69 %{__sed} -i -e "s,'/usr/bin/parallax-askpass','/usr/bin/parallax-askpass-3'," build-3/lib/parallax/askpass_client.py
70 %endif
71
72 %install
73 rm -rf $RPM_BUILD_ROOT
74
75 %if %{with python3}
76 %py3_install
77 %{__mv} $RPM_BUILD_ROOT%{_bindir}/parallax-askpass{,-3}
78 %endif
79
80 %if %{with python2}
81 %py_install
82
83 %py_postclean
84 %{__mv} $RPM_BUILD_ROOT%{_bindir}/parallax-askpass{,-2}
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %files
92 %defattr(644,root,root,755)
93 %doc AUTHORS COPYING README.md
94 %attr(755,root,root) %{_bindir}/parallax-askpass-2
95 %{py_sitescriptdir}/parallax
96 %{py_sitescriptdir}/parallax-%{version}-py*.egg-info
97 %endif
98
99 %if %{with python3}
100 %files -n python3-parallax
101 %defattr(644,root,root,755)
102 %doc AUTHORS COPYING README.md
103 %attr(755,root,root) %{_bindir}/parallax-askpass-3
104 %{py3_sitescriptdir}/parallax
105 %{py3_sitescriptdir}/parallax-%{version}-py*.egg-info
106 %endif
This page took 0.081339 seconds and 3 git commands to generate.