]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- updated to 23.1
[packages/python-numpy.git] / python-numpy.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define         module  numpy
4 %define         mname   Numeric
5
6 Summary:        Python numerical facilities
7 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
8 Name:           python-%{module}
9 Version:        23.1
10 Release:        0.1
11 License:        distributable
12 Group:          Libraries/Python
13 Source0:        http://dl.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
14 # Source0-md5:  5cd24ed20627f5cbc822a2bed8ff27e9
15 URL:            http://www.pfdubois.com/numpy/
16 BuildRequires:  python-devel >= 2.3
17 BuildRequires:  rpm-pythonprov
18 %pyrequires_eq  python
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 NumPy is a collection of extension modules to provide high-performance
23 multidimensional numeric arrays to the Python programming language.
24
25 %description -l pl
26 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
27 wielowymiarowych.
28
29 %package devel
30 Summary:        C header files for numerical modules
31 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
32 Group:          Development/Languages/Python
33 %pyrequires_eq  python
34 Requires:       %{name} = %{version}
35
36 %description devel
37 C header files for numerical modules.
38
39 %description devel -l pl
40 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
41
42 %package FFT
43 Summary:        Interface to the FFTPACK FORTRAN library
44 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
45 Group:          Libraries/Python
46 %pyrequires_eq  python
47 Requires:       %{name} = %{version}
48
49 %description FFT
50 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
51 library, which is a powerful standard library for doing fast Fourier
52 transforms of real and complex data sets.
53
54 %description FFT -l pl
55 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
56 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
57 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
58 Fouriera na liczba rzeczywistych i zespolonych.
59
60 # -- will be released as separate package
61 #%package kinds
62 #Summary:       Implementation of PEP 0242 - precision and range control of numeric computations
63 #Summary(pl):   Implementacja propozycji PEP 0242 - mo¿liwo¶æ kontrolowania precyzji i zakresu obliczeñ numerycznych
64 #Group:         Libraries/Python
65 #%pyrequires_eq python
66 #Requires:      %{name} = %{version}
67 #
68 #%description kinds
69 #This is implementation of PEP 0242. PEP's abstract follows:
70 #
71 #This proposal gives the user optional control over the precision and
72 #range of numeric computations so that a computation can be written
73 #once and run anywhere with at least the desired precision and range.
74 #It is backward compatible with existing code.
75 #
76 #%description kinds -l pl
77 #Modu³ zawiera implementacjê propozycji PEP 0242. Oto jej streszczenie.
78 #
79 #Propozycja ta umo¿liwia u¿ytkownikowi, opcjonalnie, kontrolê nad
80 #precyzj± i zakresem obliczeñ numerycznych. Dziêki temu raz napisane
81 #obliczenia mog± byæ uruchamiane na dowolnej maszynie. Mechanizm jest
82 #kompatybilny wstecz z istniej±cymi programami.
83
84 %package MA
85 Summary:        MA - a facility for dealing with masked arrays
86 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
87 Group:          Libraries/Python
88 %pyrequires_eq  python
89 Requires:       %{name} = %{version}
90
91 %description MA
92 Masked arrays are arrays that may have missing or invalid entries.
93 Module MA provides a work-alike replacement for Numeric that supports
94 data arrays with masks.
95
96 %description MA -l pl
97 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog±
98 zawieraæ niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia
99 do operowania na tego typu macierzach.
100
101 # -- removed(?)
102 #%package Properties
103 #Summary:       Property class implementation for Python
104 #Summary(pl):   Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
105 #Group:         Libraries/Python
106 #%pyrequires_eq python
107 #Requires:      %{name} = %{version}
108 #
109 #%description Properties
110 #PropertiedClass is a mixin class that can be used to emulate
111 #properties in a Python class. A property is an attribute whose read,
112 #write, or deleting requires special handling. It is also possible to
113 #use this facility to prevent the writing or deleting of a property.
114 #
115 #%description Properties -l pl
116 #PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji
117 #w³a¶ciwo¶ci w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem,
118 #którego czytanie, przypisywanie mu warto¶ci, czy te¿ jego usuwanie
119 #powinno byæ traktowane w sposób specjalny. Mechanizm ten mo¿e byæ te¿
120 #u¿ywany w celu ustalenia jakiego¶ atrybutu jako tylko do odczytu.
121
122 %package RNG
123 Summary:        Random Number Generator Object for NumPy
124 Summary(pl):    Obiekt generatora liczb losowych dla modu³u NumPy
125 Group:          Libraries/Python
126 %pyrequires_eq  python
127 Requires:       %{name} = %{version}
128
129 %description RNG
130 RNG provides a random number object to Numerical Python.
131
132 %description RNG -l pl
133 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
134 jêzyka Python.
135
136 %prep
137 %setup -q -n %{mname}-%{version}
138
139 %build
140 CC="%{__cc}"; export CC
141 CFLAGS="%{rpmcflags}"; export CFLAGS
142 python setup.py build
143
144 %install
145 rm -rf $RPM_BUILD_ROOT
146
147 python setup.py install \
148         --root=$RPM_BUILD_ROOT
149
150 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
151 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
152
153 %clean
154 rm -rf $RPM_BUILD_ROOT
155
156 %files
157 %defattr(644,root,root,755)
158 %dir %{py_sitedir}/%{mname}
159 %{py_sitedir}/%{mname}.pth
160 %attr(755,root,root) %{py_sitedir}/%{mname}/*.so
161 %{py_sitedir}/%{mname}/*.py[co]
162
163 %files devel
164 %defattr(644,root,root,755)
165 %{py_incdir}/%{mname}
166
167 %files FFT
168 %defattr(644,root,root,755)
169 %dir %{py_sitedir}/%{mname}/FFT
170 %attr(755,root,root) %{py_sitedir}/%{mname}/FFT/*.so
171 %{py_sitedir}/%{mname}/FFT/*.py[co]
172
173 #%files kinds
174 #%defattr(644,root,root,755)
175 #%dir %{py_sitedir}/%{mname}/kinds
176 #%attr(755,root,root) %{py_sitedir}/%{mname}/kinds/*.so
177 #%{py_sitedir}/%{mname}/kinds/*.py[co]
178
179 %files MA
180 %defattr(644,root,root,755)
181 %dir %{py_sitedir}/%{mname}/MA
182 %{py_sitedir}/%{mname}/MA/*.py[co]
183
184 #%files Properties
185 #%defattr(644,root,root,755)
186 #%dir %{py_sitedir}/%{mname}/PropertiedClasses
187 #%{py_sitedir}/%{mname}/PropertiedClasses/*.py[co]
188
189 %files RNG
190 %defattr(644,root,root,755)
191 %dir %{py_sitedir}/%{mname}/RNG
192 %attr(755,root,root) %{py_sitedir}/%{mname}/RNG/*.so
193 %{py_sitedir}/%{mname}/RNG/*.py[co]
This page took 0.070552 seconds and 4 git commands to generate.