]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- use py_incdir macro for python includes
[packages/python-numpy.git] / python-numpy.spec
1
2 %define module numpy
3 %define mname Numeric
4
5 Summary:        Python numerical facilities 
6 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
7 Name:           python-%{module}
8 Version:        20.2.0
9 Release:        1
10 License:        distributable
11 Group:          Development/Languages/Python
12 Group(de):      Entwicklung/Sprachen/Python
13 Group(pl):      Programowanie/Jêzyki/Python
14 Source0:        http://prdownloads.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
15 URL:            http://www.pfdubois.com/numpy/
16 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
17 %requires_eq    python
18 BuildRequires:  python-devel >= 1.5
19 BuildRequires:  rpm-pythonprov
20
21 %include /usr/lib/rpm/macros.python
22
23 %description
24 NumPy is a collection of extension modules to provide high-performance
25 multidimensional numeric arrays to the Python programming language.
26
27 %description -l pl
28 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
29 wielowymiarowych.
30
31 %package devel
32 Summary:        C header files for numerical modules
33 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
34 Group:          Development/Languages/Python
35 Group(de):      Entwicklung/Sprachen/Python
36 Group(pl):      Programowanie/Jêzyki/Python
37 %requires_eq    python
38 Requires:       %{name} = %{version}
39
40 %description devel
41 C header files for numerical modules.
42
43 %description devel -l pl
44 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
45
46 %package FFT
47 Summary:        Interface to the FFTPACK FORTRAN library
48 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
49 Group:          Development/Languages/Python
50 Group(de):      Entwicklung/Sprachen/Python
51 Group(pl):      Programowanie/Jêzyki/Python
52 %requires_eq    python
53 Requires:       %{name} = %{version}
54
55 %description FFT
56 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
57 library, which is a powerful standard library for doing fast Fourier
58 transforms of real and complex data sets.
59
60 %description FFT -l pl
61 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
62 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
63 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
64 Fouriera na liczba rzeczywistych i zespolonych.
65
66 %package kinds
67 Summary:        Implementation of PEP 0242 - precision and range control of numeric computations
68 Summary(pl):    Implementacja propozycji PEP 0242 - mo¿liwo¶æ kontrolowania precyzji i zakresu obliczeñ numerycznych
69 Group:          Development/Languages/Python
70 Group(de):      Entwicklung/Sprachen/Python
71 Group(pl):      Programowanie/Jêzyki/Python
72 %requires_eq    python
73 Requires:       %{name} = %{version}
74 Requires:       %{name}-kinds = %{version}
75
76 %description kinds
77 This is implementation of PEP 0242. PEP's abstract follows:
78
79 This proposal gives the user optional control over the precision and
80 range of numeric computations so that a computation can be written
81 once and run anywhere with at least the desired precision and range.
82 It is backward compatible with existing code.
83
84 %description kinds -l pl
85 Modu³ zawiera implementacjê propozycji PEP 0242. Oto jej streszczenie.
86
87 Propozycja ta umo¿liwia u¿ytkownikowi, opcjonalnie, kontrolê nad
88 precyzj± i zakresem obliczeñ numerycznych. Dziêki temu raz napisane
89 obliczenia mog± byæ uruchamiane na dowolnej maszynie. Mechanizm jest
90 kompatybilny wstecz z istniej±cymi programami.
91
92 %package MA
93 Summary:        MA - a facility for dealing with masked arrays
94 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
95 Group:          Development/Languages/Python
96 Group(de):      Entwicklung/Sprachen/Python
97 Group(pl):      Programowanie/Jêzyki/Python
98 %requires_eq    python
99 Requires:       %{name} = %{version}
100
101 %description MA
102 Masked arrays are arrays that may have missing or invalid entries.
103 Module MA provides a work-alike replacement for Numeric that supports
104 data arrays with masks.
105
106 %description MA -l pl
107 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog±
108 zawieraæ niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia
109 do operowania na tego typu macierzach.
110
111 %package Properties
112 Summary:        Property class implementation for Python
113 Summary(pl):    Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
114 Group:          Development/Languages/Python
115 Group(de):      Entwicklung/Sprachen/Python
116 Group(pl):      Programowanie/Jêzyki/Python
117 %requires_eq    python
118 Requires:       %{name} = %{version}
119
120 %description Properties
121 PropertiedClass is a mixin class that can be used to emulate
122 properties in a Python class. A property is an attribute whose read,
123 write, or deleting requires special handling. It is also possible to
124 use this facility to prevent the writing or deleting of a property.
125
126 %description Properties -l pl
127 PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji
128 w³a¶ciwo¶ci w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem,
129 którego czytanie, przypisywanie mu warto¶ci, czy te¿ jego usuwanie
130 powinno byæ traktowane w sposób specjalny. Mechanizm ten mo¿e byæ te¿
131 u¿ywany w celu ustalenia jakiego¶ atrybutu jako tylko do odczytu.
132
133 %package RNG
134 Summary:        Random Number Generator Object for NumPy
135 Summary:        Obiekt generatora liczb losowych dla modu³u NumPy
136 Group:          Development/Languages/Python
137 Group(de):      Entwicklung/Sprachen/Python
138 Group(pl):      Programowanie/Jêzyki/Python
139 %requires_eq    python
140 Requires:       %{name} = %{version}
141
142 %description RNG
143 RNG provides a random number object to Numerical Python.
144
145 %description RNG -l pl
146 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
147 jêzyka Python.
148
149 %prep
150 %setup -q -n %{mname}-%{version}
151
152 %build
153 CFLAGS="%{rpmcflags}"
154 export CFLAGS
155 python setup_all.py build
156
157 %install
158 rm -rf $RPM_BUILD_ROOT
159 python setup_all.py install --root=$RPM_BUILD_ROOT
160 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
161 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
162
163 %clean
164 rm -rf $RPM_BUILD_ROOT
165
166 %files
167 %defattr(644,root,root,755)
168 %dir %{py_sitedir}/%{mname}
169 %{py_sitedir}/%{mname}.pth
170 %attr(755,root,root) %{py_sitedir}/%{mname}/*.so
171 %{py_sitedir}/%{mname}/*.py[co]
172
173 %files devel
174 %defattr(644,root,root,755)
175 %{py_incdir}/%{mname}
176
177 %files FFT
178 %defattr(644,root,root,755)
179 %dir %{py_sitedir}/FFT
180 %attr(755,root,root) %{py_sitedir}/FFT/*.so
181 %{py_sitedir}/FFT/*.py[co]
182
183 %files kinds
184 %defattr(644,root,root,755)
185 %dir %{py_sitedir}/kinds
186 %attr(755,root,root) %{py_sitedir}/kinds/*.so
187 %{py_sitedir}/kinds/*.py[co]
188
189 %files MA
190 %defattr(644,root,root,755)
191 %dir %{py_sitedir}/MA
192 %{py_sitedir}/MA/*.py[co]
193
194 %files Properties
195 %defattr(644,root,root,755)
196 %dir %{py_sitedir}/PropertiedClasses
197 %{py_sitedir}/PropertiedClasses/*.py[co]
198
199 %files RNG
200 %defattr(644,root,root,755)
201 %dir %{py_sitedir}/RNG
202 %attr(755,root,root) %{py_sitedir}/RNG/*.so
203 %{py_sitedir}/RNG/*.py[co]
This page took 0.075086 seconds and 4 git commands to generate.