]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- release 2
[packages/python-numpy.git] / python-numpy.spec
1 #
2 # TODO:
3 #       - description for oldnumeric
4 #
5 %define         module  numpy
6
7 Summary:        Python numerical facilities
8 Summary(pl.UTF-8):      Moduły do obliczeń numerycznych dla języka Python
9 Name:           python-%{module}
10 Version:        1.0.4
11 Release:        2
12 Epoch:          1
13 License:        distributable
14 Group:          Libraries/Python
15 Source0:        http://dl.sourceforge.net/numpy/%{module}-%{version}.tar.gz
16 # Source0-md5:  8f011e9d7697da570efaac61c51725e0
17 URL:            http://sourceforge.net/projects/numpy/
18 BuildRequires:  lapack-devel >= 3.1.1-2
19 BuildRequires:  python-devel >= 1:2.5
20 BuildRequires:  rpm-pythonprov
21 %pyrequires_eq  python-libs
22 # -- dropped some time ago
23 Obsoletes:      python-numpy-Properties
24 # -- dropped some time ago, should have been released as separate package, but wasn't
25 Obsoletes:      python-numpy-kinds
26 # old subpackage, merged into main
27 Obsoletes:      python-numpy-FFT
28 # -- dropped during Numeric->numpy transition
29 Obsoletes:      python-numpy-MA
30 Obsoletes:      python-numpy-RNG
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 %description
34 NumPy is a collection of extension modules to provide high-performance
35 multidimensional numeric arrays to the Python programming language.
36
37 %description -l pl.UTF-8
38 Pakiet umożliwia wydajne obliczenia numeryczne na macierzach
39 wielowymiarowych.
40
41 %package devel
42 Summary:        C header files for numerical modules
43 Summary(pl.UTF-8):      Pliki nagłówkowe języka C modułów numerycznych
44 Group:          Development/Languages/Python
45 %pyrequires_eq  python-devel
46 Requires:       %{name} = %{epoch}:%{version}-%{release}
47
48 %description devel
49 C header files for numerical modules.
50
51 %description devel -l pl.UTF-8
52 Pliki nagłówkowe języka C modułów numerycznych.
53
54 %package numarray
55 Summary:        Array manipulation and computations for python
56 Summary(pl.UTF-8):      Operacje i obliczenia na tablicach dla Pythona
57 Group:          Development/Languages/Python
58 Requires:       %{name} = %{epoch}:%{version}-%{release}
59
60 %description numarray
61 Numarray provides array manipulation and computational capabilities
62 similar to those found in IDL, Matlab, or Octave. Using numarray, it
63 is possible to write many efficient numerical data processing
64 applications directly in Python without using any C, C++ or Fortran
65 code (as well as doing such analysis interactively within Python or
66 PyRAF). For algorithms that are not well suited for efficient
67 computation using array facilities it is possible to write C functions
68 (and eventually Fortran) that can read and write numarray arrays that
69 can be called from Python.
70
71 Numarray is a re-implementation of an older Python array module called
72 Numeric. In general its interface is very similar. It is mostly
73 backward compatible and will be becoming more so in future releases.
74
75 %description numarray -l pl.UTF-8
76 Numarray zapewnia narzędzia do operacji oraz obliczeń na tablicach
77 podobne do tych, jakie zapewniają IDL, Matlab czy Octave. Używając
78 numarray możliwe jest stworzenie bezpośrednio w Pythonie, nie używając
79 wstawek C, C++ czy fortranowych, wielu wydajnych aplikacji do
80 przetwarzania danych numerycznych. Dla algorytmów, które nie pracują
81 wydajnie z tablicami, możliwe jest napisanie funkcji C, które mogą
82 czytać i zapisywać tablice numarray, i które mogą być wywoływane z
83 poziomu Pythona.
84
85 Numarray jest ponowną implementacją starszego modułu Pythona -
86 Numeric. Interfejsy tych modułów są do siebie bardzo podobne. Numarray
87 jest w większości przypadków kompatybilny wstecz, a sytuacja poprawi
88 się w nowszych wersjach.
89
90 %package numarray-devel
91 Summary:        Header files for python-numarray
92 Summary(pl.UTF-8):      Pliki nagłówkowe dla python-numarray
93 Group:          Development/Libraries
94 Requires:       %{name}-devel = %{epoch}:%{version}-%{release}
95 Requires:       %{name}-numarray = %{epoch}:%{version}-%{release}
96
97 %description numarray-devel
98 Header files for python-numarray.
99
100 %description numarray-devel -l pl.UTF-8
101 Pliki nagłówkowe dla python-numarray.
102
103 %package oldnumeric
104 Summary:        Old numeric packages
105 Summary(pl.UTF-8):      Stare pakiety numeric
106 Group:          Libraries/Python
107 Requires:       %{name} = %{epoch}:%{version}-%{release}
108
109 %description oldnumeric
110 Old numeric packages.
111
112 %description oldnumeric -l pl.UTF-8
113 Stare pakiety numeric.
114
115 %package -n f2py
116 Summary:        Fortran to Python interface generator
117 Summary(pl.UTF-8):      Generator interfejsów z Fortranu do Pythona
118 Group:          Libraries/Python
119 Requires:       %{name} = %{epoch}:%{version}-%{release}
120
121 %description -n f2py
122 Fortran to Python interface generator.
123
124 %description -n f2py -l pl.UTF-8
125 Generator interfejsów z Fortranu do Pythona.
126
127 %prep
128 %setup -q -n %{module}-%{version}
129
130 %build
131 CC="%{__cc}"; export CC
132 CFLAGS="%{rpmcflags}"; export CFLAGS
133 python setup.py build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 python setup.py install \
139         --root=$RPM_BUILD_ROOT
140
141 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
142 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
143 %py_postclean
144
145 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/{*.txt,COMPATIBILITY,scipy_compatibility,doc}
146 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*/{tests,docs}
147 # already in f2py package
148 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/f2py/f2py.1
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/%{module}
156 %{py_sitedir}/%{module}/*.py[co]
157 %{py_sitedir}/%{module}/tests
158 %dir %{py_sitedir}/%{module}/core
159 %{py_sitedir}/%{module}/core/*.py[co]
160 %attr(755,root,root) %{py_sitedir}/%{module}/core/*.so
161 %dir %{py_sitedir}/%{module}/distutils
162 %{py_sitedir}/%{module}/distutils/*.py[co]
163 #%{py_sitedir}/%{module}/distutils/site.cfg
164 %dir %{py_sitedir}/%{module}/distutils/command
165 %{py_sitedir}/%{module}/distutils/command/*.py[co]
166 %dir %{py_sitedir}/%{module}/distutils/fcompiler
167 %{py_sitedir}/%{module}/distutils/fcompiler/*.py[co]
168 %dir %{py_sitedir}/%{module}/fft
169 %attr(755,root,root) %{py_sitedir}/%{module}/fft/*.so
170 %{py_sitedir}/%{module}/fft/*.py[co]
171 %dir %{py_sitedir}/%{module}/lib
172 %{py_sitedir}/%{module}/lib/*.py[co]
173 %attr(755,root,root) %{py_sitedir}/%{module}/lib/*.so
174 %dir %{py_sitedir}/%{module}/linalg
175 %{py_sitedir}/%{module}/linalg/*.py[co]
176 %attr(755,root,root) %{py_sitedir}/%{module}/linalg/*.so
177 %dir %{py_sitedir}/%{module}/random
178 %{py_sitedir}/%{module}/random/*.py[co]
179 %attr(755,root,root) %{py_sitedir}/%{module}/random/*.so
180 %dir %{py_sitedir}/%{module}/testing
181 %{py_sitedir}/%{module}/testing/*.py[co]
182 %{py_sitedir}/numpy-*.egg-info
183
184 %files devel
185 %defattr(644,root,root,755)
186 %{py_sitedir}/%{module}/core/include
187 %{py_sitedir}/%{module}/random/*.h
188
189 %files numarray
190 %defattr(644,root,root,755)
191 %dir %{py_sitedir}/%{module}/numarray
192 %attr(755,root,root) %{py_sitedir}/%{module}/numarray/*.so
193 %{py_sitedir}/%{module}/numarray/*.py[co]
194
195 %files numarray-devel
196 %defattr(644,root,root,755)
197 %dir %{py_sitedir}/%{module}/numarray/numpy
198 %{py_sitedir}/%{module}/numarray/numpy/*
199
200 %files oldnumeric
201 %defattr(644,root,root,755)
202 %dir %{py_sitedir}/%{module}/oldnumeric
203 %{py_sitedir}/%{module}/oldnumeric/*
204
205 %files -n f2py
206 %defattr(644,root,root,755)
207 %attr(744,root,root) %{_bindir}/f2py
208 %dir %{py_sitedir}/%{module}/f2py
209 %{py_sitedir}/%{module}/f2py/*.py[co]
210 %{py_sitedir}/%{module}/f2py/src
211 %{py_sitedir}/%{module}/f2py/lib
This page took 0.09947 seconds and 4 git commands to generate.