]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- rel .2
[packages/python-numpy.git] / python-numpy.spec
1 #
2 # TODO:
3 #       - description for oldnumeric
4 #
5 %define         module  numpy
6 %define         _rc1 rc1
7
8 Summary:        Python numerical facilities
9 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
10 Name:           python-%{module}
11 Version:        1.0
12 Release:        0.%{_rc1}.2
13 Epoch:          1
14 License:        distributable
15 Group:          Libraries/Python
16 Source0:        http://dl.sourceforge.net/numpy/%{module}-%{version}%{_rc1}.tar.gz
17 # Source0-md5:  b8cd486ee334520047f9a35454dad94a
18 URL:            http://sourceforge.net/projects/numpy/
19 BuildRequires:  python-devel >= 1:2.3
20 %pyrequires_eq  python-libs
21 # -- dropped some time ago
22 Obsoletes:      python-numpy-Properties
23 # -- dropped some time ago, should have been released as separate package, but wasn't
24 Obsoletes:      python-numpy-kinds
25 # -- dropped during Numeric->numpy transition
26 Obsoletes:      python-numpy-MA
27 Obsoletes:      python-numpy-RNG
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 NumPy is a collection of extension modules to provide high-performance
32 multidimensional numeric arrays to the Python programming language.
33
34 %description -l pl
35 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
36 wielowymiarowych.
37
38 %package devel
39 Summary:        C header files for numerical modules
40 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
41 Group:          Development/Languages/Python
42 %pyrequires_eq  python-devel
43 Requires:       %{name} = %{epoch}:%{version}-%{release}
44
45 %description devel
46 C header files for numerical modules.
47
48 %description devel -l pl
49 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
50
51 %package FFT
52 Summary:        Interface to the FFTPACK FORTRAN library
53 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
54 Group:          Libraries/Python
55 %pyrequires_eq  python-libs
56 Requires:       %{name} = %{epoch}:%{version}-%{release}
57
58 %description FFT
59 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
60 library, which is a powerful standard library for doing fast Fourier
61 transforms of real and complex data sets.
62
63 %description FFT -l pl
64 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
65 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
66 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
67 Fouriera na liczba rzeczywistych i zespolonych.
68
69 %package numarray
70 Summary:        Array manipulation and computations for python
71 Summary(pl):    Operacje i obliczenia na tablicach dla Pythona
72 Group:          Development/Languages/Python
73 Requires:       %{name} = %{epoch}:%{version}-%{release}
74
75 %description numarray
76 Numarray provides array manipulation and computational capabilities
77 similar to those found in IDL, Matlab, or Octave. Using numarray, it
78 is possible to write many efficient numerical data processing
79 applications directly in Python without using any C, C++ or Fortran
80 code (as well as doing such analysis interactively within Python or
81 PyRAF). For algorithms that are not well suited for efficient
82 computation using array facilities it is possible to write C functions
83 (and eventually Fortran) that can read and write numarray arrays that
84 can be called from Python.
85
86 Numarray is a re-implementation of an older Python array module called
87 Numeric. In general its interface is very similar. It is mostly
88 backward compatible and will be becoming more so in future releases.
89
90 %description numarray -l pl
91 Numarray zapewnia narzêdzia do operacji oraz obliczeñ na tablicach
92 podobne do tych, jakie zapewniaj± IDL, Matlab czy Octabe. U¿ywaj±c
93 numarray mo¿liwe jest stworzenie bezpo¶rednio w Pythonie, nie u¿ywaj±c
94 wstawek C, C++ czy Fortranowych, wielu wydajnych aplikacji do
95 przetwarzania danych numerycznych. Dla algorytmów, które nie pracuj±
96 wydajnie z tablicami, mo¿liwe jest napisanie funkcji C, które mog±
97 czytaæ i zapisywaæ tablice numarray, i które mog± byæ wywo³ywane z
98 poziomu Pythona.
99
100 Numarray jest ponown± implementacj± starszego modu³u Pythona -
101 Numeric. Interfejsy tych modu³ów s± do siebie bardzo podobne. Numarray
102 jest w wiêkszo¶ci przypadków kompatybilny wstecz, a sytuacja poprawi
103 siê w nowszych wersjach.
104
105 %package numarray-devel
106 Summary:        Header files for python-numarray
107 Summary(pl):    Pliki nag³ówkowe dla python-numarray
108 Group:          Development/Libraries
109
110 %description numarray-devel
111 Header files for python-numarray.
112
113 %description numarray-devel -l pl
114 Pliki nag³ówkowe dla python-numarray.
115
116 %package oldnumeric
117 Summary:        Old numeric packages
118 Summary(pl):    Old numeric packages
119 Group:          Libraries/Python
120
121 %description oldnumeric
122 Old numeric packages.
123
124 %description oldnumeric -l pl
125 Old numeric packages.
126
127 %prep
128 %setup -q -n %{module}-%{version}%{_rc1}
129
130 %build
131 CC="%{__cc}"; export CC
132 CFLAGS="%{rpmcflags}"; export CFLAGS
133 python setup.py build
134
135 %install
136 rm -rf $RPM_BUILD_ROOT
137
138 python setup.py install \
139         --root=$RPM_BUILD_ROOT
140
141 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
142 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
143 %py_postclean
144
145 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/{*.txt,COMPATIBILITY,scipy_compatibility,doc}
146 rm -rf $RPM_BUILD_ROOT%{py_sitedir}/%{module}/*/{tests,docs}
147 # already in f2py package
148 rm -rf $RPM_BUILD_ROOT{%{_bindir}/f2py,%{py_sitedir}/%{module}/f2py/f2py.1}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/%{module}
156 %{py_sitedir}/%{module}/*.py[co]
157 %dir %{py_sitedir}/%{module}/core
158 %{py_sitedir}/%{module}/core/*.py[co]
159 %attr(755,root,root) %{py_sitedir}/%{module}/core/*.so
160 %dir %{py_sitedir}/%{module}/distutils
161 %{py_sitedir}/%{module}/distutils/*.py[co]
162 %{py_sitedir}/%{module}/distutils/site.cfg
163 %dir %{py_sitedir}/%{module}/distutils/command
164 %{py_sitedir}/%{module}/distutils/command/*.py[co]
165 %dir %{py_sitedir}/%{module}/distutils/fcompiler
166 %{py_sitedir}/%{module}/distutils/fcompiler/*.py[co]
167 %dir %{py_sitedir}/%{module}/f2py
168 %{py_sitedir}/%{module}/f2py/*.py[co]
169 %{py_sitedir}/%{module}/f2py/src
170 %dir %{py_sitedir}/%{module}/lib
171 %{py_sitedir}/%{module}/lib/*.py[co]
172 %attr(755,root,root) %{py_sitedir}/%{module}/lib/*.so
173 %dir %{py_sitedir}/%{module}/linalg
174 %{py_sitedir}/%{module}/linalg/*.py[co]
175 %attr(755,root,root) %{py_sitedir}/%{module}/linalg/*.so
176 %dir %{py_sitedir}/%{module}/random
177 %{py_sitedir}/%{module}/random/*.py[co]
178 %attr(755,root,root) %{py_sitedir}/%{module}/random/*.so
179 %dir %{py_sitedir}/%{module}/testing
180 %{py_sitedir}/%{module}/testing/*.py[co]
181
182 %files devel
183 %defattr(644,root,root,755)
184 %{py_sitedir}/%{module}/core/include
185 %{py_sitedir}/%{module}/random/*.h
186
187 %files FFT
188 %defattr(644,root,root,755)
189 %dir %{py_sitedir}/%{module}/fft
190 %attr(755,root,root) %{py_sitedir}/%{module}/fft/*.so
191 %{py_sitedir}/%{module}/fft/*.py[co]
192
193 %files numarray
194 %defattr(644,root,root,755)
195 %attr(755,root,root) %{py_sitedir}/%{module}/numarray/*.so
196 %dir %{py_sitedir}/%{module}/numarray
197 %{py_sitedir}/%{module}/numarray/*.py[co]
198
199 %files numarray-devel
200 %defattr(644,root,root,755)
201 %dir %{py_sitedir}/%{module}/numarray/numpy
202 %{py_sitedir}/%{module}/numarray/numpy/*
203
204 %files oldnumeric
205 %defattr(644,root,root,755)
206 %dir %{py_sitedir}/%{module}/oldnumeric
207 %{py_sitedir}/%{module}/oldnumeric/*
This page took 0.076586 seconds and 4 git commands to generate.