]> git.pld-linux.org Git - packages/python-numpy.git/blob - python-numpy.spec
- updated to 21.0
[packages/python-numpy.git] / python-numpy.spec
1 %include        /usr/lib/rpm/macros.python
2
3 %define module numpy
4 %define mname Numeric
5
6 Summary:        Python numerical facilities
7 Summary(pl):    Modu³y do obliczeñ numerycznych dla jêzyka Python
8 Name:           python-%{module}
9 Version:        21.0
10 Release:        1
11 License:        distributable
12 Group:          Development/Languages/Python
13 Source0:        http://prdownloads.sourceforge.net/numpy/%{mname}-%{version}.tar.gz
14 URL:            http://www.pfdubois.com/numpy/
15 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
16 BuildRequires:  python-devel >= 2.2
17 %requires_eq    python
18 BuildRequires:  rpm-pythonprov
19
20 %description
21 NumPy is a collection of extension modules to provide high-performance
22 multidimensional numeric arrays to the Python programming language.
23
24 %description -l pl
25 Pakiet umo¿liwia wydajne obliczenia numeryczne na macierzach
26 wielowymiarowych.
27
28 %package devel
29 Summary:        C header files for numerical modules
30 Summary(pl):    Pliki nag³ówkowe jêzyka C modu³ów numerycznych
31 Group:          Development/Languages/Python
32 %requires_eq    python
33 Requires:       %{name} = %{version}
34
35 %description devel
36 C header files for numerical modules.
37
38 %description devel -l pl
39 Pliki nag³ówkowe jêzyka C modu³ów numerycznych.
40
41 %package FFT
42 Summary:        Interface to the FFTPACK FORTRAN library
43 Summary(pl):    Interfejs do biblioteki FFTPACK jêzyka Fortran
44 Group:          Development/Languages/Python
45 %requires_eq    python
46 Requires:       %{name} = %{version}
47
48 %description FFT
49 The FFT.py module provides a simple interface to the FFTPACK FORTRAN
50 library, which is a powerful standard library for doing fast Fourier
51 transforms of real and complex data sets.
52
53 %description FFT -l pl
54 Modu³ FFT zawiera prosty interfejs do biblioteki FFTPACK jêzyka
55 Fortran. Ta biblioteka o wysokich mo¿liwo¶ciach jest standardowo
56 u¿ywana do prowadzenia obliczeñ za pomoc± dyskretnej transformaty
57 Fouriera na liczba rzeczywistych i zespolonych.
58
59 %package kinds
60 Summary:        Implementation of PEP 0242 - precision and range control of numeric computations
61 Summary(pl):    Implementacja propozycji PEP 0242 - mo¿liwo¶æ kontrolowania precyzji i zakresu obliczeñ numerycznych
62 Group:          Development/Languages/Python
63 %requires_eq    python
64 Requires:       %{name} = %{version}
65
66 %description kinds
67 This is implementation of PEP 0242. PEP's abstract follows:
68
69 This proposal gives the user optional control over the precision and
70 range of numeric computations so that a computation can be written
71 once and run anywhere with at least the desired precision and range.
72 It is backward compatible with existing code.
73
74 %description kinds -l pl
75 Modu³ zawiera implementacjê propozycji PEP 0242. Oto jej streszczenie.
76
77 Propozycja ta umo¿liwia u¿ytkownikowi, opcjonalnie, kontrolê nad
78 precyzj± i zakresem obliczeñ numerycznych. Dziêki temu raz napisane
79 obliczenia mog± byæ uruchamiane na dowolnej maszynie. Mechanizm jest
80 kompatybilny wstecz z istniej±cymi programami.
81
82 %package MA
83 Summary:        MA - a facility for dealing with masked arrays
84 Summary(pl):    Modu³ do obs³ugi macierzy niepe³nych
85 Group:          Development/Languages/Python
86 %requires_eq    python
87 Requires:       %{name} = %{version}
88
89 %description MA
90 Masked arrays are arrays that may have missing or invalid entries.
91 Module MA provides a work-alike replacement for Numeric that supports
92 data arrays with masks.
93
94 %description MA -l pl
95 Macierze niepe³ne s± to macierze, którym mo¿e brakowaæ lub mog±
96 zawieraæ niepoprawne warto¶ci. Modu³ MA zawiera odpowiednie narzêdzia
97 do operowania na tego typu macierzach.
98
99 %package Properties
100 Summary:        Property class implementation for Python
101 Summary(pl):    Implementacja klasy z w³a¶ciwo¶ciami dla jêzyka Python
102 Group:          Development/Languages/Python
103 %requires_eq    python
104 Requires:       %{name} = %{version}
105
106 %description Properties
107 PropertiedClass is a mixin class that can be used to emulate
108 properties in a Python class. A property is an attribute whose read,
109 write, or deleting requires special handling. It is also possible to
110 use this facility to prevent the writing or deleting of a property.
111
112 %description Properties -l pl
113 PropertiedClass jest klas±, która mo¿e byæ u¿yta do emulacji
114 w³a¶ciwo¶ci w klasach jêzyka Python. W³a¶ciwo¶æ klasy jest atrybutem,
115 którego czytanie, przypisywanie mu warto¶ci, czy te¿ jego usuwanie
116 powinno byæ traktowane w sposób specjalny. Mechanizm ten mo¿e byæ te¿
117 u¿ywany w celu ustalenia jakiego¶ atrybutu jako tylko do odczytu.
118
119 %package RNG
120 Summary:        Random Number Generator Object for NumPy
121 Summary:        Obiekt generatora liczb losowych dla modu³u NumPy
122 Group:          Development/Languages/Python
123 %requires_eq    python
124 Requires:       %{name} = %{version}
125
126 %description RNG
127 RNG provides a random number object to Numerical Python.
128
129 %description RNG -l pl
130 Modu³ ten zawiera implementacjê obiektu generatora liczb losowych dla
131 jêzyka Python.
132
133 %prep
134 %setup -q -n %{mname}-%{version}
135
136 %build
137 CC="%{__cc}"; export CC
138 CFLAGS="%{rpmcflags}"; export CFLAGS
139 python setup.py build
140
141 %install
142 rm -rf $RPM_BUILD_ROOT
143
144 python setup.py install \
145         --root=$RPM_BUILD_ROOT
146
147 %py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
148 %py_comp $RPM_BUILD_ROOT%{py_sitedir}
149
150 %clean
151 rm -rf $RPM_BUILD_ROOT
152
153 %files
154 %defattr(644,root,root,755)
155 %dir %{py_sitedir}/%{mname}
156 %{py_sitedir}/%{mname}.pth
157 %attr(755,root,root) %{py_sitedir}/%{mname}/*.so
158 %{py_sitedir}/%{mname}/*.py[co]
159
160 %files devel
161 %defattr(644,root,root,755)
162 %{py_incdir}/%{mname}
163
164 %files FFT
165 %defattr(644,root,root,755)
166 %dir %{py_sitedir}/%{mname}/FFT
167 %attr(755,root,root) %{py_sitedir}/%{mname}/FFT/*.so
168 %{py_sitedir}/%{mname}/FFT/*.py[co]
169
170 %files kinds
171 %defattr(644,root,root,755)
172 %dir %{py_sitedir}/%{mname}/kinds
173 %attr(755,root,root) %{py_sitedir}/%{mname}/kinds/*.so
174 %{py_sitedir}/%{mname}/kinds/*.py[co]
175
176 %files MA
177 %defattr(644,root,root,755)
178 %dir %{py_sitedir}/%{mname}/MA
179 %{py_sitedir}/%{mname}/MA/*.py[co]
180
181 %files Properties
182 %defattr(644,root,root,755)
183 %dir %{py_sitedir}/%{mname}/PropertiedClasses
184 %{py_sitedir}/%{mname}/PropertiedClasses/*.py[co]
185
186 %files RNG
187 %defattr(644,root,root,755)
188 %dir %{py_sitedir}/%{mname}/RNG
189 %attr(755,root,root) %{py_sitedir}/%{mname}/RNG/*.so
190 %{py_sitedir}/%{mname}/RNG/*.py[co]
This page took 0.106039 seconds and 4 git commands to generate.