]> git.pld-linux.org Git - packages/python-numarray.git/blob - python-numarray.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-numarray.git] / python-numarray.spec
1
2 %define         module  numarray
3
4 Summary:        Array manipulation and computations for python
5 Summary(pl.UTF-8):      Operacje i obliczenia na tablicach dla Pythona
6 Name:           python-%{module}
7 Version:        1.5.2
8 Release:        6
9 License:        GPL-like
10 Group:          Development/Languages/Python
11 Source0:        http://dl.sourceforge.net/numpy/%{module}-%{version}.tar.gz
12 # Source0-md5:  d2ecfc60fe4869c328b872540d04e0f7
13 Source1:        http://dl.sourceforge.net/numpy/%{module}-1.5.pdf
14 # Source1-md5:  922731aeb775b1f5eb3a0622750314e1
15 Patch0:         %{name}-includes.patch
16 Patch1:         %{name}-python25.patch
17 Patch2:         %{name}-refcount.patch
18 URL:            http://www.stsci.edu/resources/software_hardware/numarray
19 BuildRequires:  rpmbuild(macros) >= 1.710
20 BuildRequires:  python
21 BuildRequires:  python-devel >= 1:2.3
22 BuildRequires:  python-modules
23 BuildRequires:  rpm-pythonprov
24 %pyrequires_eq  python-modules
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 Numarray provides array manipulation and computational capabilities
29 similar to those found in IDL, Matlab, or Octave. Using numarray, it
30 is possible to write many efficient numerical data processing
31 applications directly in Python without using any C, C++ or Fortran
32 code (as well as doing such analysis interactively within Python or
33 PyRAF). For algorithms that are not well suited for efficient
34 computation using array facilities it is possible to write C functions
35 (and eventually Fortran) that can read and write numarray arrays that
36 can be called from Python.
37
38 Numarray is a re-implementation of an older Python array module called
39 Numeric. In general its interface is very similar. It is mostly
40 backward compatible and will be becoming more so in future releases.
41
42 %description -l pl.UTF-8
43 Numarray zapewnia narzędzia do operacji oraz obliczeń na tablicach
44 podobne do tych, jakie zapewniają IDL, Matlab czy Octabe. Używając
45 numarray możliwe jest stworzenie bezpośrednio w Pythonie, nie używając
46 wstawek C, C++ czy Fortranowych, wielu wydajnych aplikacji do
47 przetwarzania danych numerycznych. Dla algorytmów, które nie pracują
48 wydajnie z tablicami, możliwe jest napisanie funkcji C, które mogą
49 czytać i zapisywać tablice numarray, i które mogą być wywoływane z
50 poziomu Pythona.
51
52 Numarray jest ponowną implementacją starszego modułu Pythona -
53 Numeric. Interfejsy tych modułów są do siebie bardzo podobne. Numarray
54 jest w większości przypadków kompatybilny wstecz, a sytuacja poprawi
55 się w nowszych wersjach.
56
57 %package devel
58 Summary:        Header files for python-numarray
59 Summary(pl.UTF-8):      Pliki nagłówkowe dla python-numarray
60 Group:          Development/Libraries
61
62 %description devel
63 Header files for python-numarray.
64
65 %description devel -l pl.UTF-8
66 Pliki nagłówkowe dla python-numarray.
67
68 %prep
69 %setup -q -n %{module}-%{version}
70 %patch0 -p0
71 %patch1 -p0
72 %patch2 -p0
73 cp %{SOURCE1} .
74
75 %build
76 %py_build
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %py_install
82
83 find $RPM_BUILD_ROOT%{py_sitedir} -name '*.py' | \
84         grep -v examples | \
85         xargs rm
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %files
91 %defattr(644,root,root,755)
92 %doc README.txt *.pdf
93 %dir %{py_sitedir}/%{module}
94 %{py_sitedir}/%{module}/*
95
96 %files devel
97 %defattr(644,root,root,755)
98 %dir %{py_incdir}/%{module}
99 %{py_incdir}/%{module}/*
This page took 0.060089 seconds and 3 git commands to generate.