]> git.pld-linux.org Git - packages/python-nose_randomly.git/blob - python-nose_randomly.spec
4ef43f3ff06ef3d98a6dcd067f9a48a76f5d3bfe
[packages/python-nose_randomly.git] / python-nose_randomly.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # unit tests
4 %bcond_without  python2 # CPython 2.x module
5 %bcond_without  python3 # CPython 3.x module
6
7 Summary:        Nose plugin to randomly order tests and control random.seed
8 Summary(pl.UTF-8):      Wtyczka nose do losowania kolejności testów oraz sterowania random.seed
9 Name:           python-nose_randomly
10 Version:        1.2.6
11 Release:        1
12 License:        BSD
13 Group:          Libraries/Python
14 #Source0Download: https://pypi.org/simple/nose-randomly/
15 Source0:        https://files.pythonhosted.org/packages/source/n/nose-randomly/nose-randomly-%{version}.tar.gz
16 # Source0-md5:  e358c97da4be4514b8505c27ca8e8a5d
17 URL:            https://pypi.org/project/nose-randomly/
18 %if %{with python2}
19 BuildRequires:  python-modules >= 1:2.7
20 BuildRequires:  python-setuptools
21 %if %{with tests}
22 BuildRequires:  python-nose
23 %endif
24 %endif
25 %if %{with python3}
26 BuildRequires:  python3-modules >= 1:3.4
27 BuildRequires:  python3-setuptools
28 %if %{with tests}
29 BuildRequires:  python3-nose
30 %endif
31 %endif
32 BuildRequires:  rpm-pythonprov
33 BuildRequires:  rpmbuild(macros) >= 1.714
34 Requires:       python-modules >= 1:2.7
35 BuildArch:      noarch
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 Nose plugin to randomly order tests and control random.seed.
40
41 %description -l pl.UTF-8
42 Wtyczka nose do losowania kolejności testów oraz sterowania
43 random.seed.
44
45 %package -n python3-nose_randomly
46 Summary:        Nose plugin to randomly order tests and control random.seed
47 Summary(pl.UTF-8):      Wtyczka nose do losowania kolejności testów oraz sterowania random.seed
48 Group:          Libraries/Python
49 Requires:       python3-modules >= 1:3.4
50
51 %description -n python3-nose_randomly
52 Nose plugin to randomly order tests and control random.seed.
53
54 %description -n python3-nose_randomly -l pl.UTF-8
55 Wtyczka nose do losowania kolejności testów oraz sterowania
56 random.seed.
57
58 %prep
59 %setup -q -n nose-randomly-%{version}
60
61 %build
62 %if %{with python2}
63 %py_build
64
65 %if %{with tests}
66 %{__python} -m nose tests
67 %endif
68 %endif
69
70 %if %{with python3}
71 %py3_build
72
73 %if %{with tests}
74 %{__python3} -m nose tests
75 %endif
76 %endif
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %py_install
83
84 %py_postclean
85 %endif
86
87 %if %{with python3}
88 %py3_install
89 %endif
90
91 %clean
92 rm -rf $RPM_BUILD_ROOT
93
94 %if %{with python2}
95 %files
96 %defattr(644,root,root,755)
97 %doc AUTHORS.rst HISTORY.rst LICENSE README.rst
98 %{py_sitescriptdir}/nose_randomly.py[co]
99 %{py_sitescriptdir}/nose_randomly-%{version}-py*.egg-info
100 %endif
101
102 %if %{with python3}
103 %files -n python3-nose_randomly
104 %defattr(644,root,root,755)
105 %doc AUTHORS.rst HISTORY.rst LICENSE README.rst
106 %{py3_sitescriptdir}/nose_randomly.py
107 %{py3_sitescriptdir}/__pycache__/nose_randomly.cpython-*.py[co]
108 %{py3_sitescriptdir}/nose_randomly-%{version}-py*.egg-info
109 %endif
This page took 0.060518 seconds and 2 git commands to generate.