]> git.pld-linux.org Git - packages/python-fasteners.git/blob - python-fasteners.spec
- release 5 (by relup.sh)
[packages/python-fasteners.git] / python-fasteners.spec
1 # Conditional build:
2 %bcond_without  tests   # do not perform "make test"
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         module          fasteners
7 %define         egg_name        fasteners
8 %define         pypi_name       fasteners
9 Summary:        Provides useful locks
10 Name:           python-%{pypi_name}
11 Version:        0.14.1
12 Release:        5
13 License:        Apache v2.0
14 Group:          Libraries/Python
15 Source0:        https://pypi.python.org/packages/f4/6f/41b835c9bf69b03615630f8a6f6d45dafbec95eb4e2bb816638f043552b2/fasteners-%{version}.tar.gz
16 # Source0-md5:  fcb13261c9b0039d9b1c4feb9bc75e04
17 URL:            https://pypi.python.org/pypi/fasteners
18 BuildRequires:  rpm-pythonprov
19 BuildRequires:  rpmbuild(macros) >= 1.714
20 %if %{with python2}
21 BuildRequires:  python-modules
22 BuildRequires:  python-setuptools
23 %if %{with tests}
24 BuildRequires:  python-monotonic
25 BuildRequires:  python-testtools
26 %endif
27 %endif
28 %if %{with python3}
29 BuildRequires:  python3-modules
30 BuildRequires:  python3-setuptools
31 %if %{with tests}
32 BuildRequires:  python3-monotonic
33 BuildRequires:  python3-testtools
34 %endif
35 %endif
36 Requires:       python-modules
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 Provides useful locks.
42
43 %package -n python3-%{module}
44 Summary:        Provides useful locks
45 Group:          Libraries/Python
46 Requires:       python3-modules
47
48 %description -n python3-%{module}
49 Provides useful locks
50
51 %prep
52 %setup -q -n %{pypi_name}-%{version}
53
54 %build
55 %if %{with python2}
56 %py_build %{?with_tests:test}
57 %endif
58
59 %if %{with python3}
60 %py3_build %{?with_tests:test}
61 %endif
62
63 %install
64 rm -rf $RPM_BUILD_ROOT
65
66 %if %{with python2}
67 %py_install
68 %py_postclean
69 %endif
70
71 %if %{with python3}
72 %py3_install
73 %endif
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %if %{with python2}
79 %files
80 %defattr(644,root,root,755)
81 %doc ChangeLog README.rst
82 %{py_sitescriptdir}/%{module}
83 %{py_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
84 %endif
85
86 %if %{with python3}
87 %files -n python3-%{module}
88 %defattr(644,root,root,755)
89 %doc ChangeLog README.rst
90 %{py3_sitescriptdir}/%{module}
91 %{py3_sitescriptdir}/%{egg_name}-%{version}-py*.egg-info
92 %endif
This page took 0.108753 seconds and 3 git commands to generate.