]> git.pld-linux.org Git - packages/python-efl.git/blob - python-efl.spec
b59c40b0e124f56cb06d196b42fff6a607927e8d
[packages/python-efl.git] / python-efl.spec
1 %define         efl_ver         1.9.0
2 %define         ecore_ver       %{efl_ver}
3 %define         ecore_file_ver  1.8.0
4 %define         edje_ver        %{efl_ver}
5 %define         eina_ver        %{efl_ver}
6 %define         emotion_ver     %{efl_ver}
7 %define         eo_ver          %{efl_ver}
8 %define         evas_ver        %{efl_ver}
9 %define         elementary_ver  1.9.0
10 %define         py_dbus_ver     0.83.0
11
12 Summary:        Python bindings for Enlightenment Foundation Libraries
13 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
14 Name:           python-efl
15 Version:        1.9.0
16 Release:        1
17 License:        LGPL v3+
18 Group:          Development/Languages/Python
19 Source0:        http://download.enlightenment.org/rel/bindings/python/%{name}-%{version}.tar.bz2
20 # Source0-md5:  4a37778c690cd9d673575416df060b55
21 URL:            http://trac.enlightenment.org/e/wiki/Python
22 BuildRequires:  python-dbus-devel >= %{py_dbus_ver}
23 BuildRequires:  ecore-devel >= %{ecore_ver}
24 BuildRequires:  ecore-file-devel >= %{ecore_file_ver}
25 BuildRequires:  edje-devel >= %{edje_ver}
26 BuildRequires:  eina-devel >= %{eina_ver}
27 BuildRequires:  elementary-devel >= %{elementary_ver}
28 BuildRequires:  emotion-devel >= %{emotion_ver}
29 BuildRequires:  eo-devel >= %{eo_ver}
30 BuildRequires:  evas-devel >= %{evas_ver}
31 BuildRequires:  pkgconfig
32 # when using *.pyx sources, not pregenerated *.c
33 #BuildRequires: python-Cython >= 0.17.0
34 BuildRequires:  python-Sphinx
35 BuildRequires:  python-devel >= 1:2.7
36 BuildRequires:  rpm-pythonprov
37 BuildRequires:  rpmbuild(macros) >= 1.219
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %description
41 EFL is a collection of libraries for handling many common tasks a
42 developer man have such as data structures, communication, rendering,
43 widgets and more. PYTHON-EFL are the Python bindings for EFL and
44 Elementary.
45
46 %description -l pl.UTF-8
47 EFL to zbiór bibliotek do obsługi wielu częstych zadań programisty,
48 takich jak struktury danych, komunikacja, renderowanie, widgety itp.
49 PYTHON-EFL to wiązania Pythona do bibliotek EFL i Elementary.
50
51 %package base
52 Summary:        Python bindings for Enlightenment Foundation Libraries - base common part
53 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek EFL - wspólna część podstawowa
54 Group:          Development/Languages/Python
55 Requires:       eina >= %{eina_ver}
56 Requires:       eo >= %{eina_ver}
57
58 %description base
59 Python bindings for Enlightenment Foundation Libraries - base common
60 part:
61 - Eo library binding
62 - efl.utils modules
63
64 %description base
65 Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
66 - wspólna część podstawowa:
67 - wiązanie do biblioteki Eo
68 - moduły efl.utils
69
70 %package examples
71 Summary:        Examples for PYTHON-EFL bindings
72 Summary(pl.UTF-8):      Przykłady do wiązań PYTHON-EFL
73 Group:          Development/Libraries
74 Requires:       python-dbus >= %{py_dbus_ver}
75 Requires:       python-e_dbus = %{version}-%{release}
76 Requires:       python-ecore = %{version}-%{release}
77 Requires:       python-edje = %{version}-%{release}
78 Requires:       python-elementary = %{version}-%{release}
79 Requires:       python-emotion = %{version}-%{release}
80 Requires:       python-evas = %{version}-%{release}
81
82 %description examples
83 Examples for PYTHON-EFL bindings.
84
85 %description examples -l pl.UTF-8
86 Przykłady do wiązań PYTHON-EFL.
87
88 %package -n python-e_dbus
89 Summary:        D-Bus Python integration for Ecore main loop
90 Summary(pl.UTF-8):      Integracja Python i DBus z główną pętlą Ecore
91 Group:          Development/Languages/Python
92 Requires:       %{name}-base = %{version}-%{release}
93 Requires:       ecore >= %{ecore_ver}
94 Obsoletes:      python-e_dbus < 1.8.0
95
96 %description -n python-e_dbus
97 D-Bus Python integration for Ecore main loop. There is also e_dbus
98 API provided for compatibility with EFL 1.7.0 bindings.
99
100 %description -n python-e_dbus -l pl.UTF-8
101 Integracja Python i DBus z główną pętlą Ecore. Dołączone jest także
102 API e_dbus dla kompatybilności z wiązaniami EFL 1.7.0.
103
104 %package -n python-ecore
105 Summary:        Python bindings for Ecore library
106 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Ecore
107 Group:          Development/Languages/Python
108 Requires:       %{name}-base = %{version}-%{release}
109 Requires:       ecore >= %{ecore_ver}
110 Requires:       ecore-file >= %{ecore_file_ver}
111 Obsoletes:      python-ecore-devel < 1.8.0
112 Obsoletes:      python-ecore-evas < 1.8.0
113 Obsoletes:      python-ecore-evas-devel < 1.8.0
114 Obsoletes:      python-ecore-file < 1.8.0
115 Obsoletes:      python-ecore-file-devel < 1.8.0
116 Obsoletes:      python-ecore-imf < 1.8.0
117 Obsoletes:      python-ecore-imf-devel < 1.8.0
118 Obsoletes:      python-ecore-x < 1.8.0
119 Obsoletes:      python-ecore-x-devel < 1.8.0
120
121 %description -n python-ecore
122 Python bindings for Ecore library.
123
124 %description -n python-ecore -l pl.UTF-8
125 Wiązania Pythona do biblioteki Ecore.
126
127 %package -n python-edje
128 Summary:        Python bindings for Edje library
129 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Edje
130 Group:          Development/Languages/Python
131 Requires:       %{name}-base = %{version}-%{release}
132 Requires:       edje-libs >= %{edje_ver}
133 Requires:       eina >= %{eina_ver}
134 Obsoletes:      python-edje-devel < 1.8.0
135
136 %description -n python-edje
137 Python bindings for Edje library.
138
139 %description -n python-edje -l pl.UTF-8
140 Wiązania Pythona do biblioteki Edje.
141
142 %package -n python-elementary
143 Summary:        Python bindings for Elementary library
144 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary
145 Group:          Development/Languages/Python
146 Requires:       %{name}-base = %{version}-%{release}
147 Requires:       eina >= %{eina_ver}
148 Requires:       elementary-libs >= %{elementary_ver}
149 Requires:       evas >= %{evas_ver}
150 Obsoletes:      python-elementary-devel < 1.8.0
151
152 %description -n python-elementary
153 Python bindings for Elementary library.
154
155 %description -n python-elementary -l pl.UTF-8
156 Wiązania Pythona do biblioteki Elementary.
157
158 %package -n python-emotion
159 Summary:        Python bindings for Emotion library
160 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Emotion
161 Group:          Development/Languages/Python
162 Requires:       %{name}-base = %{version}-%{release}
163 Requires:       emotion >= %{emotion_ver}
164 Requires:       evas >= %{evas_ver}
165 Obsoletes:      python-emotion-devel < 1.8.0
166
167 %description -n python-emotion
168 Python bindings for Emotion library.
169
170 %description -n python-emotion -l pl.UTF-8
171 Wiązania Pythona do biblioteki Emotion.
172
173 %package -n python-evas
174 Summary:        Python bindings for Evas library
175 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Evas
176 Group:          Development/Languages/Python
177 Requires:       %{name}-base = %{version}-%{release}
178 Requires:       eina >= %{eina_ver}
179 Requires:       evas >= %{evas_ver}
180 Obsoletes:      python-evas-devel < 1.8.0
181
182 %description -n python-evas
183 Python bindings for Evas library.
184
185 %description -n python-evas -l pl.UTF-8
186 Wiązania Pythona do biblioteki Evas.
187
188 %prep
189 %setup -q
190
191 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' \
192         examples/dbus/*.py \
193         examples/elementary/*.py \
194         examples/emotion/*.py \
195
196 %build
197 CC="%{__cc}" \
198 CFLAGS="%{rpmcflags}" \
199 %{__python} setup.py build
200
201 %install
202 rm -rf $RPM_BUILD_ROOT
203
204 %{__python} setup.py install \
205         --skip-build \
206         --root=$RPM_BUILD_ROOT \
207         --optimize=2
208
209 %py_postclean
210
211 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
212 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
213
214 %clean
215 rm -rf $RPM_BUILD_ROOT
216
217 %files base
218 %defattr(644,root,root,755)
219 %doc AUTHORS README changes.html
220 %dir %{py_sitedir}/efl
221 %{py_sitedir}/efl/__init__.py[co]
222 %attr(755,root,root) %{py_sitedir}/efl/eo.so
223 %dir %{py_sitedir}/efl/utils
224 %{py_sitedir}/efl/utils/__init__.py[co]
225 %attr(755,root,root) %{py_sitedir}/efl/utils/*.so
226 %{py_sitedir}/python_efl-%{version}-py*.egg-info
227
228 %files examples
229 %defattr(644,root,root,755)
230 %dir %{_examplesdir}/%{name}-%{version}
231 %dir %{_examplesdir}/%{name}-%{version}/dbus
232 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/dbus/*.py
233 %dir %{_examplesdir}/%{name}-%{version}/elementary
234 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/elementary/test.py
235 %{_examplesdir}/%{name}-%{version}/elementary/test_*.py
236 %{_examplesdir}/%{name}-%{version}/elementary/*.edc
237 %{_examplesdir}/%{name}-%{version}/elementary/*.edj
238 %{_examplesdir}/%{name}-%{version}/elementary/images
239 %dir %{_examplesdir}/%{name}-%{version}/emotion
240 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/emotion/test_emotion.py
241 %{_examplesdir}/%{name}-%{version}/emotion/theme.edj
242
243 %files -n python-e_dbus
244 %defattr(644,root,root,755)
245 %attr(755,root,root) %{py_sitedir}/efl/dbus_mainloop.so
246 %{py_sitedir}/e_dbus
247
248 %files -n python-ecore
249 %defattr(644,root,root,755)
250 %attr(755,root,root) %{py_sitedir}/efl/ecore.so
251 %{py_sitedir}/ecore
252
253 %files -n python-edje
254 %defattr(644,root,root,755)
255 %attr(755,root,root) %{py_sitedir}/efl/edje.so
256 %attr(755,root,root) %{py_sitedir}/efl/edje_edit.so
257 %{py_sitedir}/edje
258
259 %files -n python-elementary
260 %defattr(644,root,root,755)
261 %dir %{py_sitedir}/efl/elementary
262 %{py_sitedir}/efl/elementary/__init__.py[co]
263 %attr(755,root,root) %{py_sitedir}/efl/elementary/*.so
264 %{py_sitedir}/elementary
265
266 %files -n python-emotion
267 %defattr(644,root,root,755)
268 %attr(755,root,root) %{py_sitedir}/efl/emotion.so
269 %{py_sitedir}/emotion
270
271 %files -n python-evas
272 %defattr(644,root,root,755)
273 %attr(755,root,root) %{py_sitedir}/efl/evas.so
274 %{py_sitedir}/evas
This page took 0.126817 seconds and 2 git commands to generate.