]> git.pld-linux.org Git - packages/python-efl.git/blob - python-efl.spec
- updated to 1.8.1
[packages/python-efl.git] / python-efl.spec
1 %define         ecore_ver       1.8.0
2 %define         edje_ver        1.8.0
3 %define         eina_ver        1.8.0
4 %define         emotion_ver     1.8.0
5 %define         eo_ver          1.8.0
6 %define         evas_ver        1.8.0
7 %define         elementary_ver  1.8.0
8 %define         py_dbus_ver     0.83.0
9
10 Summary:        Python bindings for Enlightenment Foundation Libraries
11 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
12 Name:           python-efl
13 Version:        1.8.1
14 Release:        1
15 License:        LGPL v3+
16 Group:          Development/Languages/Python
17 Source0:        http://download.enlightenment.org/rel/bindings/python/%{name}-%{version}.tar.bz2
18 # Source0-md5:  dafb875fbe7f5874ecf3db3cf351e1fe
19 URL:            http://trac.enlightenment.org/e/wiki/Python
20 BuildRequires:  python-dbus-devel >= %{py_dbus_ver}
21 BuildRequires:  ecore-devel >= %{ecore_ver}
22 BuildRequires:  ecore-file-devel >= %{ecore_ver}
23 BuildRequires:  edje-devel >= %{edje_ver}
24 BuildRequires:  eina-devel >= %{eina_ver}
25 BuildRequires:  elementary-devel >= %{elementary_ver}
26 BuildRequires:  emotion-devel >= %{emotion_ver}
27 BuildRequires:  eo-devel >= %{eo_ver}
28 BuildRequires:  evas-devel >= %{evas_ver}
29 BuildRequires:  pkgconfig
30 # when using *.pyx sources, not pregenerated *.c
31 #BuildRequires: python-Cython >= 0.17.0
32 BuildRequires:  python-Sphinx
33 BuildRequires:  python-devel >= 1:2.7
34 BuildRequires:  rpm-pythonprov
35 BuildRequires:  rpmbuild(macros) >= 1.219
36 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
37
38 %description
39 EFL is a collection of libraries for handling many common tasks a
40 developer man have such as data structures, communication, rendering,
41 widgets and more. PYTHON-EFL are the Python bindings for EFL and
42 Elementary.
43
44 %description -l pl.UTF-8
45 EFL to zbiór bibliotek do obsługi wielu częstych zadań programisty,
46 takich jak struktury danych, komunikacja, renderowanie, widgety itp.
47 PYTHON-EFL to wiązania Pythona do bibliotek EFL i Elementary.
48
49 %package base
50 Summary:        Python bindings for Enlightenment Foundation Libraries - base common part
51 Summary(pl.UTF-8):      Wiązania Pythona do bibliotek EFL - wspólna część podstawowa
52 Group:          Development/Languages/Python
53 Requires:       eina >= %{eina_ver}
54 Requires:       eo >= %{eina_ver}
55
56 %description base
57 Python bindings for Enlightenment Foundation Libraries - base common
58 part:
59 - Eo library binding
60 - efl.utils modules
61
62 %description base
63 Wiązania Pythona do bibliotek EFL (Enlightenment Foundation Libraries)
64 - wspólna część podstawowa:
65 - wiązanie do biblioteki Eo
66 - moduły efl.utils
67
68 %package examples
69 Summary:        Examples for PYTHON-EFL bindings
70 Summary(pl.UTF-8):      Przykłady do wiązań PYTHON-EFL
71 Group:          Development/Libraries
72 Requires:       python-dbus >= %{py_dbus_ver}
73 Requires:       python-e_dbus = %{version}-%{release}
74 Requires:       python-ecore = %{version}-%{release}
75 Requires:       python-edje = %{version}-%{release}
76 Requires:       python-elementary = %{version}-%{release}
77 Requires:       python-emotion = %{version}-%{release}
78 Requires:       python-evas = %{version}-%{release}
79
80 %description examples
81 Examples for PYTHON-EFL bindings.
82
83 %description examples -l pl.UTF-8
84 Przykłady do wiązań PYTHON-EFL.
85
86 %package -n python-e_dbus
87 Summary:        D-Bus Python integration for Ecore main loop
88 Summary(pl.UTF-8):      Integracja Python i DBus z główną pętlą Ecore
89 Group:          Development/Languages/Python
90 Requires:       %{name}-base = %{version}-%{release}
91 Requires:       ecore >= %{ecore_ver}
92 Obsoletes:      python-e_dbus < 1.8.0
93
94 %description -n python-e_dbus
95 D-Bus Python integration for Ecore main loop. There is also e_dbus
96 API provided for compatibility with EFL 1.7.0 bindings.
97
98 %description -n python-e_dbus -l pl.UTF-8
99 Integracja Python i DBus z główną pętlą Ecore. Dołączone jest także
100 API e_dbus dla kompatybilności z wiązaniami EFL 1.7.0.
101
102 %package -n python-ecore
103 Summary:        Python bindings for Ecore library
104 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Ecore
105 Group:          Development/Languages/Python
106 Requires:       %{name}-base = %{version}-%{release}
107 Requires:       ecore >= %{ecore_ver}
108 Requires:       ecore-file >= %{ecore_ver}
109 Obsoletes:      python-ecore-devel < 1.8.0
110 Obsoletes:      python-ecore-evas < 1.8.0
111 Obsoletes:      python-ecore-evas-devel < 1.8.0
112 Obsoletes:      python-ecore-file < 1.8.0
113 Obsoletes:      python-ecore-file-devel < 1.8.0
114 Obsoletes:      python-ecore-imf < 1.8.0
115 Obsoletes:      python-ecore-imf-devel < 1.8.0
116 Obsoletes:      python-ecore-x < 1.8.0
117 Obsoletes:      python-ecore-x-devel < 1.8.0
118
119 %description -n python-ecore
120 Python bindings for Ecore library.
121
122 %description -n python-ecore -l pl.UTF-8
123 Wiązania Pythona do biblioteki Ecore.
124
125 %package -n python-edje
126 Summary:        Python bindings for Edje library
127 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Edje
128 Group:          Development/Languages/Python
129 Requires:       %{name}-base = %{version}-%{release}
130 Requires:       edje-libs >= %{edje_ver}
131 Requires:       eina >= %{eina_ver}
132 Obsoletes:      python-edje-devel < 1.8.0
133
134 %description -n python-edje
135 Python bindings for Edje library.
136
137 %description -n python-edje -l pl.UTF-8
138 Wiązania Pythona do biblioteki Edje.
139
140 %package -n python-elementary
141 Summary:        Python bindings for Elementary library
142 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Elementary
143 Group:          Development/Languages/Python
144 Requires:       %{name}-base = %{version}-%{release}
145 Requires:       eina >= %{eina_ver}
146 Requires:       elementary-libs >= %{elementary_ver}
147 Requires:       evas >= %{evas_ver}
148 Obsoletes:      python-elementary-devel < 1.8.0
149
150 %description -n python-elementary
151 Python bindings for Elementary library.
152
153 %description -n python-elementary -l pl.UTF-8
154 Wiązania Pythona do biblioteki Elementary.
155
156 %package -n python-emotion
157 Summary:        Python bindings for Emotion library
158 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Emotion
159 Group:          Development/Languages/Python
160 Requires:       %{name}-base = %{version}-%{release}
161 Requires:       emotion >= %{emotion_ver}
162 Requires:       evas >= %{evas_ver}
163 Obsoletes:      python-emotion-devel < 1.8.0
164
165 %description -n python-emotion
166 Python bindings for Emotion library.
167
168 %description -n python-emotion -l pl.UTF-8
169 Wiązania Pythona do biblioteki Emotion.
170
171 %package -n python-evas
172 Summary:        Python bindings for Evas library
173 Summary(pl.UTF-8):      Wiązania Pythona do biblioteki Evas
174 Group:          Development/Languages/Python
175 Requires:       %{name}-base = %{version}-%{release}
176 Requires:       eina >= %{eina_ver}
177 Requires:       evas >= %{evas_ver}
178 Obsoletes:      python-evas-devel < 1.8.0
179
180 %description -n python-evas
181 Python bindings for Evas library.
182
183 %description -n python-evas -l pl.UTF-8
184 Wiązania Pythona do biblioteki Evas.
185
186 %prep
187 %setup -q
188
189 %{__sed} -i -e '1s,/usr/bin/env python,/usr/bin/python,' \
190         examples/dbus/*.py \
191         examples/elementary/*.py \
192         examples/emotion/*.py \
193
194 %build
195 CC="%{__cc}" \
196 CFLAGS="%{rpmcflags}" \
197 %{__python} setup.py build
198
199 %install
200 rm -rf $RPM_BUILD_ROOT
201
202 %{__python} setup.py install \
203         --skip-build \
204         --root=$RPM_BUILD_ROOT \
205         --optimize=2
206
207 %py_postclean
208
209 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
210 cp -pr examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
211
212 %clean
213 rm -rf $RPM_BUILD_ROOT
214
215 %files base
216 %defattr(644,root,root,755)
217 %doc AUTHORS README changes.html
218 %dir %{py_sitedir}/efl
219 %{py_sitedir}/efl/__init__.py[co]
220 %attr(755,root,root) %{py_sitedir}/efl/eo.so
221 %dir %{py_sitedir}/efl/utils
222 %{py_sitedir}/efl/utils/__init__.py[co]
223 %attr(755,root,root) %{py_sitedir}/efl/utils/*.so
224 %{py_sitedir}/python_efl-%{version}-py*.egg-info
225
226 %files examples
227 %defattr(644,root,root,755)
228 %dir %{_examplesdir}/%{name}-%{version}
229 %dir %{_examplesdir}/%{name}-%{version}/dbus
230 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/dbus/*.py
231 %dir %{_examplesdir}/%{name}-%{version}/elementary
232 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/elementary/test.py
233 %{_examplesdir}/%{name}-%{version}/elementary/test_*.py
234 %{_examplesdir}/%{name}-%{version}/elementary/*.edc
235 %{_examplesdir}/%{name}-%{version}/elementary/*.edj
236 %{_examplesdir}/%{name}-%{version}/elementary/images
237 %dir %{_examplesdir}/%{name}-%{version}/emotion
238 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/emotion/test_emotion.py
239 %{_examplesdir}/%{name}-%{version}/emotion/theme.edj
240
241 %files -n python-e_dbus
242 %defattr(644,root,root,755)
243 %attr(755,root,root) %{py_sitedir}/efl/dbus_mainloop.so
244 %{py_sitedir}/e_dbus
245
246 %files -n python-ecore
247 %defattr(644,root,root,755)
248 %attr(755,root,root) %{py_sitedir}/efl/ecore.so
249 %{py_sitedir}/ecore
250
251 %files -n python-edje
252 %defattr(644,root,root,755)
253 %attr(755,root,root) %{py_sitedir}/efl/edje.so
254 %attr(755,root,root) %{py_sitedir}/efl/edje_edit.so
255 %{py_sitedir}/edje
256
257 %files -n python-elementary
258 %defattr(644,root,root,755)
259 %dir %{py_sitedir}/efl/elementary
260 %{py_sitedir}/efl/elementary/__init__.py[co]
261 %attr(755,root,root) %{py_sitedir}/efl/elementary/*.so
262 %{py_sitedir}/elementary
263
264 %files -n python-emotion
265 %defattr(644,root,root,755)
266 %attr(755,root,root) %{py_sitedir}/efl/emotion.so
267 %{py_sitedir}/emotion
268
269 %files -n python-evas
270 %defattr(644,root,root,755)
271 %attr(755,root,root) %{py_sitedir}/efl/evas.so
272 %{py_sitedir}/evas
This page took 0.080593 seconds and 3 git commands to generate.