]> git.pld-linux.org Git - packages/python-djblets.git/blob - python-djblets.spec
98644656dff9440a6dc48249ddf7deaf5f2a0cab
[packages/python-djblets.git] / python-djblets.spec
1 # TODO
2 # - use system jquery, jquery-ui
3 Summary:        A collection of useful classes and functions for Django
4 Name:           python-djblets
5 Version:        0.7.8
6 Release:        1
7 Group:          Applications/Networking
8 # Djblets is MIT licensed:
9 # http://code.google.com/p/reviewboard/wiki/Djblets
10 # jQuery is bundled in Djblets. Jquery is dual-licensed MIT or GPLv2, hence
11 # the package license is "MIT and (MIT or GPLv2)":
12 # https://www.redhat.com/archives/fedora-legal-list/2009-May/msg00025.html
13 License:        MIT and (MIT or GPL v2)
14 URL:            http://www.review-board.org/
15 Source0:        http://downloads.review-board.org/releases/Djblets/0.7/Djblets-%{version}.tar.gz
16 # Source0-md5:  9540b0d25ba632c38cc3e3a41e659564
17 BuildRequires:  python
18 BuildRequires:  python-devel
19 BuildRequires:  python-django-pipeline >= 1.2.16
20 BuildRequires:  python-modules
21 BuildRequires:  python-setuptools
22 BuildRequires:  rpm-pythonprov
23 BuildRequires:  sed >= 4.0
24 Requires:       python-PIL
25 Requires:       python-django >= 1.4.2
26 Requires:       python-django-pipeline >= 1.2.16
27 Requires:       python-feedparser >= 5.1.2
28 Requires:       python-pytz
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 A collection of useful classes and functions for Django
34
35 %prep
36 %setup -q -n Djblets-%{version}
37
38 # Remove packaged egg-info so it's regenerated by setup.py
39 %{__rm} -r Djblets*.egg-info
40
41 %build
42 %{__python} setup.py build
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 %{__python} setup.py install \
47         --optimize=2 \
48         --root=$RPM_BUILD_ROOT
49
50 %py_postclean
51
52 # Remove bundled copy of feedparser.py
53 #%{__rm} $RPM_BUILD_ROOT%{py_sitescriptdir}/djblets/feedview/feedparser.py*
54
55 # Remove the "tests" subdirectory to avoid it polluting the main python namespace:
56 %{__rm} -r $RPM_BUILD_ROOT%{py_sitescriptdir}/tests
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc NEWS
64 %{py_sitescriptdir}/djblets
65 %{py_sitescriptdir}/Djblets*.egg-info
This page took 0.070474 seconds and 2 git commands to generate.