]> git.pld-linux.org Git - packages/python-distribute.git/blob - python-distribute.spec
b5edd03e6ce9b0a125eb03b0cb64f1c25861978f
[packages/python-distribute.git] / python-distribute.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         pname   distribute
7 Summary:        distribute compatibility wrapper for setuptools
8 Summary(pl.UTF-8):      Nakładka na python-setuptools zastępujące distribute
9 Name:           python-distribute
10 Version:        0.7.3
11 Release:        5
12 License:        PSF or ZPL
13 Group:          Development/Languages/Python
14 Source0:        https://pypi.python.org/packages/source/d/distribute/distribute-%{version}.zip
15 # Source0-md5:  c6c59594a7b180af57af8a0cc0cf5b4a
16 URL:            https://pypi.python.org/pypi/distribute
17 %if %{with python2}
18 BuildRequires:  python-setuptools > 1:7.0
19 BuildConflicts: python-distribute < 0.7
20 %endif
21 %if %{with python3}
22 BuildRequires:  python3-setuptools > 1:7.0
23 BuildConflicts: python3-distribute < 0.7
24 %endif
25 BuildRequires:  rpm-pythonprov
26 BuildRequires:  rpmbuild(macros) >= 1.523
27 Requires:       python-setuptools > 1:7.0
28 BuildArch:      noarch
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 Distribute was a fork of the Setuptools project. This package replaces
33 this fork with current Setuptools wrapper.
34
35 %description -l pl.UTF-8
36 Distribute było odgałęzieniem (forkiem) projektu Setuptools. Teraz
37 jest tylko nakładką na współczesne Setuptools.
38
39 %package -n python3-%{pname}
40 Summary:        Easily download, build, install, upgrade, and uninstall Python 3.x packages
41 Summary(pl.UTF-8):      Łatwe ściąganie, budowanie, instalowanie, uaktualnianie i usuwanie pakietów Pythona 3.x
42 Group:          Development/Languages/Python
43 Requires:       python3-setuptools > 1:7.0
44
45 %description -n python3-%{pname}
46 Distribute was a fork of the Setuptools project. This package replaces
47 this fork with current Setuptools wrapper.
48
49 %description -n python3-%{pname} -l pl.UTF-8
50 Distribute było odgałęzieniem (forkiem) projektu Setuptools. Teraz
51 jest tylko nakładką na współczesne Setuptools.
52
53 %prep
54 %setup -q -n %{pname}-%{version}
55
56 %build
57 %if %{with python2}
58 %{__python} setup.py \
59         build -b build-2
60 %endif
61
62 %if %{with python3}
63 %{__python3} setup.py \
64         build -b build-3
65 %endif
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %if %{with python2}
71 %{__python} -- setup.py \
72         build -b build-2 \
73         install \
74         --root=$RPM_BUILD_ROOT \
75         --optimize=2
76 %py_postclean
77 %endif
78
79 %if %{with python3}
80 %{__python3} -- setup.py \
81         build -b build-3 \
82         install \
83         --root=$RPM_BUILD_ROOT \
84         --optimize=2
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{with python2}
91 %files
92 %defattr(644,root,root,755)
93 %{py_sitescriptdir}/distribute-%{version}-py*.egg-info
94 %endif
95
96 %if %{with python3}
97 %files -n python3-%{pname}
98 %defattr(644,root,root,755)
99 %{py3_sitescriptdir}/distribute-%{version}-py*.egg-info
100 %endif
This page took 0.1539 seconds and 2 git commands to generate.