]> git.pld-linux.org Git - packages/python-distribute.git/blob - python-distribute.spec
10f294d7bb23020fa572ec93fbaea5e13993b95d
[packages/python-distribute.git] / python-distribute.spec
1 #
2 # Conditional build:
3 %bcond_without  python2 # CPython 2.x module
4 %bcond_without  python3 # CPython 3.x module
5
6 %define         pname   distribute
7 Summary:        distribute compatibility wrapper for setuptools
8 Summary(pl.UTF-8):      Nakładka na python-setuptools zastępujące distribute
9 Name:           python-distribute
10 Version:        0.7.3
11 Release:        10
12 License:        PSF or ZPL
13 Group:          Development/Languages/Python
14 Source0:        https://pypi.python.org/packages/source/d/distribute/distribute-%{version}.zip
15 # Source0-md5:  c6c59594a7b180af57af8a0cc0cf5b4a
16 Patch0:         python-distribute-build.patch
17 URL:            https://pypi.python.org/pypi/distribute
18 %if %{with python2}
19 BuildRequires:  python-setuptools > 1:7.0
20 BuildConflicts: python-distribute < 0.7
21 %endif
22 %if %{with python3}
23 BuildRequires:  python3-setuptools > 1:7.0
24 BuildConflicts: python3-distribute < 0.7
25 %endif
26 BuildRequires:  rpm-pythonprov
27 BuildRequires:  rpmbuild(macros) >= 1.713
28 Requires:       python-setuptools > 1:7.0
29 BuildArch:      noarch
30 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
31
32 %description
33 Distribute was a fork of the Setuptools project. This package replaces
34 this fork with current Setuptools wrapper.
35
36 %description -l pl.UTF-8
37 Distribute było odgałęzieniem (forkiem) projektu Setuptools. Teraz
38 jest tylko nakładką na współczesne Setuptools.
39
40 %package -n python3-%{pname}
41 Summary:        Easily download, build, install, upgrade, and uninstall Python 3.x packages
42 Summary(pl.UTF-8):      Łatwe ściąganie, budowanie, instalowanie, uaktualnianie i usuwanie pakietów Pythona 3.x
43 Group:          Development/Languages/Python
44 Requires:       python3-setuptools > 1:7.0
45
46 %description -n python3-%{pname}
47 Distribute was a fork of the Setuptools project. This package replaces
48 this fork with current Setuptools wrapper.
49
50 %description -n python3-%{pname} -l pl.UTF-8
51 Distribute było odgałęzieniem (forkiem) projektu Setuptools. Teraz
52 jest tylko nakładką na współczesne Setuptools.
53
54 %prep
55 %setup -q -n %{pname}-%{version}
56 %patch0 -p1
57
58 %build
59 %if %{with python2}
60 %py_build
61 %endif
62
63 %if %{with python3}
64 %py3_build
65 %endif
66
67 %install
68 rm -rf $RPM_BUILD_ROOT
69
70 %if %{with python2}
71 %py_install
72 %endif
73
74 %if %{with python3}
75 %py3_install
76 %endif
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %if %{with python2}
82 %files
83 %defattr(644,root,root,755)
84 %{py_sitescriptdir}/distribute-%{version}-py*.egg-info
85 %endif
86
87 %if %{with python3}
88 %files -n python3-%{pname}
89 %defattr(644,root,root,755)
90 %{py3_sitescriptdir}/distribute-%{version}-py*.egg-info
91 %endif
This page took 0.053738 seconds and 2 git commands to generate.