]> git.pld-linux.org Git - packages/python-Sphinx-PyPI-upload.git/blob - python-Sphinx-PyPI-upload.spec
BR: rpmbuild(macros) >= 1.710
[packages/python-Sphinx-PyPI-upload.git] / python-Sphinx-PyPI-upload.spec
1 #
2 # Conditional build:
3 # %bcond_without        tests   # do not perform "make test"
4
5 %define         module  Sphinx-PyPI-upload
6 Summary:        setuptools command for uploading Sphinx documentation to PyPI
7 Summary(pl.UTF-8):      komenda setuptools do publikowana dokumentacji Sphinx na PyPI
8 Name:           python-%{module}
9 Version:        0.2.1
10 Release:        2
11 License:        BSD-3
12 Group:          Development/Languages/Python
13 Source0:        http://pypi.python.org/packages/source/S/%{module}/%{module}-%{version}.tar.gz
14 # Source0-md5:  b9f1df5c8443197e4d49abbba1cfddc4
15 URL:            https://bitbucket.org/jezdez/sphinx-pypi-upload/
16 BuildRequires:  python-devel
17 BuildRequires:  python-distribute
18 BuildRequires:  rpm-pythonprov
19 # remove BR: python-devel for 'noarch' packages.
20 # if py_postclean is used
21 BuildRequires:  rpmbuild(macros) >= 1.710
22 #Requires:              python-libs
23 Requires:       python-modules
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 setuptools command for uploading Sphinx documentation to PyPI
29
30 %description -l pl.UTF-8
31 komenda setuptools do publikowana dokumentacji Sphinx na PyPI
32
33 %prep
34 %setup -q -n %{module}-%{version}
35
36 %build
37 %py_build
38
39 # %{?with_tests:%{__python} setup.py test}
40
41 %install
42 rm -rf $RPM_BUILD_ROOT
43 %py_install
44
45 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
46 %py_ocomp $RPM_BUILD_ROOT%{py_sitescriptdir}
47 %py_comp $RPM_BUILD_ROOT%{py_sitescriptdir}
48 %py_postclean
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %doc README
56 %{py_sitescriptdir}/*.py[co]
57 %if "%{py_ver}" > "2.4"
58 %{py_sitescriptdir}/Sphinx_PyPI_upload-*.egg-info
59 %endif
This page took 0.055852 seconds and 3 git commands to generate.