]> git.pld-linux.org Git - packages/pyp2rpm.git/blob - pyp2rpm.spec
up to 3.3.0
[packages/pyp2rpm.git] / pyp2rpm.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # do not perform "make test". requires network access, https://github.com/fedora-python/pyp2rpm/issues/57
4
5 Summary:        Convert Python packages to RPM .spec files
6 Name:           pyp2rpm
7 Version:        3.3.0
8 Release:        1
9 License:        MIT
10 Group:          Development
11 Source0:        https://github.com/fedora-python/pyp2rpm/archive/v%{version}/%{name}-%{version}.tar.gz
12 # Source0-md5:  9c744bc722f554cb22f63e1fd2b1a187
13 Patch0:         default-savepath.patch
14 Patch1:         no-rpmdev-packager.patch
15 Patch2:         default-distro.patch
16 URL:            https://github.com/fedora-python/pyp2rpm
17 BuildRequires:  python-flexmock >= 0.9.3
18 BuildRequires:  python-pytest
19 BuildRequires:  python-setuptools
20 BuildRequires:  rpm-pythonprov
21 BuildRequires:  rpmbuild(macros) >= 1.714
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 Convert Python packages to RPM .spec.
27
28 Users can provide their own templates for rendering the package
29 metadata. Both the package source and metadata can be extracted from
30 PyPI or from local filesystem (local file doesn't provide that much
31 information though).
32
33 %prep
34 %setup -q
35 %patch0 -p1
36 %patch1 -p1
37 %patch2 -p1
38
39 %build
40 %py_build
41
42 %if %{with tests}
43 PYTHONPATH=$(pwd) py.test
44 %endif
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %py_install
49 %py_postclean
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README.md LICENSE
57 %attr(755,root,root) %{_bindir}/pyp2rpm
58 %dir %{py_sitescriptdir}/%{name}
59 %{py_sitescriptdir}/%{name}/*.py[co]
60 %{py_sitescriptdir}/%{name}/command
61 %dir %{py_sitescriptdir}/%{name}/templates
62 %{py_sitescriptdir}/%{name}/templates/epel6.spec
63 %{py_sitescriptdir}/%{name}/templates/epel7.spec
64 %{py_sitescriptdir}/%{name}/templates/fedora.spec
65 %{py_sitescriptdir}/%{name}/templates/macros.spec
66 %{py_sitescriptdir}/%{name}/templates/mageia.spec
67 %{py_sitescriptdir}/%{name}/templates/pld.spec
68 %{py_sitescriptdir}/%{name}-%{version}-py*.egg-info
This page took 0.093433 seconds and 3 git commands to generate.