]> git.pld-linux.org Git - packages/povray.git/commitdiff
- use sources from pvmpov.sf.net to build PVM enabled POV-Ray
authorArtur Frysiak <artur@frysiak.net>
Thu, 16 Jan 2003 09:49:54 +0000 (09:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    povray.spec -> 1.35

povray.spec

index dc0131aa552c78e9aadc40bd6f340daa578d108f..021e86ba179fb005a6c792bd6c703a65b923d8a9 100644 (file)
@@ -2,12 +2,14 @@
 #
 # todo:
 #      patch for s#/usr/local#/usr# in povray.ini
+#      (no)svga version
 #
 
 # Conditional build:
 # _without_x   - without X11 subpackage
-# _without_pvm - [temporarily disabled by default] without PVM support
+# _without_pvm - without PVM support
 #
+%define                snap 20030110
 Summary:       Persistence of Vision Ray Tracer
 Summary(pl):   Persistence of Vision Ray Tracer
 Name:          povray
@@ -15,11 +17,12 @@ Version:    3.50c
 Release:       1
 License:       distributable
 Group:         Applications/Graphics
-Source0:       ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
+#Source0:      ftp://ftp.povray.org/pub/povray/Official/Unix/povuni_s.tgz
+# based on sources from CVS at http://pvmpov.sourceforge.net/
+Source0:       %{name}-%{version}-%{snap}.tar.gz
 Source1:       %{name}-%{version}.md5sum
 Patch0:                %{name}-legal.patch
 Patch1:                %{name}-types.patch
-# pvm support not yet available - http://pvmpov.sourceforge.net/
 URL:           http://www.povray.org/
 BuildRequires: libjpeg-devel
 BuildRequires: libpng-devel >= 1.0.8
@@ -31,6 +34,8 @@ BuildRequires:        zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _libdir         %{_datadir}
+%define                _pvmarch        %(/usr/bin/pvmgetarch)
+%define                _pvmroot        /usr/lib/pvm3/
 
 %description
 The Persistence of Vision(tm) Ray-Tracer creates three-dimensional,
@@ -92,11 +97,11 @@ Plik wykonywalny The Persistence of Vision(tm) Ray-Tracer dla
 PVM/xwin.
 
 %prep
-cd %{_sourcedir}
-md5sum -c %{name}-%{version}.md5sum
-cd -
+#cd %{_sourcedir}
+#md5sum -c %{name}-%{version}.md5sum
+#cd -
 %setup -q
-%patch0 -p1
+#%patch0 -p1
 %ifarch alpha
 %patch1 -p1
 %endif
@@ -105,6 +110,27 @@ cd -
 %{__aclocal}
 %{__autoconf}
 %{__automake}
+%if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
+%configure \
+       --enable-pvm \
+       --with-pvm-arch=%{_pvmarch} \
+       --x-includes=%{_prefix}/X11R6/include \
+       --x-libraries=%{_prefix}/X11R6/lib
+%{__make}
+install src/povray x-pvmpov
+%endif
+
+%if %{!?_without_pvm:1}%{?_without_pvm:0}
+%{__make} clean
+
+%configure \
+       --enable-pvm \
+       --with-pvm-arch=%{_pvmarch} \
+       --without-x
+%{__make}
+install src/povray pvmpov
+%endif
+
 %if %{!?_without_x:1}%{?_without_x:0}
 %configure \
        --x-includes=%{_prefix}/X11R6/include \
@@ -118,9 +144,11 @@ install src/povray x-povray
        --without-x
 %{__make}
 
+
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin} \
+       $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}
 
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
@@ -129,6 +157,14 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_prefix}/X11R6/bin}
 install x-povray $RPM_BUILD_ROOT%{_prefix}/X11R6/bin
 %endif
 
+%if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
+install x-pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
+%endif
+
+%if %{!?_without_pvm:1}%{?_without_pvm:0}
+install pvmpov $RPM_BUILD_ROOT%{_pvmroot}/bin/%{_pvmarch}/pvmpov
+%endif
+
 install povray.ini $RPM_BUILD_ROOT%{_sysconfdir}
 install povray.conf $RPM_BUILD_ROOT%{_sysconfdir}
 ln -sf %{_sysconfdir}/povray.ini $RPM_BUILD_ROOT%{_datadir}/povray-3.5/povray.ini
@@ -150,14 +186,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_prefix}/X11R6/bin/x-povray
 %endif
 
-#%if %{!?_without_pvm:1}%{?_without_pvm:0}
-#%files pvm
-#%defattr(644,root,root,755)
-#%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/pvmpov
-#
-#%if %{!?_without_x:1}%{?_without_x:0}
-#%files pvm-X11
-#%defattr(644,root,root,755)
-#%attr(755,root,root) %{_pvm_root}/bin/%{_pvm_arch}/x-pvmpov
-#%endif
-#%endif
+%if %{!?_without_pvm:1}%{?_without_pvm:0}
+%files pvm
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/pvmpov
+%endif
+
+%if %{!?_without_pvm:%{!?_without_x:1}%{?_without_x:0}}%{?_without_pvm:0}
+%files pvm-X11
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_pvmroot}/bin/%{_pvmarch}/x-pvmpov
+%endif
This page took 0.118395 seconds and 4 git commands to generate.