]> git.pld-linux.org Git - packages/pound.git/blob - pound.spec
- up to 2.6, supports SNI and multiple AddHeader
[packages/pound.git] / pound.spec
1 Summary:        Pound - reverse-proxy and load-balancer
2 Summary(pl.UTF-8):      Pound - reverse-proxy i load-balancer
3 Name:           pound
4 Version:        2.6
5 Release:        1
6 License:        GPL
7 Group:          Networking/Daemons
8 Source0:        http://www.apsis.ch/pound/Pound-%{version}.tgz
9 # Source0-md5:  8c913b527332694943c4c67c8f152071
10 Patch0:         %{name}-hash-UL.patch
11 Patch1:         %{name}-logfile.patch
12 Patch2:         %{name}-daemonize.patch
13 Patch3:         %{name}-log-notice.patch
14 Patch4:         %{name}-man.patch
15 Source1:        %{name}.cfg
16 Source2:        %{name}.init
17 Source3:        %{name}.sysconfig
18 Source4:        %{name}.logrotate
19 URL:            http://www.apsis.ch/pound/
20 BuildRequires:  automake
21 BuildRequires:  openssl-devel >= 0.9.7d
22 BuildRequires:  openssl-tools
23 BuildRequires:  pcre-devel
24 BuildRequires:  rpmbuild(macros) >= 1.202
25 Requires(post,preun):   /sbin/chkconfig
26 Requires(postun):       /usr/sbin/groupdel
27 Requires(postun):       /usr/sbin/userdel
28 Requires(pre):  /bin/id
29 Requires(pre):  /usr/bin/getgid
30 Requires(pre):  /usr/sbin/groupadd
31 Requires(pre):  /usr/sbin/useradd
32 Requires:       pcre >= 7.8
33 Requires:       rc-scripts
34 Provides:       group(pound)
35 Provides:       user(pound)
36 Conflicts:      logrotate < 3.7-4
37 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
38
39 %define         _sysconfdir     /etc/pound
40
41 %description
42 The Pound program is a reverse proxy, load balancer and HTTPS
43 front-end for Web server(s). Pound was developped to enable
44 distributing the load among several Web-servers and to allow for a
45 convenient SSL wrapper for those Web servers that do not offer it
46 natively. Pound is distributed under the GPL - no warranty, it's free
47 to use, copy and give away.
48
49 %description -l pl.UTF-8
50 Program Pound jest odwrotnym proxy, load-balancerem i interfejsem
51 HTTPS do serwera(ów) WWW. Pount został stworzony by pozwolić na
52 rozdzielenie obciążenia na kilka serwerów WWW i pozwolić na wygodne
53 opakowanie SSL-em tych serwerów, które same nie obsługują SSL. Pound
54 jest rozpowszechniany na licencji GPL - bez gwarancji, z możliwością
55 swobodnego używania, kopiowania i rozdawania.
56
57 %prep
58 %setup -q -n Pound-%{version}
59 %patch0 -p1
60 %patch1 -p1
61 %patch2 -p1
62 %patch3 -p1
63 %patch4 -p1
64
65 %build
66 cp -f /usr/share/automake/config.sub .
67 %configure \
68         --with-maxbuf=2048
69 %{__make}
70
71 %install
72 rm -rf $RPM_BUILD_ROOT
73 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8,%{_sysconfdir},/etc/{sysconfig,logrotate.d,rc.d/init.d}} \
74         $RPM_BUILD_ROOT{/var/log/{%{name},archive/%{name}},/var/run/%{name}}
75
76 install -p pound    $RPM_BUILD_ROOT%{_sbindir}
77 install -p poundctl $RPM_BUILD_ROOT%{_sbindir}
78 cp -p pound.8  $RPM_BUILD_ROOT%{_mandir}/man8
79 cp -p poundctl.8 $RPM_BUILD_ROOT%{_mandir}/man8
80 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}
81 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}
82 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/sysconfig/%{name}
83 cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
84
85 %clean
86 rm -rf $RPM_BUILD_ROOT
87
88 %pre
89 %groupadd -g 200 %{name}
90 %useradd -u 200 -d /var/lib/%{name} -g %{name} -c "Pound Daemon" %{name}
91
92 %post
93 for a in access.log pound.log; do
94         if [ ! -f /var/log/%{name}/$a ]; then
95                 touch /var/log/%{name}/$a
96                 chown pound:pound /var/log/%{name}/$a
97                 chmod 644 /var/log/%{name}/$a
98         fi
99 done
100 /sbin/chkconfig --add %{name}
101 %service %{name} restart "Pound Daemon"
102
103 %preun
104 if [ "$1" = "0" ]; then
105         %service %{name} stop
106         /sbin/chkconfig --del %{name}
107 fi
108
109 %postun
110 if [ "$1" = "0" ]; then
111         %userremove %{name}
112         %groupremove %{name}
113 fi
114
115 %files
116 %defattr(644,root,root,755)
117 %doc README FAQ CHANGELOG z*.py
118 %attr(755,root,root) %{_sbindir}/pound
119 %attr(755,root,root) %{_sbindir}/poundctl
120 %dir %{_sysconfdir}
121 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/pound.cfg
122 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
123 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
124 %attr(754,root,root) /etc/rc.d/init.d/%{name}
125 %{_mandir}/man8/*
126 %dir /var/run/%{name}
127 %dir %attr(751,root,root) /var/log/%{name}
128 %attr(750,root,root) %dir /var/log/archive/%{name}
This page took 0.093517 seconds and 4 git commands to generate.