]> git.pld-linux.org Git - packages/postfix.git/blob - postfix.spec
c3b798ce1e16a4c50407b64dbbc4db994e513448
[packages/postfix.git] / postfix.spec
1 #
2 # Conditional build:
3 %bcond_without  ldap    # without LDAP map module
4 %bcond_without  mysql   # without MySQL map module
5 %bcond_without  pgsql   # without PostgreSQL map module
6 %bcond_without  sqlite  # without SQLite map module
7 %bcond_without  sasl    # without SMTP AUTH support
8 %bcond_without  ssl     # without SSL/TLS support
9 %bcond_without  cdb     # without cdb map support
10 %if "%{pld_release}" == "th"
11 %bcond_without  vda     # without VDA patch
12 %else
13 %bcond_with     vda     # with VDA patch
14 %endif
15 %bcond_with     hir     # with Beeth's header_if_reject patch
16 %bcond_with     tcp     # with unofficial tcp: lookup table
17 %if "%{pld_release}" == "ac"
18 %bcond_with             epoll   # enable epoll for 2.6 kernels
19 # there didn't exist x86_64 2.4 kernel in PLD, so can safely enable epoll
20 %ifarch %{x8664}
21 %define         with_epoll      1
22 %endif
23 %else
24 %bcond_without  epoll   # disable epoll for 2.4 kernels
25 %endif
26
27 %define         vda_ver v13-2.10.0
28 Summary:        Postfix Mail Transport Agent
29 Summary(cs.UTF-8):      Postfix - program pro přepravu pošty (MTA)
30 Summary(es.UTF-8):      Postfix - Un MTA (Mail Transport Agent) de alto desempeño
31 Summary(fr.UTF-8):      Agent de transport de courrier Postfix
32 Summary(pl.UTF-8):      Serwer SMTP Postfix
33 Summary(pt_BR.UTF-8):   Postfix - Um MTA (Mail Transport Agent) de alto desempenho
34 Summary(sk.UTF-8):      Agent prenosu pošty Postfix
35 Name:           postfix
36 Version:        2.11.10
37 Release:        1
38 Epoch:          2
39 License:        distributable
40 Group:          Networking/Daemons/SMTP
41 Source0:        ftp://ftp.porcupine.org/mirrors/postfix-release/official/%{name}-%{version}.tar.gz
42 # Source0-md5:  0f947753a3864dc3bd40aa211f3202bb
43 Source1:        %{name}.aliases
44 Source2:        %{name}.cron
45 Source3:        %{name}.init
46 Source4:        %{name}.sysconfig
47 Source5:        %{name}.sasl
48 Source6:        %{name}.pamd
49 Source7:        %{name}-vda.patch
50 #Source7:       http://vda.sourceforge.net/VDA/%{name}-vda-%{vda_ver}.patch
51 # -ource7-md5:  01e1b031d79b85f3cb67d98ceddd775d
52 Source8:        %{name}-bounce.cf.pl
53 # http://postfix.state-of-mind.de/bounce-templates/bounce.de-DE.cf
54 Source9:        %{name}-bounce.cf.de
55 Source10:       %{name}.monitrc
56 Source11:       %{name}-vda-bigquota.patch
57 #Source11:      http://vda.sourceforge.net/VDA/%{name}-%{vda_ver}-vda-ng-bigquota.patch.gz
58 # -ource11-md5: d46103195b43ec5784ea2c166b238f71
59 Source12:       %{name}.service
60 Patch0:         %{name}-config.patch
61 Patch1:         %{name}-conf_msg.patch
62 Patch2:         %{name}-dynamicmaps.patch
63 Patch3:         %{name}-master.cf_cyrus.patch
64 # from http://akson.sgh.waw.pl/~chopin/unix/postfix-2.1.5-header_if_reject.diff
65 Patch4:         %{name}-header_if_reject.patch
66 Patch5:         %{name}-ident.patch
67 Patch6:         %{name}-lib64.patch
68 Patch7:         %{name}-conf.patch
69 Patch8:         %{name}-dictname.patch
70 Patch9:         %{name}-make-jN.patch
71 Patch10:        %{name}-link.patch
72 Patch11:        %{name}-scache_clnt.patch
73 Patch12:        format-security.patch
74 Patch13:        %{name}-no_cdb.patch
75 Patch14:        %{name}-vbuf_print.patch
76 URL:            http://www.postfix.org/
77 %{?with_sasl:BuildRequires:     cyrus-sasl-devel}
78 BuildRequires:  db-devel
79 # getifaddrs() with IPv6 support
80 BuildRequires:  glibc-devel >= 6:2.3.4
81 %{?with_mysql:BuildRequires:    mysql-devel}
82 %{?with_ldap:BuildRequires:     openldap-devel >= 2.0.12}
83 %{?with_ssl:BuildRequires:      openssl-devel >= 0.9.7l}
84 BuildRequires:  pcre-devel
85 BuildRequires:  perl-base
86 %{?with_pgsql:BuildRequires:    postgresql-devel}
87 BuildRequires:  rpm >= 4.4.9-56
88 BuildRequires:  rpmbuild(macros) >= 1.644
89 BuildRequires:  sed >= 4.0
90 %{?with_sqlite:BuildRequires:   sqlite3-devel}
91 %{?with_cdb:BuildRequires:      tinycdb-devel}
92 %{?with_mysql:BuildRequires:    zlib-devel}
93 Requires(post): /bin/hostname
94 Requires(post,postun):  /sbin/ldconfig
95 Requires(post,preun):   /sbin/chkconfig
96 Requires(postun):       /usr/sbin/groupdel
97 Requires(postun):       /usr/sbin/userdel
98 Requires(pre):  /bin/id
99 Requires(pre):  /usr/bin/getgid
100 Requires(pre):  /usr/sbin/groupadd
101 Requires(pre):  /usr/sbin/useradd
102 Requires:       /sbin/chkconfig
103 Requires:       diffutils
104 Requires:       findutils
105 Requires:       rc-scripts
106 Requires:       sed
107 %{?with_cdb:Requires:tinycdb}
108 Requires:       systemd-units >= 38
109 Suggests:       cyrus-sasl-saslauthd
110 Provides:       group(postfix)
111 Provides:       smtpdaemon
112 Provides:       user(postfix)
113 Obsoletes:      smtpdaemon
114 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
115
116 %description
117 Postfix is attempt to provide an alternative to the widely-used
118 Sendmail program. Postfix attempts to be fast, easy to administer, and
119 hopefully secure, while at the same time being sendmail compatible
120 enough to not upset your users. This version has IPv6 support.
121
122 %description -l es.UTF-8
123 Postfix es una alternativa para el mundialmente utilizado sendmail. Si
124 desea tener un servidor SMTP *rápido*, debe instalar este paquete.
125
126 %description -l fr.UTF-8
127 Postfix (voir http://www.postfix.org/) se veut une alternative à
128 sendmail, responsable de l'acheminement de 70% des courriers
129 électroniques sur Internet. IBM en a suppotré le développement, mais
130 ne contrôle pas son évolution. Le but est d'installer Postfix sur le
131 plus grand nombre de systèmes possible. Dans cette optique, il a été
132 écrit pour être totalement sous le contrôle de l'utilisateur.
133
134 %description -l it.UTF-8
135 Postfix (http://www.postfix.org/) e' un'alternativa al programma
136 sendmail utilizzato per la gestione del 70 per cento della posta
137 Internet.
138
139 Seppur IBM supporti lo sviluppo di Postfix, non controlla la sua
140 evoluzione.
141
142 Consultate la pagine web http://www.moongroup.com/how-to.phtml nella
143 quale troverete le indicazioni per una corretta installazione e
144 configurazione di questo programma.
145
146 %description -l pl.UTF-8
147 Postfix jest próbą dostarczenia alternatywnego MTA w stosunku do
148 szeroko używanego sendmaila. Postfix w zamierzeniu ma być szybki,
149 łatwy w administrowaniu, bezpieczny oraz ma być na tyle kompatybilny z
150 sendmailem by nie denerwować użytkowników. Ta wersja obsługuje IPv6.
151
152 %description -l pt_BR.UTF-8
153 O Postfix é uma alternativa para o mundialmente utilizado sendmail. Se
154 você deseja um servidor SMTP *rápido*, instale este pacote.
155
156 %description -l sk.UTF-8
157 Postfix (pozri http://www.postfix.org/) má za cieľ byť alternatívou k
158 široko rozšírenému programu sendmail, zodpovednému za 70% všetkej
159 elektronickej pošty doručenej na Internete.
160
161 Aj keď IBM podporovala vývoj Postfixu, zdržiava sa vplyvu na jeho
162 vývoj. Cieľom je inštalácia Postfixu na čo najväčšom počte systémov.
163 Do tohoto momentu je softvér poskytovaný bez ovplyvňovania, takže sa
164 môže vyvíjať podľa jeho používateľov.
165
166 Určite si prečítajte http://www.moongroup.com/how-to.phtml, kde sú
167 popísané kroky potrebné pred a po inštalácii Postfixu.
168
169 %package devel
170 Summary:        Postfix loadable modules development package
171 Summary(pl.UTF-8):      Pakiet dla programistów ładowanych modułów do postfiksa
172 Group:          Development/Libraries
173 Requires:       %{name} = %{epoch}:%{version}-%{release}
174
175 %description devel
176 Header files to build additional map types for Postfix.
177
178 %description devel -l pl.UTF-8
179 Pliki nagłówkowe do tworzenia dodatkowych typów map dla Postfiksa.
180
181 %package dict-ldap
182 Summary:        LDAP map support for Postfix
183 Summary(pl.UTF-8):      Obsługa map LDAP dla Postfiksa
184 Group:          Networking/Daemons/SMTP
185 Requires:       %{name} = %{epoch}:%{version}-%{release}
186 Requires:       openldap >= 2.3.6
187
188 %description dict-ldap
189 This package provides support for LDAP maps in Postfix.
190
191 %description dict-ldap -l pl.UTF-8
192 Ten pakiet dodaje obsługę map LDAP do Postfiksa.
193
194 %package dict-mysql
195 Summary:        MySQL map support for Postfix
196 Summary(pl.UTF-8):      Obsługa map MySQL dla Postfiksa
197 Group:          Networking/Daemons/SMTP
198 Requires:       %{name} = %{epoch}:%{version}-%{release}
199
200 %description dict-mysql
201 This package provides support for MySQL maps in Postfix.
202
203 %description dict-mysql -l pl.UTF-8
204 Ten pakiet dodaje obsługę map MySQL do Postfiksa.
205
206 %package dict-pcre
207 Summary:        PCRE map support for Postfix
208 Summary(pl.UTF-8):      Obsługa map PCRE dla Postfiksa
209 Group:          Networking/Daemons/SMTP
210 Requires:       %{name} = %{epoch}:%{version}-%{release}
211
212 %description dict-pcre
213 This package provides support for PCRE maps in Postfix.
214
215 %description dict-pcre -l pl.UTF-8
216 Ten pakiet dodaje obsługę map PCRE do Postfiksa.
217
218 %package dict-pgsql
219 Summary:        PostgreSQL map support for Postfix
220 Summary(pl.UTF-8):      Obsługa map PostgreSQL dla Postfiksa
221 Group:          Networking/Daemons/SMTP
222 Requires:       %{name} = %{epoch}:%{version}-%{release}
223
224 %description dict-pgsql
225 This package provides support for PostgreSQL maps in Postfix.
226
227 %description dict-pgsql -l pl.UTF-8
228 Ten pakiet dodaje obsługę map PostgreSQL do Postfiksa.
229
230 %package dict-sqlite
231 Summary:        SQLite map support for Postfix
232 Summary(pl.UTF-8):      Obsługa map SQLite dla Postfiksa
233 Group:          Networking/Daemons/SMTP
234 Requires:       %{name} = %{epoch}:%{version}-%{release}
235
236 %description dict-sqlite
237 This package provides support for SQLite maps in Postfix.
238
239 %description dict-sqlite -l pl.UTF-8
240 Ten pakiet dodaje obsługę map SQLite do Postfiksa.
241
242 %package qshape
243 Summary:        qshape - Print Postfix queue domain and age distribution
244 Summary(pl.UTF-8):      qshape - wypisywanie rozkładu domen i wieku z kolejki Postfiksa
245 Group:          Networking/Daemons/SMTP
246 Requires:       %{name} = %{epoch}:%{version}-%{release}
247
248 %description qshape
249 The qshape program helps the administrator understand the Postfix
250 queue message distribution in time and by sender domain or recipient
251 domain. The program needs read access to the queue directories and
252 queue files, so it must run as the superuser or the mail_owner
253 specified in main.cf (typically postfix).
254
255 %description qshape -l pl.UTF-8
256 Program qshape pomaga administratorowi zrozumieć rozkład kolejki
257 wiadomości Postfiksa w czasie i w zależności od domeny nadawcy lub
258 adresata. Program wymaga prawa odczytu do katalogów kolejki i plików
259 kolejki, więc musi być uruchamiany przez superużytkownika lub
260 użytkownika mail_owner podanego w main.cf (zwykle nazywającego się
261 postfix).
262
263 %package -n monit-rc-%{name}
264 Summary:        monit support for Postfix
265 Summary(pl.UTF-8):      Wsparcie monita dla Postfiksa
266 Group:          Applications/System
267 Requires:       %{name} = %{epoch}:%{version}-%{release}
268 Requires:       monit
269
270 %description -n monit-rc-%{name}
271 monitrc file for monitoring Postfix.
272
273 %description -n monit-rc-%{name} -l pl.UTF-8
274 Plik monitrc do monitorowania serwera Postfix.
275
276 %prep
277 %setup -q
278 %if %{with vda}
279 cat %{SOURCE7} | %{__patch} -p1 -s
280 cat %{SOURCE11} | %{__patch} -p1 -s
281 %endif
282
283 find -type f | xargs sed -i -e 's|/etc/postfix|/etc/mail|g'
284
285 %patch0 -p1
286 %patch1 -p0
287 %patch2 -p1
288 %patch3 -p1
289 %{?with_hir:%patch4 -p0}
290 %patch5 -p1
291 sed -i '/scache_clnt_create/s/server/var_scache_service/' src/global/scache_clnt.c
292 %if "%{_lib}" == "lib64"
293 %patch6 -p1
294 %endif
295 %patch7 -p1
296 %patch8 -p1
297 %patch9 -p1
298 %patch10 -p1
299 %patch11 -p1
300 %if %{with vda}
301 %patch12 -p1
302 %endif
303 %{!?with_cdb:%patch13 -p1}
304 %patch14 -p1
305
306 %if %{with tcp}
307 sed -i 's/ifdef SNAPSHOT/if 1/' src/util/dict_open.c
308 %endif
309
310 %build
311 %{__make} -f Makefile.init makefiles
312 %{__make} tidy
313 export CC="%{__cc}"
314 %{__make} -j1 \
315         DEBUG="" \
316         OPT="%{rpmcflags} %{rpmcppflags} -D_FILE_OFFSET_BITS=64" \
317         %{!?with_ldap:LDAPSO=""} \
318         %{!?with_mysql:MYSQLSO=""} \
319         %{!?with_pgsql:PGSQLSO=""} \
320         CCARGS="%{!?with_epoll:-DNO_EPOLL} %{?with_ldap:-DHAS_LDAP} -DHAS_PCRE %{?with_sasl:-DUSE_SASL_AUTH -DUSE_CYRUS_SASL -I/usr/include/sasl} %{?with_mysql:-DHAS_MYSQL -I/usr/include/mysql} %{?with_pgsql:-DHAS_PGSQL} %{?with_ssl:-DUSE_TLS} -DMAX_DYNAMIC_MAPS %{?with_cdb:-DHAS_CDB}" \
321         AUXLIBS="-ldb -lresolv %{?with_sasl:-lsasl} %{?with_ssl:-lssl -lcrypto} %{?with_cdb:-lcdb} -lpcre"
322
323 %install
324 rm -rf $RPM_BUILD_ROOT
325 install -d $RPM_BUILD_ROOT/etc/{cron.daily,rc.d/init.d,sysconfig,pam.d,security,monit} \
326         $RPM_BUILD_ROOT%{_sysconfdir}/{mail,sasl} \
327         $RPM_BUILD_ROOT{%{_bindir},%{_sbindir},%{_libdir}/postfix,/usr/lib}\
328         $RPM_BUILD_ROOT{%{_includedir}/postfix,%{_mandir}} \
329         $RPM_BUILD_ROOT%{_var}/spool/postfix/{active,corrupt,deferred,maildrop,private,saved,bounce,defer,incoming,pid,public} \
330         $RPM_BUILD_ROOT%{_var}/lib/postfix \
331         $RPM_BUILD_ROOT%{systemdunitdir}
332
333 %{__rm} html/Makefile.in conf/{LICENSE,main.cf.default}
334
335 install -p bin/* $RPM_BUILD_ROOT%{_sbindir}
336 install -p libexec/* $RPM_BUILD_ROOT%{_libdir}/postfix
337 ln $RPM_BUILD_ROOT%{_libdir}/postfix/smtp $RPM_BUILD_ROOT%{_libdir}/postfix/lmtp
338 ln $RPM_BUILD_ROOT%{_libdir}/postfix/qmgr $RPM_BUILD_ROOT%{_libdir}/postfix/nqmgr
339 cp -a conf/* $RPM_BUILD_ROOT%{_sysconfdir}/mail
340 sed -e's,^daemon_directory = .*,daemon_directory = %{_libdir}/postfix,' \
341         conf/main.cf > $RPM_BUILD_ROOT%{_sysconfdir}/mail/main.cf
342
343 for f in dns global master util ; do
344         cp -a lib/lib${f}.a $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so.1
345         ln -sf lib${f}.so.1 $RPM_BUILD_ROOT%{_libdir}/libpostfix-${f}.so
346 done
347 install -p lib/dict*.so $RPM_BUILD_ROOT%{_libdir}/postfix
348 cp -a include/*.h $RPM_BUILD_ROOT%{_includedir}/postfix
349
350 cp -a man/man* $RPM_BUILD_ROOT%{_mandir}
351
352 cp -a %{SOURCE1} $RPM_BUILD_ROOT%{_sysconfdir}/mail/aliases
353 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/cron.daily/postfix
354 install %{SOURCE3} $RPM_BUILD_ROOT/etc/rc.d/init.d/postfix
355 cp -a %{SOURCE4} $RPM_BUILD_ROOT/etc/sysconfig/postfix
356 cp -a %{SOURCE5} $RPM_BUILD_ROOT%{_sysconfdir}/sasl/smtpd.conf
357 cp -a %{SOURCE6} $RPM_BUILD_ROOT/etc/pam.d/smtp
358 cp -a %{SOURCE8} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.pl
359 cp -a %{SOURCE9} $RPM_BUILD_ROOT%{_sysconfdir}/mail/bounce.cf.de
360 cp -a %{SOURCE10} $RPM_BUILD_ROOT/etc/monit/%{name}.monitrc
361 cp -a %{SOURCE12} $RPM_BUILD_ROOT%{systemdunitdir}/%{name}.service
362 install -p auxiliary/rmail/rmail $RPM_BUILD_ROOT%{_bindir}/rmail
363 install -p auxiliary/qshape/qshape.pl $RPM_BUILD_ROOT%{_bindir}/qshape
364
365 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/mailq
366 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT%{_bindir}/newaliases
367 ln -sf %{_sbindir}/sendmail $RPM_BUILD_ROOT/usr/lib/sendmail
368
369 touch $RPM_BUILD_ROOT%{_sysconfdir}/mail/\
370         {aliases,access,canonical,relocated,transport,virtual}{,.db}
371
372 touch $RPM_BUILD_ROOT/etc/security/blacklist.smtp
373
374 > $RPM_BUILD_ROOT/var/spool/postfix/.nofinger
375
376 %{__rm} -r $RPM_BUILD_ROOT%{_sysconfdir}/mail/makedefs.out
377 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/TLS_LICENSE
378
379 %{__rm} $RPM_BUILD_ROOT%{_sysconfdir}/mail/{postfix-files,postfix-script,post-install}
380
381 %clean
382 rm -rf $RPM_BUILD_ROOT
383
384 %pre
385 %groupadd -g 62 postfix
386 %groupadd -g 63 maildrop
387 %useradd -u 62 -d /var/spool/postfix -s /bin/false -c "Postfix User" -g postfix postfix
388
389 %post
390 /sbin/ldconfig
391 if ! grep -q "^postmaster:" %{_sysconfdir}/mail/aliases; then
392         echo "Adding Entry for postmaster in %{_sysconfdir}/mail/aliases" >&2
393         echo "postmaster: root" >>%{_sysconfdir}/mail/aliases
394 fi
395 if [ "$1" = "1" ]; then
396         # only on installation, not upgrade; set sane defaults
397         # postfix expects gethostname() to return FQDN, which is obviously wrong
398         if ! grep -qE "^my(domain|hostname)" %{_sysconfdir}/mail/main.cf; then
399                 domain=$(/bin/hostname -d 2>/dev/null)
400                 [ -n "$domain" -a "$domain" != 'localdomain' ] && \
401                         postconf -e mydomain="$domain"
402         fi
403 else
404         %{_sbindir}/postfix upgrade-configuration
405 fi
406
407 %{_bindir}/newaliases
408 /sbin/chkconfig --add postfix
409 %service postfix restart "Postfix Daemon"
410 %systemd_post postfix.service
411
412 %preun
413 if [ "$1" = "0" ]; then
414         %service postfix stop
415         /sbin/chkconfig --del postfix
416 fi
417 %systemd_preun postfix.service
418
419 %postun
420 /sbin/ldconfig
421 if [ "$1" = "0" ]; then
422         %groupremove maildrop
423         %userremove postfix
424         %groupremove postfix
425 fi
426 %systemd_reload
427
428 %triggerpostun -- postfix < 2:2.9.4-4
429 %systemd_trigger postfix.service
430
431 %files
432 %defattr(644,root,root,755)
433 %doc html COMPATIBILITY HISTORY LICENSE RELEASE_NOTES* TLS_*
434 %doc README_FILES/*README
435 %doc examples/smtpd-policy
436 %dir %{_sysconfdir}/mail
437 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/access
438 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/aliases
439 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.default
440 %lang(de) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.de
441 %lang(pl) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/bounce.cf.pl
442 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/canonical
443 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/generic
444 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/regexp_table
445 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/relocated
446 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/transport
447 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/virtual
448 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/header_checks
449 #%ghost %{_sysconfdir}/mail/*.db
450 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/dynamicmaps.cf
451 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/main.cf
452 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/master.cf
453 %{_sysconfdir}/mail/postfix-wrapper
454 %{_sysconfdir}/mail/postmulti-script
455 %attr(740,root,root) /etc/cron.daily/postfix
456 %attr(754,root,root) /etc/rc.d/init.d/postfix
457 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/postfix
458 %config(noreplace) %verify(not md5 mtime size) /etc/pam.d/smtp
459 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/security/blacklist.smtp
460 %{?with_sasl:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/smtpd.conf}
461 %attr(755,root,root) %{_libdir}/libpostfix-*.so.*
462 %attr(755,root,root) %{_bindir}/mailq
463 %attr(755,root,root) %{_bindir}/newaliases
464 %attr(755,root,root) %{_bindir}/rmail
465 %attr(755,root,root) %{_sbindir}/s*
466 %attr(755,root,root) %{_sbindir}/postfix
467 %attr(755,root,root) %{_sbindir}/postalias
468 %attr(755,root,root) %{_sbindir}/postkick
469 %attr(755,root,root) %{_sbindir}/postl*
470 %attr(755,root,root) %{_sbindir}/postc*
471 %attr(755,root,root) %{_sbindir}/postmap
472 %attr(755,root,root) %{_sbindir}/postmulti
473 %attr(2755,root,maildrop) %{_sbindir}/postqueue
474 %attr(755,root,root) %{_sbindir}/postsuper
475 %attr(755,root,root) %{_sbindir}/posttls-finger
476 %attr(2755,root,maildrop) %{_sbindir}/postdrop
477 %attr(755,root,root) %{_sbindir}/qmqp-sink
478 %attr(755,root,root) %{_sbindir}/qmqp-source
479 %attr(755,root,root) /usr/lib/sendmail
480 %dir %{_libdir}/postfix
481 %attr(755,root,root) %{_libdir}/postfix/[!d]*
482 %attr(755,root,root) %{_libdir}/postfix/discard
483 %attr(755,root,root) %{_libdir}/postfix/dnsblog
484 %attr(755,root,root) %dir %{_var}/spool/postfix
485 %attr(700,postfix,root) %dir %{_var}/spool/postfix/active
486 %attr(700,postfix,root) %dir %{_var}/spool/postfix/bounce
487 %attr(700,postfix,root) %dir %{_var}/spool/postfix/corrupt
488 %attr(700,postfix,root) %dir %{_var}/spool/postfix/defer
489 %attr(700,postfix,root) %dir %{_var}/spool/postfix/deferred
490 %attr(700,postfix,root) %dir %{_var}/spool/postfix/incoming
491 %attr(1730,postfix,maildrop) %dir %{_var}/spool/postfix/maildrop
492 %attr(755,postfix,root) %dir %{_var}/spool/postfix/pid
493 %attr(700,postfix,root) %dir %{_var}/spool/postfix/private
494 %attr(710,postfix,maildrop) %dir %{_var}/spool/postfix/public
495 %attr(700,postfix,root) %dir %{_var}/spool/postfix/saved
496 %attr(644,postfix,root) %{_var}/spool/postfix/.nofinger
497 %attr(700,postfix,root) %{_var}/lib/postfix
498 %{_mandir}/man1/mailq.1*
499 %{_mandir}/man1/newaliases.1*
500 %{_mandir}/man1/post*.1*
501 %{_mandir}/man1/qmqp-*.1*
502 %{_mandir}/man1/sendmail.1*
503 %{_mandir}/man1/smtp-*.1*
504 %{_mandir}/man5/access.5*
505 %{_mandir}/man5/aliases.5*
506 %{_mandir}/man5/body_checks.5*
507 %{_mandir}/man5/bounce.5*
508 %{_mandir}/man5/canonical.5*
509 %{_mandir}/man5/cidr_table.5*
510 %{_mandir}/man5/generic.5*
511 %{_mandir}/man5/header_checks.5*
512 %{_mandir}/man5/lmdb_table.5*
513 %{_mandir}/man5/master.5*
514 %{_mandir}/man5/memcache_table.5*
515 %{_mandir}/man5/nisplus_table.5*
516 %{_mandir}/man5/postconf.5*
517 %{_mandir}/man5/postfix-wrapper.5*
518 %{_mandir}/man5/regexp_table.5*
519 %{_mandir}/man5/relocated.5*
520 %{_mandir}/man5/socketmap_table.5*
521 %{_mandir}/man5/tcp_table.5*
522 %{_mandir}/man5/transport.5*
523 %{_mandir}/man5/virtual.5*
524 %{_mandir}/man8/*.8*
525 %{systemdunitdir}/%{name}.service
526
527 %files devel
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/libpostfix-*.so
530 %{_includedir}/postfix
531
532 %if %{with ldap}
533 %files dict-ldap
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_libdir}/postfix/dict_ldap.so
536 %{_mandir}/man5/ldap_table.5*
537 %endif
538
539 %if %{with mysql}
540 %files dict-mysql
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/postfix/dict_mysql.so
543 %{_mandir}/man5/mysql_table.5*
544 %endif
545
546 %files dict-pcre
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/postfix/dict_pcre.so
549 #%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mail/pcre_table
550 %{_mandir}/man5/pcre_table.5*
551
552 %if %{with pgsql}
553 %files dict-pgsql
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/postfix/dict_pgsql.so
556 %{_mandir}/man5/pgsql_table.5*
557 %endif
558
559 %if %{with sqlite}
560 %files dict-sqlite
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/postfix/dict_sqlite.so
563 %{_mandir}/man5/sqlite_table.5*
564 %endif
565
566 %files qshape
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_bindir}/qshape
569 %{_mandir}/man1/qshape.1*
570
571 %files -n monit-rc-%{name}
572 %defattr(644,root,root,755)
573 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/monit/%{name}.monitrc
This page took 0.2058 seconds and 2 git commands to generate.