]> git.pld-linux.org Git - packages/php4.git/commitdiff
- rel 42; no pcre_info anymore auto/th/php4-4_4_9-43
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Mon, 2 Jul 2012 12:20:35 +0000 (12:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    php4-pcre.patch -> 1.1
    php4.spec -> 1.671

php4-pcre.patch [new file with mode: 0644]
php4.spec

diff --git a/php4-pcre.patch b/php4-pcre.patch
new file mode 100644 (file)
index 0000000..2ee0c94
--- /dev/null
@@ -0,0 +1,24 @@
+diff -ur php-4.4.9.org/ext/pcre/php_pcre.c php-4.4.9/ext/pcre/php_pcre.c
+--- php-4.4.9.org/ext/pcre/php_pcre.c  2007-12-31 08:22:50.000000000 +0100
++++ php-4.4.9/ext/pcre/php_pcre.c      2012-07-02 14:17:54.974558709 +0200
+@@ -141,6 +141,7 @@
+       int                                      regex_len;
+       int                                      do_study = 0;
+       int                                      poptions = 0;
++      int                             count = 0;
+       unsigned const char *tables = NULL;
+ #if HAVE_SETLOCALE
+       char                            *locale = setlocale(LC_CTYPE, NULL);
+@@ -154,10 +155,10 @@
+       regex_len = strlen(regex);
+       if (zend_hash_find(&PCRE_G(pcre_cache), regex, regex_len+1, (void **)&pce) == SUCCESS) {
+               /*
+-               * We use a quick pcre_info() check to see whether cache is corrupted, and if it
++               * We use a quick pcre_fullinfo() check to see whether cache is corrupted, and if it
+                * is, we flush it and compile the pattern from scratch.
+                */
+-              if (pcre_info(pce->re, NULL, NULL) == PCRE_ERROR_BADMAGIC) {
++              if (pcre_fullinfo(pce->re, NULL, PCRE_INFO_CAPTURECOUNT, &count) == PCRE_ERROR_BADMAGIC) {
+                       zend_hash_clean(&PCRE_G(pcre_cache));
+               } else {
+ #if HAVE_SETLOCALE
index 97d7242f513e1532247604603512fe9c0f52d38e..07c3c3936cf7cd6b0fe1db5c48e075fa28340996 100644 (file)
--- a/php4.spec
+++ b/php4.spec
@@ -72,7 +72,7 @@
 %undefine      with_msession
 %endif
 
-%define                rel 42
+%define                rel 43
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -150,6 +150,7 @@ Patch53:    %{name}-silent-session-cleanup.patch
 Patch54:       %{name}-m4-divert.patch
 Patch55:       %{name}-libpng.patch
 Patch56:       %{name}-gmp.patch
+Patch57:       %{name}-pcre.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1626,6 +1627,7 @@ cp php.ini-dist php.ini
 %patch54 -p1
 %patch55 -p1
 %patch56 -p1
+%patch57 -p1
 
 %if %{with hardening}
 zcat %{SOURCE8} | patch -p1
This page took 0.115678 seconds and 4 git commands to generate.