]> git.pld-linux.org Git - packages/php4.git/commitdiff
- rel 50; fix php bug 68486 visible under apache 2.4 auto/th/php4-4.4.9-50
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Oct 2015 07:47:42 +0000 (09:47 +0200)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 2 Oct 2015 07:47:42 +0000 (09:47 +0200)
php-bug-68486.patch [new file with mode: 0644]
php4.spec

diff --git a/php-bug-68486.patch b/php-bug-68486.patch
new file mode 100644 (file)
index 0000000..ad70f8f
--- /dev/null
@@ -0,0 +1,18 @@
+commit af1cd45d171fbb06712f846cec7bf69438db8ec2
+Author: Stanislav Malyshev <stas@php.net>
+Date:   Sat Apr 4 15:03:46 2015 -0700
+
+    Fix bug #68486 and bug #69218 (segfault in apache2handler with apache 2.4)
+
+diff --git a/sapi/apache2handler/sapi_apache2.c b/sapi/apache2handler/sapi_apache2.c
+index e97f11c..cfebc5f 100644
+--- a/sapi/apache2handler/sapi_apache2.c
++++ b/sapi/apache2handler/sapi_apache2.c
+@@ -688,6 +688,7 @@ zend_first_try {
+ } zend_end_try();
+               }
+               apr_brigade_cleanup(brigade);
++              apr_pool_cleanup_run(r->pool, (void *)&SG(server_context), php_server_context_cleanup);
+       } else {
+               ctx->r = parent_req;
+       }
index fccd5989d3f687b6b57347cb8f9e82e015acaa03..e7e4232a258d09db0b6f986b0326bde8ff70ab08 100644 (file)
--- a/php4.spec
+++ b/php4.spec
@@ -73,7 +73,7 @@
 %undefine      with_msession
 %endif
 
-%define                rel 49
+%define                rel 50
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -153,6 +153,7 @@ Patch55:    %{name}-libpng.patch
 Patch56:       %{name}-gmp.patch
 Patch57:       %{name}-pcre.patch
 Patch58:       %{name}-apache24.patch
+Patch59:       php-bug-68486.patch
 URL:           http://www.php.net/
 %{?with_interbase:%{!?with_interbase_inst:BuildRequires:       Firebird-devel >= 1.0.2.908-2}}
 %{?with_pspell:BuildRequires:  aspell-devel >= 2:0.50.0}
@@ -1630,6 +1631,7 @@ cp php.ini-dist php.ini
 %patch56 -p1
 %patch57 -p1
 %patch58 -p1
+%patch59 -p1
 
 %if %{with hardening}
 zcat %{SOURCE8} | patch -p1
This page took 0.176117 seconds and 4 git commands to generate.