]> git.pld-linux.org Git - packages/php.git/commitdiff
Up to 8.3.4. auto/th/php83-8.3.4-1
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 20 Mar 2024 13:18:06 +0000 (14:18 +0100)
committerArkadiusz Miśkiewicz <arekm@maven.pl>
Wed, 20 Mar 2024 13:18:06 +0000 (14:18 +0100)
opcache.ini
php-ini.patch
php.spec

index 67c0381339beddcf86f08c07f076604d9b4b65ba..ef26a89247c87b3dcd6d15677fbac1456cbdb7db 100644 (file)
 ; are cached.
 ;opcache.max_file_size=0
 
-; Check the cache checksum each N requests.
-; The default value of "0" means that the checks are disabled.
-;opcache.consistency_checks=0
-
 ; How long to wait (in seconds) for a scheduled restart to begin if the cache
 ; is not being accessed.
 ;opcache.force_restart_timeout=180
 ;opcache.file_cache_fallback=1
 
 ; Enables or disables copying of PHP code (text segment) into HUGE PAGES.
-; This should improve performance, but requires appropriate OS configuration.
-;opcache.huge_code_pages=1
+; Under certain circumstances (if only a single global PHP process is
+; started from which all others fork), this can increase performance
+; by a tiny amount because TLB misses are reduced.  On the other hand, this
+; delays PHP startup, increases memory usage and degrades performance
+; under memory pressure - use with care.
+; Requires appropriate OS configuration.
+;opcache.huge_code_pages=0
 
 ; Validate cached file permissions.
 ;opcache.validate_permission=0
 
 ; Specifies a PHP script that is going to be compiled and executed at server
 ; start-up.
-; http://php.net/opcache.preload
+; https://php.net/opcache.preload
 ;opcache.preload=
 
 ; Preloading code as root is not allowed for security reasons. This directive
 ; facilitates to let the preloading to be run as another user.
-; http://php.net/opcache.preload_user
+; https://php.net/opcache.preload_user
 ;opcache.preload_user=
 
 ; Prevents caching files that are less than this number of seconds old. It
 
 ; Absolute path used to store shared lockfiles (for *nix only).
 ;opcache.lockfile_path=/tmp
+
index c19d4dcb0a1d6a0b7d7da83d8be95982f00bf1d5..8cab4a071ce5afe2a1a4823c29198e20287616d9 100644 (file)
  
  ; (time to live) Sets the number of second while cached file will be used
  ; instead of original one.
-@@ -1674,165 +1674,6 @@
+@@ -1673,161 +1673,6 @@ ldap.max_links = -1
  [dba]
  ;dba.default_handler=
  
 -; are cached.
 -;opcache.max_file_size=0
 -
--; Check the cache checksum each N requests.
--; The default value of "0" means that the checks are disabled.
--;opcache.consistency_checks=0
--
 -; How long to wait (in seconds) for a scheduled restart to begin if the cache
 -; is not being accessed.
 -;opcache.force_restart_timeout=180
  [curl]
  ; A default value for the CURLOPT_CAINFO option. This is required to be an
  ; absolute path.
+
index 071b032d43f65489401ecaa5d5ea1c8613adb56e..a0e5f3cd08ae9ad1d59f9270f090994c03468d62 100644 (file)
--- a/php.spec
+++ b/php.spec
 %endif
 
 %define                orgname         php
-%define                ver_suffix      82
+%define                ver_suffix      83
 %define                php_suffix      %{!?with_default_php:%{ver_suffix}}
 %define                subver          %{nil}
-%define                rel             2
+%define                rel             1
 Summary:       PHP: Hypertext Preprocessor
 Summary(fr.UTF-8):     Le langage de script embarque-HTML PHP
 Summary(pl.UTF-8):     Język skryptowy PHP
@@ -150,7 +150,7 @@ Summary(pt_BR.UTF-8):       A linguagem de script PHP
 Summary(ru.UTF-8):     PHP - язык препроцессирования HTML-файлов, выполняемый на сервере
 Summary(uk.UTF-8):     PHP - мова препроцесування HTML-файлів, виконувана на сервері
 Name:          %{orgname}%{php_suffix}
-Version:       8.2.17
+Version:       8.3.4
 Release:       %{rel}
 Epoch:         4
 # All files licensed under PHP version 3.01, except
@@ -159,7 +159,7 @@ Epoch:              4
 License:       PHP 3.01 and Zend and BSD
 Group:         Libraries
 Source0:       https://www.php.net/distributions/%{orgname}-%{version}.tar.xz
-# Source0-md5: 6d7f56031948ff9da9739fe5a712baf3
+# Source0-md5: 598f9d78cbf4bbe4dc1c008a43459e61
 #Source0:      https://downloads.php.net/~pierrick/php-%{version}%{subver}.tar.xz
 Source1:       opcache.ini
 Source2:       %{orgname}-mod_php.conf
@@ -289,7 +289,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir                     %{php_sysconfdir}
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                php_api_version         20220829
+%define                php_api_version         20230831
 %define                zend_module_api         %{php_api_version}
 %define                zend_extension_api      4%{zend_module_api}
 %define                php_pdo_api_version     20170320
@@ -303,7 +303,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                jsonver         %{version}
 %define                pharver         %{version}
 %define                sqlite3ver      %{version}
-%define                zipver          1.21.1
+%define                zipver          1.22.3
 %define                phpdbgver       %{version}
 %define                sodiumver       %{version}
 
@@ -2200,6 +2200,7 @@ for sapi in $sapis; do
        --enable-option-checking=fatal \
        %{__enable_disable bcmath bcmath shared} \
        %{__enable_disable calendar calendar shared} \
+       %{?with_opcache:--with-capstone} \
        %{__enable_disable ctype ctype shared} \
        %{__enable_disable dba dba shared} \
        %{__enable_disable dom dom shared} \
This page took 0.086243 seconds and 4 git commands to generate.