]> git.pld-linux.org Git - packages/php-phpoffice-PHPExcel.git/blob - php-phpoffice-PHPExcel.spec
suggests php-jpgraph (PHPExcel_Chart_Renderer_jpgraph)
[packages/php-phpoffice-PHPExcel.git] / php-phpoffice-PHPExcel.spec
1 # TODO
2 # - drop PHPExcel/Calculation/Functions.php - php compat functions (find minimum required and use that in .spec)
3 # - mbstring used unconditionally in some places: ./PHPExcel/Writer/CSV.php, ./PHPExcel/Calculation.php
4 # %define               pkgname PHPExcel
5 %define         php_min_version 5.2.1
6 %include        /usr/lib/rpm/macros.php
7 Summary:        PHPExcel - OpenXML - Create Excel2007 documents in PHP - Spreadsheet engine
8 Name:           php-phpoffice-%{pkgname}
9 Version:        1.7.9
10 Release:        1
11 License:        LGPL v2.1
12 Group:          Development/Languages/PHP
13 Source0:        https://github.com/PHPOffice/PHPExcel/archive/%{version}/%{pkgname}-%{version}.tar.gz
14 # Source0-md5:  3a08fd80a8d77c79c72b2ce6f1d4440c
15 URL:            http://phpexcel.codeplex.com/
16 BuildRequires:  rpm-php-pearprov >= 4.4.2-11
17 BuildRequires:  rpmbuild(macros) >= 1.654
18 Requires:       php(core) >= %{php_min_version}
19 Requires:       php(ctype)
20 Requires:       php(date)
21 Requires:       php(mbstring)
22 Requires:       php(pcre)
23 Requires:       php(spl)
24 Requires:       php(xml)
25 Requires:       php-pear
26 Suggests:       php(gd)
27 Suggests:       php(iconv)
28 Suggests:       php(simplexml)
29 Suggests:       php(sqlite)
30 Suggests:       php(xmlreader)
31 Suggests:       php(zip)
32 Suggests:       php-jpgraph
33 BuildArch:      noarch
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         _noautoreq_pear jpgraph_line.php
37
38 # exclude optional php dependencies
39 %define         _noautophp      php-gd php-iconv php-mbstring php-simplexml php-sqlite php-xmlreader
40
41 # put it together for rpmbuild
42 %define         _noautoreq      %{?_noautophp}
43
44 %description
45 PHPExcel - OpenXML - Read, Write and Create Excel documents in PHP -
46 Spreadsheet engine
47
48 Project providing a set of classes for the PHP programming language,
49 which allow you to write to and read from different spreadsheet file
50 formats, like Excel (BIFF) .xls, Excel 2007 (OfficeOpenXML) .xlsx,
51 CSV, Libre/OpenOffice Calc .ods, Gnumeric, PDF, HTML, ... This project
52 is built around Microsoft's OpenXML standard and PHP. Checkout the
53 Features this class set provides, such as setting spreadsheet meta
54 data (author, title, description, ...), multiple worksheets, different
55 fonts and font styles, cell borders, fills, gradients, adding images
56 to your spreadsheet, calculating formulas, converting between file
57 types and much, much more!
58
59 %package examples
60 Summary:        Examples for %{pkgname}
61 Group:          Documentation
62
63 %description examples
64 Documentation for %{name}.
65
66 %description examples -l pl.UTF-8
67 Dokumentacja do %{name}.
68
69 %prep
70 %setup -q -n %{pkgname}-%{version}
71 %undos -f php
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{php_data_dir},%{_examplesdir}/%{name}-%{version}}
76 cp -a Classes/* $RPM_BUILD_ROOT%{php_data_dir}
77 cp -a Examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %files
83 %defattr(644,root,root,755)
84 %doc install.txt changelog.txt
85 %{php_data_dir}/PHPExcel.php
86 %dir %{php_data_dir}/PHPExcel
87 %{php_data_dir}/PHPExcel/*.php
88 %{php_data_dir}/PHPExcel/CachedObjectStorage
89 %{php_data_dir}/PHPExcel/CalcEngine
90 %{php_data_dir}/PHPExcel/Calculation
91 %{php_data_dir}/PHPExcel/Cell
92 %{php_data_dir}/PHPExcel/Chart
93 %{php_data_dir}/PHPExcel/Reader
94 %{php_data_dir}/PHPExcel/RichText
95 %{php_data_dir}/PHPExcel/Shared
96 %{php_data_dir}/PHPExcel/Style
97 %{php_data_dir}/PHPExcel/Worksheet
98 %{php_data_dir}/PHPExcel/Writer
99
100 %dir %{php_data_dir}/PHPExcel/locale
101 %lang(cs) %{php_data_dir}/PHPExcel/locale/cs
102 %lang(da) %{php_data_dir}/PHPExcel/locale/da
103 %lang(de) %{php_data_dir}/PHPExcel/locale/de
104 %lang(en_GB) %dir %{php_data_dir}/PHPExcel/locale/en
105 %lang(en_GB) %{php_data_dir}/PHPExcel/locale/en/uk
106 %lang(es) %{php_data_dir}/PHPExcel/locale/es
107 %lang(fi) %{php_data_dir}/PHPExcel/locale/fi
108 %lang(fr) %{php_data_dir}/PHPExcel/locale/fr
109 %lang(hu) %{php_data_dir}/PHPExcel/locale/hu
110 %lang(it) %{php_data_dir}/PHPExcel/locale/it
111 %lang(nb) %{php_data_dir}/PHPExcel/locale/no
112 %lang(nl) %{php_data_dir}/PHPExcel/locale/nl
113 %lang(pl) %{php_data_dir}/PHPExcel/locale/pl
114 %lang(pt_BR) %dir %{php_data_dir}/PHPExcel/locale/pt
115 %lang(pt_BR) %{php_data_dir}/PHPExcel/locale/pt/br
116 %lang(pt_BR) %{php_data_dir}/locale/pt/config
117 %lang(pt_BR) %{php_data_dir}/locale/pt/functions
118 %lang(ru) %{php_data_dir}/PHPExcel/locale/ru
119 %lang(sv) %{php_data_dir}/PHPExcel/locale/sv
120 %lang(tr) %{php_data_dir}/PHPExcel/locale/tr
121
122 %files examples
123 %defattr(644,root,root,755)
124 %{_examplesdir}/%{name}-%{version}
This page took 0.093367 seconds and 3 git commands to generate.