]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
90fb48334ed65d050ecbc29553a94bacaaddb353
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         php_name        php%{?php_suffix}
2 %define         modname sasl
3 %define         status          alpha
4 Summary:        %{modname} - Cyrus SASL extension
5 Summary(pl.UTF-8):      %{modname} - rozszerzenie Cyrus SASL
6 Name:           %{php_name}-pecl-%{modname}
7 Version:        0.2.0
8 Release:        1
9 License:        PHP 3.01
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{modname}-0.1.0.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 Patch99:        prepatch.patch
14 Patch100:       branch.diff
15 Patch1:         php-pecl-%{modname}-lib64_fix.patch
16 URL:            http://pecl.php.net/package/sasl/
17 BuildRequires:  %{php_name}-devel >= 3:5.0.4
18 BuildRequires:  cyrus-sasl-devel
19 BuildRequires:  rpmbuild(macros) >= 1.650
20 %{?requires_php_extension}
21 Provides:       php(%{modname}) = %{version}
22 Obsoletes:      php-pecl-sasl < 0.1.0-14
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 SASL is the Simple Authentication and Security Layer (as defined by
27 RFC 2222). It provides a system for adding plugable authenticating
28 support to connection-based protocols. The SASL extension for PHP
29 makes the Cyrus SASL library functions available to PHP. It aims to
30 provide a 1-to-1 wrapper around the SASL library to provide the
31 greatest amount of implementation flexibility. To that end, it is
32 possible to build both a client-side and server-side SASL
33 implementation entirely in PHP.
34
35 In PECL status of this extension is: %{status}.
36
37 %description -l pl.UTF-8
38 SASL to warstwa prostego uwierzytelnienia i bezpieczeństwa (Simple
39 Authentication and Security Layer) zdefiniowana w RFC 2222. Dostarcza
40 system do dodawania wtyczek obsługujących uwierzytelnianie do
41 protokołów opartych na połączeniach. Rozszerzenie SASL dla PHP
42 udostępnia w PHP funkcje biblioteki Cyrus SASL. Celem jest
43 dostarczenie obudowania 1-do-1 biblioteki SASL, aby udostępnić jak
44 największą elastyczność implementacji. W tym celu możliwe jest
45 zbudowanie zarówno klienckiej jak i serwerowej implementacji SASL
46 całkowicie w PHP.
47
48 To rozszerzenie ma w PECL status: %{status}.
49
50 %prep
51 %setup -qc
52 mv %{modname}-*/* .
53 %patch99 -p1
54 %patch100 -p0
55 %if "%{_lib}" == "lib64"
56 %patch1 -p1
57 %endif
58
59 %build
60 phpize
61 %configure
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
67 install -p modules/%{modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
68 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
69 ; Enable %{modname} extension module
70 extension=%{modname}.so
71 EOF
72
73 %clean
74 rm -rf $RPM_BUILD_ROOT
75
76 %post
77 %php_webserver_restart
78
79 %postun
80 if [ "$1" = 0 ]; then
81         %php_webserver_restart
82 fi
83
84 %files
85 %defattr(644,root,root,755)
86 %doc docs/TODO docs/guide.txt
87 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
88 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.17601 seconds and 2 git commands to generate.