]> git.pld-linux.org Git - packages/php-pecl-sasl.git/blob - php-pecl-sasl.spec
065bec87cccff449a7795ccbef322394649a874b
[packages/php-pecl-sasl.git] / php-pecl-sasl.spec
1 %define         _modname        sasl
2 %define         _status         alpha
3
4 Summary:        %{_modname} - Cyrus SASL extension
5 Summary(pl):    %{_modname} - rozszerzenie Cyrus SASL
6 Name:           php-pecl-%{_modname}
7 Version:        0.1.0
8 Release:        1
9 License:        PHP 2.02
10 Group:          Development/Languages/PHP
11 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
12 # Source0-md5:  8431731cc8a7921a2922af23a57a572f
13 Patch0:         %{name}-lib_fix.patch
14 URL:            http://pecl.php.net/package/sasl/
15 BuildRequires:  cyrus-sasl-devel
16 BuildRequires:  libtool
17 BuildRequires:  php-devel
18 Requires:       php-common
19 Obsoletes:      php-pear-%{_modname}
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %define         _sysconfdir     /etc/php
23 %define         extensionsdir   %{_libdir}/php
24
25 %description
26 SASL is the Simple Authentication and Security Layer (as defined by
27 RFC 2222). It provides a system for adding plugable authenticating
28 support to connection-based protocols. The SASL extension for PHP
29 makes the Cyrus SASL library functions available to PHP. It aims to
30 provide a 1-to-1 wrapper around the SASL library to provide the
31 greatest amount of implementation flexibility. To that end, it is
32 possible to build both a client-side and server-side SASL
33 implementation entirely in PHP.
34
35 In PECL status of this extension is: %{_status}.
36
37 #%description -l pl
38 #
39 #To rozszerzenie ma w PECL status: %{_status}.
40
41 %prep
42 %setup -q -c
43 %patch0 -p1
44
45 %build
46 cd %{_modname}-%{version}
47 phpize
48 LDFLAGS="%{_rpmldflags} -L%{_libdir}" %configure
49 %{__make}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d $RPM_BUILD_ROOT%{extensionsdir}
54
55 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{extensionsdir}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %post
61 %{_sbindir}/php-module-install install %{_modname} %{_sysconfdir}/php-cgi.ini
62
63 %preun
64 if [ "$1" = "0" ]; then
65         %{_sbindir}/php-module-install remove %{_modname} %{_sysconfdir}/php-cgi.ini
66 fi
67
68 %files
69 %defattr(644,root,root,755)
70 %doc %{_modname}-%{version}/docs/TODO
71 %attr(755,root,root) %{extensionsdir}/%{_modname}.so
This page took 0.114539 seconds and 2 git commands to generate.