]> git.pld-linux.org Git - packages/php-pecl-expect.git/blob - php-pecl-expect.spec
- release 2
[packages/php-pecl-expect.git] / php-pecl-expect.spec
1 %define         _modname        expect
2 %define         _status         beta
3 Summary:        %{_modname} - PHP extension for expect library
4 Summary(pl.UTF-8):      %{_modname} - rozszerzenie PHP dla biblioteki expect
5 Name:           php-pecl-%{_modname}
6 Version:        0.2.2
7 Release:        2
8 License:        PHP 2.02
9 Group:          Development/Languages/PHP
10 Source0:        http://pecl.php.net/get/%{_modname}-%{version}.tgz
11 # Source0-md5:  cfa53c9cad2fa80317d81e72f391c9f5
12 URL:            http://pecl.php.net/package/expect/
13 BuildRequires:  expect-devel
14 BuildRequires:  php-devel >= 3:5.0.0
15 BuildRequires:  rpmbuild(macros) >= 1.344
16 %{?requires_php_extension}
17 Requires:       php-common >= 4:5.0.4
18 Obsoletes:      php-pear-%{_modname}
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This extension allows to interact with processes through PTY, using
23 expect library.
24
25 In PECL status of this extension is: %{_status}.
26
27 %description -l pl.UTF-8
28 To rozszerzenie pozwala na interakcję z procesami poprzez PTY przy
29 użyciu biblioteki expect.
30
31 To rozszerzenie ma w PECL status: %{_status}.
32
33 %prep
34 %setup -q -c
35
36 %build
37 cd %{_modname}-%{version}
38 phpize
39 %configure
40 %{__make}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44 install -d $RPM_BUILD_ROOT{%{php_sysconfdir}/conf.d,%{php_extensiondir}}
45
46 install %{_modname}-%{version}/modules/%{_modname}.so $RPM_BUILD_ROOT%{php_extensiondir}
47 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{_modname}.ini
48 ; Enable %{_modname} extension module
49 extension=%{_modname}.so
50 EOF
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %post
56 %php_webserver_restart
57
58 %postun
59 if [ "$1" = 0 ]; then
60         %php_webserver_restart
61 fi
62
63 %files
64 %defattr(644,root,root,755)
65 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{_modname}.ini
66 %attr(755,root,root) %{php_extensiondir}/%{_modname}.so
This page took 0.111768 seconds and 3 git commands to generate.