]> git.pld-linux.org Git - packages/php-dbus.git/blob - php-dbus.spec
- obsolete old php name
[packages/php-dbus.git] / php-dbus.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # build without tests
4
5 %define         php_name        php%{?php_suffix}
6 %define         modname dbus
7 Summary:        DBus binding for PHP
8 Name:           %{php_name}-%{modname}
9 Version:        0.1.2
10 Release:        3
11 License:        PHP 3.0
12 Group:          Development/Languages/PHP
13 Source0:        http://labs.gree.jp/data/source/php-dbus-%{version}.tgz
14 # Source0-md5:  2fc2b92ac805128326ecfa382f6807ab
15 URL:            http://labs.gree.jp/Top/OpenSource/DBus-en.html
16 BuildRequires:  %{php_name}-devel >= 4:5.0.4
17 BuildRequires:  dbus-devel
18 BuildRequires:  pkgconfig
19 BuildRequires:  rpmbuild(macros) >= 1.519
20 %{?requires_php_extension}
21 Obsoletes:      php-dbus < 0.1.2-2
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 PHP Dbus is a PHP extension to handle D-Bus functions. This module
26 provides D-Bus interfaces via PHP classes and enables Inter Porcess
27 Communication in D-Bus.
28
29 %prep
30 %setup -q -n php-%{modname}-%{version}
31
32 %build
33 phpize
34 CPPFLAGS="%{rpmcppflags} -DDBUS_API_SUBJECT_TO_CHANGE"
35 %configure
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d
41
42 %{__make} install \
43         INSTALL_ROOT=$RPM_BUILD_ROOT \
44         EXTENSION_DIR=%{php_extensiondir}
45 cat <<'EOF' > $RPM_BUILD_ROOT%{php_sysconfdir}/conf.d/%{modname}.ini
46 ; Enable %{modname} extension module
47 extension=%{modname}.so
48 EOF
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 %php_webserver_restart
55
56 %postun
57 if [ "$1" = 0 ]; then
58         %php_webserver_restart
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %doc CREDITS
64 %config(noreplace) %verify(not md5 mtime size) %{php_sysconfdir}/conf.d/%{modname}.ini
65 %attr(755,root,root) %{php_extensiondir}/%{modname}.so
This page took 0.094316 seconds and 3 git commands to generate.