]> git.pld-linux.org Git - packages/perl-cdk.git/blob - perl-cdk.spec
- rebuild with perl 5.30.0
[packages/perl-cdk.git] / perl-cdk.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 Summary:        Perl extensions for CDK
7 Summary(pl.UTF-8):      Rozszerzenie Perla dla CDK
8 Name:           perl-cdk
9 Version:        20150928
10 Release:        2
11 License:        distributable
12 Group:          Development/Languages/Perl
13 Source0:        ftp://ftp.invisible-island.net/cdk/cdk-perl-%{version}.tgz
14 # Source0-md5:  28bb44e50b15c94f0f6f6e86c5a69c96
15 URL:            http://invisible-island.net/cdk/
16 BuildRequires:  cdk-devel >= 5
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This is the Perl5 extension to the CDK library written by Mike Glover.
23 All the copyright notices from the CDK C distribution also apply to
24 the extension.
25
26 %description -l pl.UTF-8
27 To jest rozszerzenie Perla do biblioteki CDK. Wszystkie copyrighty z
28 dystrybucji CDK dotyczą także tego rozszerzenia.
29
30 %prep
31 %setup -q -n cdk-perl-%{version}
32
33 %build
34 %configure
35
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38 %{__make} \
39         CC="%{__cc}" \
40         OPTIMIZE="%{rpmcflags}"
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50 install examples/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc README CHANGES demos fulldemo
58 %{perl_vendorarch}/Cdk.pm
59 %{perl_vendorarch}/Cdk
60 %dir %{perl_vendorarch}/auto/Cdk
61 %attr(755,root,root) %{perl_vendorarch}/auto/Cdk/Cdk.so
62 %{perl_vendorarch}/auto/Cdk/autosplit.ix
63 %dir %{_examplesdir}/%{name}-%{version}
64 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.097411 seconds and 3 git commands to generate.