]> git.pld-linux.org Git - packages/perl-Tree-DAG_Node.git/blob - perl-Tree-DAG_Node.spec
- updated to 1.29
[packages/perl-Tree-DAG_Node.git] / perl-Tree-DAG_Node.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Tree
7 %define         pnam    DAG_Node
8 Summary:        Tree::DAG_Node - (super)class for representing nodes in a tree
9 Summary(pl.UTF-8):      Tree::DAG_Node - (nad)klasa do reprezentowania węzłów w drzewie
10 Name:           perl-Tree-DAG_Node
11 Version:        1.29
12 Release:        1
13 License:        Artistic v2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Tree/%{pdir}-%{pnam}-%{version}.tgz
16 # Source0-md5:  0d2c2f7cb7f12afafd28bbab75e15442
17 URL:            http://search.cpan.org/dist/Tree-DAG_Node/
18 BuildRequires:  perl-devel >= 1:5.8.1
19 %if %{with tests}
20 BuildRequires:  perl(File::Spec) >= 3.40
21 BuildRequires:  perl-File-Slurp-Tiny >= 0.003
22 BuildRequires:  perl-File-Temp >= 0.19
23 BuildRequires:  perl-Test-Simple >= 1.001_014
24 BuildRequires:  perl-Test-Pod >= 1.48
25 %endif
26 BuildRequires:  rpm-perlprov >= 4.1-13
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 This class encapsulates/makes/manipulates objects that represent nodes
32 in a tree structure. The tree structure is not an object itself, but
33 is emergent from the linkages you create between nodes. This class
34 provides the methods for making linkages that can be used to build up
35 a tree, while preventing you from ever making any kinds of linkages
36 which are not allowed in a tree (such as having a node be its own
37 mother or ancestor, or having a node have two mothers).
38
39 %description -l pl.UTF-8
40 Ta klasa obudowuje, tworzy i obrabia obiekty, które reprezentują węzły
41 w strukturze drzewiastej. Struktura drzewiasta jako taka nie jest
42 obiektem, ale wyłania się z połączeń tworzonych pomiędzy węzłami. Ta
43 klasa udostępnia metody do tworzenia połączeń, które mogą być używane
44 do zbudowania drzewa, nie dopuszczając na zrobienie połączeń nie
45 dozwolonych w drzewie (takich jak połączenie węzła z jego przodkiem,
46 lub nadanie węzłowi dwóch przodków).
47
48 %prep
49 %setup -q -n %{pdir}-%{pnam}-%{version}
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make}
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorlib}/Tree/DAG_Node.pm
71 %{_mandir}/man3/Tree::DAG_Node.3pm*
This page took 0.074432 seconds and 3 git commands to generate.