]> git.pld-linux.org Git - packages/perl-Sys-Virt.git/blob - perl-Sys-Virt.spec
b7113dcc1f74d7359e23ccc68e8681f2cd7aa704
[packages/perl-Sys-Virt.git] / perl-Sys-Virt.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # perform "make test" (requires libvirtd)
4 #
5 %define         pdir    Sys
6 %define         pnam    Virt
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Sys::Virt - Represent and manage a libvirt hypervisor connection
9 Summary(pl.UTF-8):      Sys::Virt - reprezentacja i zarządzanie połączeniem z hipernadzorcą libvirt
10 Name:           perl-Sys-Virt
11 Version:        1.0.5
12 Release:        2
13 License:        GPL v2+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  f3c91cb5be52919b28eb51ace45dc3f9
17 URL:            http://search.cpan.org/dist/Sys-Virt/
18 BuildRequires:  libvirt-devel >= 1.0.5
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  pkgconfig
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  libvirt-daemon >= 1.0.5
24 BuildRequires:  perl-CPAN-Changes
25 BuildRequires:  perl-Test-Pod
26 BuildRequires:  perl-Test-Pod-Coverage
27 BuildRequires:  perl-Test-Simple
28 BuildRequires:  perl-Time-HiRes
29 BuildRequires:  perl-XML-XPath
30 %endif
31 Requires:       libvirt >= 1.0.5
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 The Sys::Virt module provides a Perl XS binding to the libvirt virtual
36 machine management APIs. This allows machines running within arbitrary
37 virtualization containers to be managed with a consistent API.
38
39 %description -l pl.UTF-8
40 Moduł Sys::Virt dostarcza wiązanie XS Perla do API zarządzania
41 maszynami wirtualnymi libvirt. Pozwala na zarządzanie poprzez
42 jednolite API maszynami wirtualnymi działającymi w dowolnych
43 kontenerach.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} -j1 \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} pure_install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc AUTHORS Changes README
72 %{perl_vendorarch}/Sys/Virt.pm
73 %dir %{perl_vendorarch}/Sys/Virt
74 %{perl_vendorarch}/Sys/Virt/*.pm
75 %dir %{perl_vendorarch}/auto/Sys/Virt
76 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Virt/Virt.so
77 %{_mandir}/man3/Sys::Virt*.3pm*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.081941 seconds and 2 git commands to generate.