]> git.pld-linux.org Git - packages/perl-Sys-Mmap.git/blob - perl-Sys-Mmap.spec
41bb0ced18347bcd99de0f0a3754feb6183ae7d4
[packages/perl-Sys-Mmap.git] / perl-Sys-Mmap.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Sys
7 %define         pnam    Mmap
8 Summary:        Sys::Mmap - Perl module that allows to use mmap to map in a file as a Perl variable
9 Name:           perl-Sys-Mmap
10 Version:        0.16
11 Release:        7
12 # sae as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Sys/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  faae869e876fa86f92e6de3f13af3aef
17 URL:            http://search.cpan.org/dist/Sys-Mmap/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Mmap - uses mmap to map in a file as a Perl variable.
24
25 %prep
26 %setup -q -n %{pdir}-%{pnam}-%{version}
27
28 %build
29 %{__perl} Makefile.PL \
30         INSTALLDIRS=vendor
31 %{__make} \
32         CC="%{__cc}" \
33         OPTIMIZE="%{rpmcflags}"
34
35 %{?with_tests:%{__make} test}
36
37 %install
38 rm -rf $RPM_BUILD_ROOT
39
40 %{__make} install \
41         DESTDIR=$RPM_BUILD_ROOT
42
43 %clean
44 rm -rf $RPM_BUILD_ROOT
45
46 %files
47 %defattr(644,root,root,755)
48 %doc Change* README
49 %{perl_vendorarch}/Sys/*.pm
50 %dir %{perl_vendorarch}/auto/Sys/Mmap
51 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Mmap/*.so
52 %{_mandir}/man3/*
This page took 0.051894 seconds and 2 git commands to generate.