]> git.pld-linux.org Git - packages/perl-String-CRC.git/blob - perl-String-CRC.spec
- rebuild with perl 5.26
[packages/perl-String-CRC.git] / perl-String-CRC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    String
7 %define         pnam    CRC
8 Summary:        String::CRC - Perl interface to Cyclic Redundancy Check generation
9 Summary(pl.UTF-8):      String::CRC - perlowy interfejs do generowania CRC
10 Name:           perl-String-CRC
11 Version:        1.0
12 Release:        21
13 License:        Public Domain
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/String/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ba07f022b5abf869a7b73f98f8abcf9f
17 URL:            http://search.cpan.org/dist/String-CRC/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 String::CRC module calculates CRC of various lenghts.
24
25 %description -l pl.UTF-8
26 Moduł String::CRC oblicza CRC różnej długości.
27
28 %prep
29 %setup -q -n %{pdir}-%{pnam}-%{version}
30
31 %build
32 %{__perl} Makefile.PL \
33         INSTALLDIRS=vendor
34 %{__make} \
35         CC="%{__cc}" \
36         OPTIMIZE="%{rpmcflags}"
37
38 %{?with_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc README
52 %{perl_vendorarch}/String/CRC.pm
53 %dir %{perl_vendorarch}/auto/String/CRC
54 %attr(755,root,root) %{perl_vendorarch}/auto/String/CRC/CRC.so
55 %{_mandir}/man3/*
This page took 0.055799 seconds and 3 git commands to generate.