]> git.pld-linux.org Git - packages/perl-Plack.git/blob - perl-Plack.spec
- spec cleanup
[packages/perl-Plack.git] / perl-Plack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Plack
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        Plack - Perl Superglue for Web frameworks and Web Servers (PSGI toolkit)
8 Name:           perl-Plack
9 Version:        1.0044
10 Release:        1
11 # same as perl
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Plack/%{pdir}-%{version}.tar.gz
15 # Source0-md5:  ecca999f0034f04c8dbcf230ac8c3241
16 URL:            http://search.cpan.org/dist/Plack/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl(Devel::StackTrace::AsHTML) >= 0.11
21 BuildRequires:  perl(Filesys::Notify::Simple)
22 BuildRequires:  perl(HTTP::Body) >= 1.06
23 BuildRequires:  perl(Hash::MultiValue) >= 0.05
24 BuildRequires:  perl(Test::Requires)
25 BuildRequires:  perl(Test::TCP) >= 0.11
26 BuildRequires:  perl-Apache-LogFormat-Compiler
27 BuildRequires:  perl-Devel-StackTrace >= 1.23
28 BuildRequires:  perl-File-ShareDir >= 1.00
29 BuildRequires:  perl-File-ShareDir-Install
30 BuildRequires:  perl-HTTP-Entity-Parser
31 BuildRequires:  perl-HTTP-Request-AsCGI
32 BuildRequires:  perl-Stream-Buffered
33 BuildRequires:  perl-Try-Tiny
34 BuildRequires:  perl-URI >= 1.36
35 BuildRequires:  perl-libwww >= 5.814
36 %endif
37 BuildArch:      noarch
38 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
39
40 %define         _noautoreq_perl 'Apache::Constants' 'Apache::Request'
41
42 %description
43 Plack is a set of tools for using the PSGI stack. It contains
44 middleware components, a reference server and utilities for Web
45 application frameworks. Plack is like Ruby's Rack or Python's Paste
46 for WSGI.
47
48 See PSGI for the PSGI specification and PSGI::FAQ to know what PSGI
49 and Plack are and why we need them.
50
51 %prep
52 %setup -q -n %{pdir}-%{version}
53
54 %build
55 %{__perl} Makefile.PL \
56         INSTALLDIRS=vendor
57 %{__make}
58
59 %{?with_tests:%{__make} test}
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63
64 %{__make} pure_install \
65         DESTDIR=$RPM_BUILD_ROOT
66
67 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
68 cp -a eg $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorlib}/*.pm
77 %{perl_vendorlib}/Plack/
78 %{_mandir}/man1/*
79 %{_mandir}/man3/*
80 %{_examplesdir}/%{name}-%{version}
81 %attr(755,root,root) %{_bindir}/plackup
82 %{perl_vendorlib}/HTTP/Message/PSGI.pm
83 %{perl_vendorlib}/HTTP/Server/PSGI.pm
84 %{perl_vendorlib}/auto/share/dist/Plack
This page took 0.116286 seconds and 3 git commands to generate.