]> git.pld-linux.org Git - packages/perl-Passwd-Linux.git/blob - perl-Passwd-Linux.spec
- perl req/prov fix
[packages/perl-Passwd-Linux.git] / perl-Passwd-Linux.spec
1 #
2 # Conditional build:
3 %bcond_with     tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    Passwd
7 %define pnam    Linux
8 Summary:        Passwd::Linux - Perl module for manipulating the passwd and shadow files
9 Summary(pl.UTF-8):      Passwd::Linux - Moduł Perla do manipulowania plikami passwd i shadow
10 Name:           perl-Passwd-Linux
11 Version:        1.2
12 Release:        4
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://search.cpan.org/CPAN/authors/id/E/EE/EESTABROO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  28e46f1991d2a26e54c8593487a14c27
17 URL:            http://search.cpan.org/dist/Passwd-Linux/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Passwd::Linux provides additional password routines. It augments the
24 getpw* functions with setpwinfo, modpwinfo, rmpwnam, mgetpwnam. You
25 need to run most of the functions as root or as someone who has
26 permission to modify the shadow file.
27
28 %description -l pl.UTF-8
29 Passwd::Linux dostarcza dodatkowych metod obsługi haseł. Powiększa
30 funkcje getpw* o setpwinfo, modpwinfo, rmpwnam, mgetpwnam. Większość
31 tych funkcji musi być uruchomiona z uprawnieniami roota lub osoby
32 mającej uprawnienia do modyfikacji pliku shadow.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} pure_install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/Passwd/Linux/.packlist
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes
60 %dir %{perl_vendorarch}/Passwd
61 %{perl_vendorarch}/Passwd/*.pm
62 %dir %{perl_vendorarch}/auto/Passwd
63 %dir %{perl_vendorarch}/auto/Passwd/Linux
64 %attr(755,root,root) %{perl_vendorarch}/auto/Passwd/Linux/*.so
65 %{_mandir}/man3/*
This page took 0.112909 seconds and 3 git commands to generate.