]> git.pld-linux.org Git - packages/perl-Math-BigInteger.git/blob - perl-Math-BigInteger.spec
6a07accaf8f97fd8e1f913fd511bb4bdf497b9b0
[packages/perl-Math-BigInteger.git] / perl-Math-BigInteger.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    BigInteger
8 Summary:        Math::BigInteger - arbitrary length integer extension module for Perl
9 Summary(pl.UTF-8):      Math::BigInteger - moduł rozszerzenia liczb całkowitych dowolnej długości
10 Name:           perl-Math-BigInteger
11 Version:        1.01
12 Release:        9
13 # if used in a product, Systemics should be given attribution
14 License:        free use, distributable
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a4aa79e070f3f5f8e7f01443fdc03b8e
18 Patch0:         %{name}-Fputc_to_fputc.patch
19 URL:            http://search.cpan.org/dist/Math-BigInteger/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Math::BigInteger module gives access to Eric Young's bignum library.
26 This provides a faster alternative to the Math::BigInt library.
27
28 %description -l pl.UTF-8
29 Moduł Math::BigInteger umożliwia dostęp do biblioteki bignum Erica
30 Younga. Jest to szybsza alternatywa dla biblioteki Math::BigInt.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34 %patch0 -p0
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc README COPYRIGHT
57 %{perl_vendorarch}/Math/BigInteger.pm
58 %dir %{perl_vendorarch}/auto/Math/BigInteger
59 %{perl_vendorarch}/auto/Math/BigInteger/BigInteger.bs
60 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInteger/BigInteger.so
61 %{_mandir}/man3/*
This page took 0.073889 seconds and 2 git commands to generate.