]> git.pld-linux.org Git - packages/perl-Math-BigInt-GMP.git/blob - perl-Math-BigInt-GMP.spec
- up to 1.51
[packages/perl-Math-BigInt-GMP.git] / perl-Math-BigInt-GMP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Math
7 %define         pnam    BigInt-GMP
8 Summary:        Math::BigInt::GMP - use the GMP library for Math::BigInt routines
9 Summary(pl.UTF-8):      Math::BigInt::GMP - wykorzystanie biblioteki GMP do funkcji Math::BigInt
10 Name:           perl-Math-BigInt-GMP
11 Version:        1.51
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Math/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8031a287150f5f1b292e9a970447deff
18 URL:            http://search.cpan.org/dist/Math-BigInt-GMP/
19 BuildRequires:  gmp-devel
20 BuildRequires:  perl-Math-BigInt >= 1.999726
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 Requires:       perl-Math-BigInt >= 1.999726
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Math::BigInt::GMP provides support for big integer calculations via
28 means of the GMP C-library. Math::BigInt::GMP now no longer uses
29 Math::GMP, but provides it's own XS layer to access the GMP C-library.
30 This cuts out another (perl sub routine) layer and also reduces the
31 memory footprint by not loading Math::GMP and Carp at all.
32
33 %description -l pl.UTF-8
34 Math::BigInt::GMP dostarcza obsługę obliczeń na wielkich liczbach
35 całkowitych z wykorzystaniem funkcjonalności biblioteki C GMP. Moduł
36 ten już nie używa Math::GMP, ale dostarcza własną warstwę XS do
37 odwoływania się do biblioteki GMP w C. Dzięki temu nie ma kolejnej
38 warstwy (podprocedury Perla), a wykorzystanie pamięci jest mniejsze
39 dzięki nie wczytywaniu modułów Math::GMP i Carp.
40
41 %prep
42 %setup -q -n %{pdir}-%{pnam}-%{version}
43
44 %build
45 %{__perl} Makefile.PL \
46         INSTALLDIRS=vendor
47 %{__make} \
48         CC="%{__cc}" \
49         OPTIMIZE="%{rpmcflags}"
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc BUGS CHANGES CREDITS LICENSE README TODO
65 %{perl_vendorarch}/Math/BigInt/GMP.pm
66 %dir %{perl_vendorarch}/auto/Math/BigInt/GMP
67 %attr(755,root,root) %{perl_vendorarch}/auto/Math/BigInt/GMP/GMP.so
68 %{_mandir}/man3/Math::BigInt::GMP.3pm*
This page took 0.406229 seconds and 3 git commands to generate.