]> git.pld-linux.org Git - packages/perl-MIME-Fast.git/blob - perl-MIME-Fast.spec
c69177ed56b93a0544248af77e6c0cc6e4b0466b
[packages/perl-MIME-Fast.git] / perl-MIME-Fast.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    MIME
7 %define         pnam    Fast
8 Summary:        MIME::Fast - parsing MIME messages (wrapper for C gmime library)
9 Summary(pl.UTF-8):      MIME::Fast - przetwarzanie wiadomości MIME (interfejs do biblioteki gmime)
10 Name:           perl-MIME-Fast
11 Version:        1.6
12 Release:        5
13 # same as perl or GPL v2
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/MIME/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  3c6466c7645bed52ae6bbce9705e3814
18 Patch0:         %{name}-gmime.patch
19 URL:            http://search.cpan.org/dist/MIME-Fast/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 # Can't test with earlier versions of gmime-2
23 BuildRequires:  gmime-devel >= 2.1.0
24 %if %{with tests}
25 BuildRequires:  perl(Test::More)
26 # We don't have this
27 #BuildRequires: perl-PerlIO-gzip
28 %endif
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 MIME::Fast is a perl module for creating, editing and parsing MIME
33 messages.  This module is based on the very good C library called
34 gmime (currently in development). MIME::Fast outght to be faster and
35 should use less memory and CPU resources than standard MIME (perl
36 module), because MIME::Fast is the wrapper for C functions (calling
37 C function is much, much less expensive than calling perl function).
38
39 %description -l pl.UTF-8
40 MIME::Fast to moduł Perla do tworzenia, edycji i analizy wiadomości
41 MIME. Ten moduł jest oparty na bardzo dobrej bibliotece C o nazwie
42 gmime (aktualnie rozwijanej). MIME::Fast powinien być szybszy i używać
43 mniej pamięci oraz zasobów procesora niż standardowy moduł Perla MIME,
44 ponieważ jest interfejsem do funkcji w C (wywołanie funkcji C jest
45 dużo, dużo mniej kosztowne niż wywołanie funkcji perlowej).
46
47 %prep
48 %setup -q -n %{pdir}-%{pnam}-%{version}
49 %patch0 -p1
50
51 %build
52 %{__perl} Makefile.PL \
53         INSTALLDIRS=vendor
54 %{__make} \
55         CC="%{__cc}" \
56         OPTIMIZE="%{rpmcflags}"
57
58 %{?with_tests:%{__make} test}
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62
63 %{__make} install \
64         DESTDIR=$RPM_BUILD_ROOT
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes README TODO
72 %{perl_vendorarch}/MIME/Fast.pm
73 %dir %{perl_vendorarch}/auto/MIME/Fast
74 %attr(755,root,root) %{perl_vendorarch}/auto/MIME/Fast/*.so
75 %{_mandir}/man3/*
This page took 0.047517 seconds and 2 git commands to generate.