]> git.pld-linux.org Git - packages/perl-Image-ExifTool.git/blob - perl-Image-ExifTool.spec
dfaac2d93ebc60a1e87853cda67a94d6d1577d7c
[packages/perl-Image-ExifTool.git] / perl-Image-ExifTool.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Image
7 %define         pnam    ExifTool
8 Summary:        Perl module for reading and writing image metadata
9 Summary(pl.UTF-8):      Moduł Perla do czytania i zapisywania metadanych w plikach graficznych
10 Name:           perl-Image-ExifTool
11 Version:        6.17
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  2c839c4d58b59bf18378a99ac4ea0861
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ExifTool is a customizable set of Perl libraries plus an application
25 script for reading and writing meta information in image, audio and
26 video files.
27
28 ExifTool reads EXIF, GPS, IPTC, XMP, JFIF, GeoTIFF, ICC Profile,
29 Photoshop IRB, AFCP and ID3 meta information from JPG, JP2, TIFF, GIF,
30 BMP, PICT, QTIF, PNG, MNG, JNG, MIFF, PPM, PGM, PBM, XMP, EPS, PS, AI,
31 PDF, PSD, DCM, ACR, THM, CRW, CR2, MRW, NEF, PEF, ORF, RAF, RAW, SRF,
32 SR2, MOS, X3F and DNG images, MP3, WAV, WMA and AIFF audio files, and
33 AVI, MOV, MP4 and WMV videos. ExifTool also extracts information from
34 the maker notes of many digital cameras by various manufacturers
35 including Canon, Casio, FujiFilm, JVC/Victor, Kodak, Leaf,
36 Minolta/Konica-Minolta, Nikon, Olympus/Epson, Panasonic/Leica,
37 Pentax/Asahi, Ricoh, Sanyo and Sigma/Foveon.
38
39 ExifTool writes EXIF, GPS, IPTC, XMP, MakerNotes, Photoshop IRB and
40 AFCP meta information to JPEG, TIFF, GIF, PSD, XMP, PPM, PGM, PBM,
41 PNG, MNG, JNG, CRW, THM, CR2, MRW, NEF, PEF, MOS and DNG images.
42
43 See html/index.html for more details about ExifTool features.
44
45 %description -l pl.UTF-8
46 ExifTool to dostosowywalny zestaw bibliotek perlowych oraz aplikacja
47 do czytania i zapisywania metadanych w plikach graficznych,
48 dźwiękowych i wideo.
49
50 ExifTool potrafi odczytać metatagi EXIF, GPS, IPTC, XMP, JFIF,
51 GeoTIFF, ICC Profile, Photoshop IRB, AFCP i ID3 z plików graficznych
52 JPG, JP2, TIFF, GIF, BMP, PICT, QTIF, PNG, MNG, JNG, MIFF, PPM, PGM,
53 PBM, XMP, EPS, PS, AI, PDF, PSD, DCM, ACR, THM, CRW, CR2, MRW, NEF,
54 PEF, ORF, RAF, RAW, SRF, SR2, MOS, X3F i DNG, z plików dźwiękowych
55 MP3, WAV, WMA i AIFF oraz z plików wideo AVI, MOV, MP4 i WMV. ExifTool
56 odczytuje również informacje dodatkowe o zdjęciach zapisywane przez
57 aparaty cyfrowe takich firm jak Canon, Casio, FujiFilm, JVC/Victor,
58 Kodak, Leaf, Minolta/Konica-Minolta, Nikon, Olympus/Epson,
59 Panasonic/Leica, Pentax/Asahi, Ricoh, Sanyo i Sigma/Foveon.
60
61 ExifTool potrafi zapisać metatagi EXIF, GPS, IPTC, XMP, Photoshop IRB
62 i AFCP wraz z informacjami dodatkowymi producenta do plików JPEG,
63 TIFF, GIF, PSD, XMP, PPM, PGM, PBM, PNG, MNG, JNG, CRW, THM, CR2, MRW,
64 NEF, PEF, MOS i DNG.
65
66 Więcej informacji o możliwościach pakietu ExifTool znajduje się w
67 pliku html/index.html.
68
69 %prep
70 %setup -q -n %{pdir}-%{pnam}-%{version}
71
72 %build
73 %{__perl} Makefile.PL \
74         INSTALLDIRS=vendor \
75         destdir=$RPM_BUILD_ROOT
76 %{__make} \
77         CC="%{__cc}" \
78         OPTIMIZE="%{rpmcflags}"
79
80 %{?with_tests:%{__make} test}
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84
85 %{__make} install \
86         DESTDIR=$RPM_BUILD_ROOT
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %files
92 %defattr(644,root,root,755)
93 %doc README Changes html
94 %attr(755,root,root) %{_bindir}/exiftool
95 %{perl_vendorlib}/File/RandomAccess.pm
96 %{perl_vendorlib}/Image/ExifTool.pm
97 %dir %{perl_vendorlib}/Image/ExifTool
98 %{perl_vendorlib}/Image/ExifTool/*.p[lm]
99 %{_mandir}/man[13]/*
This page took 0.071946 seconds and 2 git commands to generate.