]> git.pld-linux.org Git - packages/perl-IO-AIO.git/blob - perl-IO-AIO.spec
- rebuild with perl 5.18.0
[packages/perl-IO-AIO.git] / perl-IO-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    AIO
8 Summary:        IO::AIO - Perl Asynchronous Input/Output
9 Summary(pl.UTF-8):      IO::AIO - asynchroniczne wejście/wyjście w Perlu
10 Name:           perl-IO-AIO
11 Version:        4.15
12 Release:        2
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/IO/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c5a127a431e8fb39395df4738055e48a
17 URL:            http://search.cpan.org/dist/IO-AIO/
18 BuildRequires:  perl-devel >= 1:5.8.2
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-common-sense
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module implements asynchronous I/O using whatever means your
27 operating system supports.
28
29 %description -l pl.UTF-8
30 Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
31 metod obsługiwanych przez system operacyjny.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %attr(755,root,root) %{_bindir}/treescan
59 %{perl_vendorarch}/IO/AIO.pm
60 %dir %{perl_vendorarch}/auto/IO/AIO
61 %{perl_vendorarch}/auto/IO/AIO/AIO.bs
62 %attr(755,root,root) %{perl_vendorarch}/auto/IO/AIO/AIO.so
63 %{_mandir}/man3/IO::AIO.3pm*
This page took 0.128735 seconds and 4 git commands to generate.