]> git.pld-linux.org Git - packages/perl-IO-AIO.git/blob - perl-IO-AIO.spec
- up to 2.51
[packages/perl-IO-AIO.git] / perl-IO-AIO.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    IO
7 %define         pnam    AIO
8 Summary:        IO::AIO - Perl Asynchronous Input/Output
9 Summary(pl.UTF-8):      IO::AIO - asynchroniczne wejście/wyjście w Perlu
10 Name:           perl-IO-AIO
11 Version:        2.51
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a9051ad1eca00a083f9880014fb17c0a
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements asynchronous I/O using whatever means your
24 operating system supports.
25
26 %description -l pl.UTF-8
27 Ten moduł implementuje asynchroniczne we/wy przy użyciu dowolnych
28 metod obsługiwanych przez system operacyjny.
29
30 %prep
31 %setup -q -n %{pdir}-%{pnam}-%{version}
32
33 %build
34 %{__perl} Makefile.PL \
35         INSTALLDIRS=vendor
36
37 %{__make} \
38         OPTIMIZE="%{rpmcflags}"
39
40 %{?with_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_vendorarch}/IO/AIO.pm
55 %dir %{perl_vendorarch}/auto/IO/AIO
56 %{perl_vendorarch}/auto/IO/AIO/AIO.bs
57 %attr(755,root,root) %{perl_vendorarch}/auto/IO/AIO/AIO.so
58 %{_mandir}/man3/*
This page took 0.085432 seconds and 4 git commands to generate.