]> git.pld-linux.org Git - packages/perl-Geo-Shapelib.git/blob - perl-Geo-Shapelib.spec
- perl req/prov fix
[packages/perl-Geo-Shapelib.git] / perl-Geo-Shapelib.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Geo
7 %define         pnam    Shapelib
8 Summary:        Geo::Shapelib - Perl extension for reading and writing shapefiles as defined by ESRI(r)
9 Summary(pl.UTF-8):      Geo::Shapelib - rozszerzenie Perla o obsługę r/w plików ESRI(r) SHP
10 Name:           perl-Geo-Shapelib
11 Version:        0.20
12 Release:        11
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Geo/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  ca0246d5b5c8950153a5c48eea0d2d2c
17 URL:            http://search.cpan.org/dist/Geo-Shapelib/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Tree-R
22 %endif
23 Requires:       perl-Tree-R
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a library for reading, creating, and writing shapefiles as
28 defined by ESRI(r) using Perl. The Perl code uses Frank Warmerdam's
29 Shapefile C Library (http://shapelib.maptools.org/). The library is
30 included in this distribution.
31
32 %description -l pl.UTF-8
33 Biblioteka ta umożliwia wczytywanie, tworzenie oraz zapisywanie tzw.
34 shapefiles zdefiniowanych przez ESRI(r) z poziomu Perla. Kod
35 wykorzystuje bibliotekę C Shapefile Franka Warmerdama
36 (http://shapelib.maptools.org/). Biblioteka ta jest załączona w
37 pakiecie.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorarch}/Geo/Shapelib.pm
63 %dir %{perl_vendorarch}/auto/Geo/Shapelib
64 %{perl_vendorarch}/auto/Geo/Shapelib/shputils
65 %attr(755,root,root) %{perl_vendorarch}/auto/Geo/Shapelib/Shapelib.so
66 %{_mandir}/man3/*
This page took 0.270651 seconds and 3 git commands to generate.