]> git.pld-linux.org Git - packages/perl-EV.git/blob - perl-EV.spec
dad7241e86fefb44d6a0e4c49c6aa14279bba16a
[packages/perl-EV.git] / perl-EV.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # perform "make test"
4
5 %define         pdir    EV
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        EV - Perl interface to libev, a high performance full-featured event loop
8 Summary(pl.UTF-8):      EV - perlowy interfejs do libev - wydajnej pętli zdarzeń
9 Name:           perl-EV
10 Version:        4.18
11 Release:        1
12 Epoch:          1
13 # same as Perl, libev: BSD-like
14 License:        GPL v1+ or Artistic (Perl module), BSD-like (embedded libev)
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/M/ML/MLEHMANN/%{pdir}-%{version}.tar.gz
17 # Source0-md5:  5931d0ba91f93b95723e80d573da606f
18 URL:            http://search.cpan.org/dist/EV/
19 BuildRequires:  perl-common-sense
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module provides an interface to libev
26 <http://software.schmorp.de/pkg/libev.html>.
27
28 This module is very fast and scalable. It is actually so fast that you
29 can use it through the AnyEvent module, stay portable to other event
30 loops (if you don't rely on any watcher types not available through
31 it) and still be faster than with any other event loop currently
32 supported in Perl.
33
34 %description -l pl.UTF-8
35 Moduł ten dostarcza intefejs do libev
36 <http://software.schmorp.de/pkg/libev.html>.
37
38 Jest bardzo szybki i skalowalny. Właściwie jest na tyle szybki, że
39 można go użyć poprzez moduł AnyEvent i pozostawić kod przenośnym na
40 inne pętle zdarzeń (jeśli nie jest wymagane użycie typów obserwatorów
41 niedostępnych przez AnyEvent), i całość jest nadal szybsza niż inne
42 pętle zdarzeń dostępne z poziomu Perla.
43
44 %prep
45 %setup -q -n %{pdir}-%{version}
46
47 %build
48 %{__perl} Makefile.PL \
49         INSTALLDIRS=vendor </dev/null
50 %{__make} \
51         CC="%{__cc}" \
52         OPTIMIZE="%{rpmcflags}"
53
54 %{?with_tests:%{__make} test}
55
56 %install
57 rm -rf $RPM_BUILD_ROOT
58
59 %{__make} pure_install \
60         DESTDIR=$RPM_BUILD_ROOT
61
62 install -d libev-doc
63 mv -f libev/{Changes,LICENSE,README} libev-doc
64 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/EV/libev.pod
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %doc Changes COPYING README libev-doc
72 %dir %{perl_vendorarch}/EV
73 %{perl_vendorarch}/EV/*.pm
74 %{perl_vendorarch}/EV.pm
75 %{perl_vendorarch}/EV/EVAPI.h
76 %{perl_vendorarch}/EV/ev.h
77 %dir %{perl_vendorarch}/auto/EV
78 %{perl_vendorarch}/auto/EV/EV.bs
79 %attr(755,root,root) %{perl_vendorarch}/auto/EV/EV.so
80 %{_mandir}/man3/EV*.3pm*
This page took 0.067919 seconds and 2 git commands to generate.