]> git.pld-linux.org Git - packages/perl-DB_File.git/blob - perl-DB_File.spec
- release 3 (by relup.sh)
[packages/perl-DB_File.git] / perl-DB_File.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define db_ver  %(rpm -q --whatprovides --qf '%%{epoch}:%%{version}' db-devel)
6 #
7 %include        /usr/lib/rpm/macros.perl
8 %define         pdir    DB_File
9 %define         pnam    DB_File
10 Summary:        DB_File allows to manage a simple ASCII database
11 Summary(pl.UTF-8):      DB_File pozwala na korzystanie z prostej, tekstowej bazy danych
12 Name:           perl-DB_File
13 Version:        1.826
14 Release:        3
15 # same as perl
16 License:        GPL v1+ or Artistic
17 Group:          Development/Languages/Perl
18 Source0:        http://www.cpan.org/modules/by-module/DB_File/%{pnam}-%{version}.tar.gz
19 # Source0-md5:  4bc334674903b799ccf15e5ae042a40b
20 Patch0:         %{name}-rpm-automation.patch
21 URL:            http://search.cpan.org/dist/DB_File/
22 BuildRequires:  db-devel
23 BuildRequires:  perl-devel >= 1:5.8.0
24 BuildRequires:  rpm-perlprov >= 4.1-13
25 Requires:       db = %{db_ver}
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 DB_File is a module which allows Perl programs to make use of the
30 facilities provided by Berkeley DB version 1.
31
32 %description -l pl.UTF-8
33 DB_File jest modułem, który pozwala programom w Perlu na korzystanie
34 z udogodnień dostarczanych przez Berkeley DB w wersji 1.
35
36 %prep
37 %setup -q -n %{pnam}-%{version}
38 %patch0 -p1
39
40 %build
41 %{__perl} -pi -e "s/INSTALLDIRS => 'perl',//" Makefile.PL
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorarch}/DB_File.pm
63 %dir %{perl_vendorarch}/auto/DB_File
64 %{perl_vendorarch}/auto/DB_File/DB_File.bs
65 %{perl_vendorarch}/auto/DB_File/autosplit.ix
66 %attr(755,root,root) %{perl_vendorarch}/auto/DB_File/DB_File.so
67 %{_mandir}/man3/DB_File.3pm*
This page took 0.076334 seconds and 3 git commands to generate.