]> git.pld-linux.org Git - packages/perl-Crypt-Twofish.git/blob - perl-Crypt-Twofish.spec
107354997c9b1fda362a255418dcc48ab68ee22a
[packages/perl-Crypt-Twofish.git] / perl-Crypt-Twofish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Twofish
8 Summary:        Crypt::Twofish Perl module - the Twofish encryption algorithm
9 Summary(pl.UTF-8):      Moduł Perla Crypt::Twofish - algorytm szyfrowania Twofish
10 Name:           perl-Crypt-Twofish
11 Version:        2.14
12 Release:        3
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  295c059d18f9a46dd14bd765fc465318
17 URL:            http://search.cpan.org/dist/Crypt-Twofish/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements Twofish encryption. It supports the Crypt::CBC
24 interface. Twofish is a 128-bit symmetric block cipher with a variable
25 length (128, 192, or 256-bit) key, developed by Counterpane Labs. It
26 is unpatented and free for all uses, as described at
27 <http://www.counterpane.com/twofish.html>.
28
29 %description -l pl.UTF-8
30 Ten moduł jest implementacją szyfrowania Twofish. Obsługuje interfejs
31 Crypt::CBC. Twofish jest 128-bitowym symetrycznym szyfrem blokowym ze
32 zmienną długością klucza (128, 192 lub 256 bitów), opracowanym przez
33 Counterpane Labs. Nie jest opatentowany i można go swobodnie używać
34 do dowolnych celów, zgodnie z opisem pod adresem
35 <http://www.counterpane.com/twofish.html>.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/Crypt/Twofish.pm
62 %dir %{perl_vendorarch}/auto/Crypt/Twofish
63 %{perl_vendorarch}/auto/Crypt/Twofish/*.bs
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish/*.so
65 %{_mandir}/man3/*
This page took 0.056102 seconds and 2 git commands to generate.