]> git.pld-linux.org Git - packages/perl-Crypt-IDEA.git/blob - perl-Crypt-IDEA.spec
- perl req/prov fix
[packages/perl-Crypt-IDEA.git] / perl-Crypt-IDEA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    IDEA
8 Summary:        Crypt::IDEA - Perl interface to IDEA block cipher
9 Summary(pl.UTF-8):      Crypt::IDEA - interfejs perlowy do szyfru blokowego IDEA
10 Name:           perl-Crypt-IDEA
11 Version:        1.08
12 Release:        15
13 License:        BSD-like (see COPYRIGHT)
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6718c630fa8ac28cb989b7db763ed97c
17 Patch0:         %{name}-paths.patch
18 Patch1:         %{name}-5.6.0.patch
19 URL:            http://search.cpan.org/dist/Crypt-IDEA/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Crypt::IDEA Perl extension is an implementation of the IDEA block
26 cipher algorithm.
27
28 %description -l pl.UTF-8
29 Rozszerzenie Perla Crypt::IDEA stanowi implementacjÄ™ algorytmu
30 szyfrowania blokowego IDEA.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34 %patch0 -p0
35 %patch1 -p1
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Crypt/._test.pl
52 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/Crypt/IDEA.pod
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc COPYRIGHT
60 %{perl_vendorarch}/Crypt/IDEA.pm
61 %dir %{perl_vendorarch}/auto/Crypt/IDEA
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/IDEA/IDEA.so
63 %{_mandir}/man3/Crypt::IDEA.3pm*
This page took 0.290597 seconds and 3 git commands to generate.