]> git.pld-linux.org Git - packages/perl-Crypt-Anubis.git/blob - perl-Crypt-Anubis.spec
e94249287ef26afc0532519fe2a7bf6b53bfa7ca
[packages/perl-Crypt-Anubis.git] / perl-Crypt-Anubis.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Anubis
8 Summary:        Crypt::Anubis - Crypt::CBC-compliant block cipher
9 Summary(pl.UTF-8):      Crypt::Abubis - szyfr blokowy kompatybilny z Crypt::CBC
10 Name:           perl-Crypt-Anubis
11 Version:        1.0.4
12 Release:        6
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  aa62fb3a199063b5dff8bcbfc632338e
17 URL:            http://search.cpan.org/dist/Crypt-Anubis/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Anubis is a variable-length key, 128-bit block cipher designed by
24 Vincent Rijmen and Paulo S. L. M. Barreto. Key length can be 128, 160,
25 192, 224, 256, 288, or 320 bits. The default key length used in this
26 implementation is 128 bits (16 bytes). This module supports the
27 Crypt::CBC interface.
28
29 %description -l pl.UTF-8
30 Anubis to 128-bitowy szyfr blokowy o zmiennej długości klucza
31 opracowany przez Vincenta Rijmena i Paulo S. L. M. Baretto. Klucz może
32 mieć długość 128, 160, 192, 224, 256, 228 lub 320 bitów. Domyślna
33 długość klucza w tej implementacji to 128 bitów (16 bajtów). Ten moduł
34 obsługuje interfejs Crypt::CBC.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 cd examples
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 for f in * ; do
57         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
58                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
59 done
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorarch}/Crypt/Anubis.pm
68 %dir %{perl_vendorarch}/auto/Crypt/Anubis
69 %{perl_vendorarch}/auto/Crypt/Anubis/Anubis.bs
70 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Anubis/Anubis.so
71 %{_mandir}/man3/*
72 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.188633 seconds and 2 git commands to generate.