]> git.pld-linux.org Git - packages/perl-Attribute-Persistent.git/blob - perl-Attribute-Persistent.spec
5967b3f3004841c09a53ed0b632a4c2af8ae65e3
[packages/perl-Attribute-Persistent.git] / perl-Attribute-Persistent.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Attribute
6 %define         pnam    Persistent
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Attribute::Persistent - really lazy persistence
9 Summary(pl.UTF-8):      Attribute::Persistent - bardzo leniwe zachowywanie atrybutów
10 Name:           perl-Attribute-Persistent
11 Version:        1.1
12 Release:        2
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  3d93ef5e3566c1bd54d4cb22ad76106a
17 URL:            http://search.cpan.org/dist/Attribute-Persistent/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Attribute-Handlers-Prospective
22 BuildRequires:  perl-Digest-MD5
23 BuildRequires:  perl-MLDBM
24 %endif
25 BuildArch:      noarch
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This module provides a way of abstracting away persistence of array
30 and hash variables.
31
32 It's useful for quick hacks when you don't care about pulling in the
33 right DBM library and calling tie and so on. Its job is to reduce fuss
34 for the lazy programmer at the cost of flexibility.
35
36 %description -l pl.UTF-8
37 Ten moduł udostępnia metodę na wyabstrahowanie zachowywania zmiennych
38 tablicowych i haszy. Jest przydatnych do szybkich hacków, kiedy nie
39 dba się o wyciąganie właściwej biblioteki DBM, wywoływanie jej
40 dowiązań itd. Zadaniem modułu jest zredukowanie zamieszania dla
41 leniwego programisty kosztem elastyczności.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc Change*
65 %{perl_vendorlib}/%{pdir}/*.pm
66 %{_mandir}/man3/*
This page took 0.033841 seconds and 2 git commands to generate.