]> git.pld-linux.org Git - packages/ossp-uuid.git/blob - ossp-uuid.spec
- cleanup, add bconds for bindings, todo!
[packages/ossp-uuid.git] / ossp-uuid.spec
1 # TODO
2 # - conflicts with e2fsprogs uuid, rename libs with ossp prefix?
3 # - rename include ossp/uuid.h?
4 # - rename package to ossp-uuid?
5 # - fix bindings compilation
6 #
7 # Conditional build:
8 %bcond_with     php             # build with PHP binding
9 %bcond_with     perl            # build with Perl binding
10 %bcond_without  pgsql           # build with postgresql binding
11 #
12 Summary:        Universally Unique Identifier library
13 Name:           uuid
14 Version:        1.5.1
15 Release:        0.1
16 License:        MIT
17 Group:          Libraries
18 URL:            http://www.ossp.org/pkg/lib/uuid/
19 Source0:        ftp://ftp.ossp.org/pkg/lib/uuid/%{name}-%{version}.tar.gz
20 # Source0-md5:  d7df0c4cb02dad7ce3e1ec8fc669f724
21 BuildRequires:  libtool
22 %{?with_php:BuildRequires:      php-devel}
23 %{?with_pgsql:BuildRequires:    postgresql-devel}
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 OSSP uuid is a ISO-C:1999 application programming interface (API) and
28 corresponding command line interface (CLI) for the generation of DCE
29 1.1, ISO/IEC 11578:1996 and RFC 4122 compliant Universally Unique
30 Identifier (UUID). It supports DCE 1.1 variant UUIDs of version 1
31 (time and node based), version 3 (name based, MD5), version 4 (random
32 number based) and version 5 (name based, SHA-1). Additional API
33 bindings are provided for the languages ISO-C++:1998, Perl:5 and
34 PHP:4/5. Optional backward compatibility exists for the ISO-C DCE-1.1
35 and Perl Data::UUID APIs.
36
37 %package devel
38 Summary:        Development support for Universally Unique Identifier library
39 Group:          Development/Libraries
40 Requires:       %{name} = %{version}-%{release}
41
42 %description devel
43 Development headers and libraries for OSSP uuid.
44
45 %package c++
46 Summary:        C++ support for Universally Unique Identifier library
47 Group:          Libraries
48 Requires:       %{name} = %{version}-%{release}
49
50 %description c++
51 C++ libraries for OSSP uuid.
52
53 %package c++-devel
54 Summary:        C++ development support for Universally Unique Identifier library
55 Group:          Development/Libraries
56 Requires:       %{name}-c++ = %{version}-%{release}
57 Requires:       %{name}-devel = %{version}-%{release}
58
59 %description c++-devel
60 C++ development headers and libraries for OSSP uuid.
61
62 %package dce
63 Summary:        DCE support for Universally Unique Identifier library
64 Group:          Development/Libraries
65 Requires:       %{name} = %{version}-%{release}
66
67 %description dce
68 DCE OSSP uuid library.
69
70 %package dce-devel
71 Summary:        DCE development support for Universally Unique Identifier library
72 Group:          Development/Libraries
73 Requires:       %{name}-dce = %{version}-%{release}
74 Requires:       %{name}-devel = %{version}-%{release}
75
76 %description dce-devel
77 DCE development headers and libraries for OSSP uuid.
78
79 %package -n perl-%{name}
80 Summary:        Perl support for Universally Unique Identifier library
81 Group:          Development/Libraries
82 Requires:       %{name} = %{version}-%{release}
83
84 %description -n perl-%{name}
85 Perl OSSP uuid modules, which includes a Data::UUID replacement.
86
87 %package -n php-%{name}
88 Summary:        PHP support for Universally Unique Identifier library
89 Group:          Development/Libraries
90 Requires:       %{name} = %{version}-%{release}
91
92 %description -n php-%{name}
93 PHP OSSP uuid module.
94
95 %package -n postgresql-%{name}
96 Summary:        PostgreSQL support for Universally Unique Identifier library
97 Group:          Development/Libraries
98 Requires:       %{name} = %{version}-%{release}
99
100 %description -n postgresql-%{name}
101 PostgreSQL OSSP uuid module.
102
103 %prep
104 %setup -q
105
106 %build
107 # Build the library.
108 %configure \
109         --disable-static \
110         --with-dce \
111         --with-cxx \
112         --with%{!?with_perl:out}-perl \
113         --with%{!?with_php:out}-php \
114         --with%{!?with_pgsql:out}-pgsql
115
116 %{__make}
117
118 %install
119 rm -rf $RPM_BUILD_ROOT
120 %{__make} install \
121         DESTDIR=$RPM_BUILD_ROOT
122
123 %clean
124 rm -rf $RPM_BUILD_ROOT
125
126 %post -p /sbin/ldconfig
127 %postun -p /sbin/ldconfig
128
129 %post c++ -p /sbin/ldconfig
130 %postun c++ -p /sbin/ldconfig
131
132 %post dce -p /sbin/ldconfig
133 %postun dce -p /sbin/ldconfig
134
135 %files
136 %defattr(644,root,root,755)
137 %doc AUTHORS ChangeLog HISTORY NEWS PORTING README SEEALSO THANKS TODO USERS
138 %attr(755,root,root) %{_bindir}/uuid
139 %attr(755,root,root) %{_libdir}/libuuid.so.*.*.*
140 %attr(755,root,root) %ghost %{_libdir}/libuuid.so.15
141 %{_mandir}/man1/*
142
143 %files devel
144 %defattr(644,root,root,755)
145 %attr(755,root,root) %{_bindir}/uuid-config
146 %{_includedir}/uuid.h
147 %{_libdir}/libuuid.so
148 %{_pkgconfigdir}/uuid.pc
149 %{_mandir}/man3/uuid.3*
150 %{_libdir}/libuuid.la
151
152 %files c++
153 %defattr(644,root,root,755)
154 %attr(755,root,root) %{_libdir}/libuuid++.so.*.*.*
155 %attr(755,root,root) %ghost %{_libdir}/libuuid++.so.15
156
157 %files c++-devel
158 %defattr(644,root,root,755)
159 %{_includedir}/uuid++.hh
160 %{_libdir}/libuuid++.so
161 %{_libdir}/libuuid++.la
162 %{_mandir}/man3/uuid++.3*
163
164 %files dce
165 %defattr(644,root,root,755)
166 %attr(755,root,root) %{_libdir}/libuuid_dce.so.*.*.*
167 %attr(755,root,root) %ghost %{_libdir}/libuuid_dce.so.15
168
169 %files dce-devel
170 %defattr(644,root,root,755)
171 %{_includedir}/uuid_dce.h
172 %{_libdir}/libuuid_dce.so
173 %{_libdir}/libuuid_dce.la
174
175 %if %{with perl}
176 %files -n perl-%{name}
177 %defattr(644,root,root,755)
178 %{perl_vendorarch}/auto/*
179 %{perl_vendorarch}/Data*
180 %{perl_vendorarch}/OSSP*
181 %{_mandir}/man3/Data::UUID.3*
182 %{_mandir}/man3/OSSP::uuid.3*
183 %endif
184
185 %if %{with php}
186 %files -n php-%{name}
187 %defattr(644,root,root,755)
188 %{_libdir}/php/uuid.so
189 %endif
190
191 %if %{with pgsql}
192 %files -n postgresql-%{name}
193 %defattr(644,root,root,755)
194 %{_libdir}/postgresql/uuid.so
195 %{_datadir}/postgresql/uuid.sql
196 %endif
This page took 0.104563 seconds and 3 git commands to generate.